ID do artigo: 929713 - Última revisão: sexta-feira, 26 de outubro de 2007 - Revisão: 1.5

Um subsistema para aplicativos baseados em UNIX (SUA) aplicativo pode parar de responder após a instalação do SUA em um computador baseado no Windows Vista

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Recolher tudo

Sintomas

Quando você tenta executar um subsistema para aplicativos baseados em UNIX (SUA) aplicativo em um computador baseado no Windows Vista, o aplicativo pode parar de responder.

Causa

Esse problema ocorre porque SUA foi projetado para ser executado automaticamente quando um ou mais das seguintes condições forem verdadeiras:
  • Reiniciar o computador após SUA instalação.
  • Um aplicativo é executado com credenciais administrativas inicia SUA.
SUA não inicia se as seguintes condições forem verdadeiras:
  • Um usuário não tem credenciais administrativas instala o subsistema SUA.
  • O computador não foi reiniciado após a SUA instalação.
  • Você não tiver executar um aplicativo de SUA usando credenciais de administrador.
Portanto, um aplicativo de SUA executado sem credenciais administrativas pode parar de responder.

Resolução

Para resolver esse problema, use um dos seguintes métodos:
  • método 1

    Reinicie o computador baseado no Windows Vista. Por padrão, SUA inicia quando você reiniciar o computador.
  • método 2

    Instale o opcional SUA software development kit (SDK).

    O seguinte arquivo está disponível para download no Centro de download da Microsoft:

    Recolher esta imagemExpandir esta imagem
    Download
    Download the Utilities and SDK for Subsystem for UNIX-based Applications in Microsoft Windows Vista package now. (http://go.microsoft.com/fwlink/?LinkId=59121)

    Data de lançamento: 14 de dezembro de 2006

    Para obter mais informações sobre como baixar os arquivos de suporte da Microsoft, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
    119591  (http://support.microsoft.com/kb/119591/ ) Como obter arquivos de suporte da Microsoft de serviços on-line
    Microsoft examinou esse arquivo em busca de vírus. Microsoft utilizou o mais recente software de detecção de vírus que estava disponível na data em que o arquivo foi publicado. O arquivo é armazenado em servidores com segurança avançada que ajudam a evitar qualquer alteração não autorizada no arquivo.
  • método 3

    Execute o comando POSIX em um prompt de comando elevado. Para fazer isso, execute as seguintes etapas:
    1. Clique
      Recolher esta imagemExpandir esta imagem
      the Start button
      Iniciar , clique em Todos os programas , clique em Acessórios , clique com o botão direito do mouse Prompt de comando e, em seguida, clique em Executar como administrador .

      Recolher esta imagemExpandir esta imagem
      User Account Control permission
      Se você for solicitada uma senha de administrador ou confirmação, digite a senha ou clique em continuar .
    2. No prompt de comando, digite posix /u /c /bin/loginenv e, em seguida, pressione ENTER.

      Para obter mais informações sobre prompt de comando elevado no Windows Vista, visite o seguinte site:
      http://technet2.microsoft.com/WindowsVista/en/library/00d04415-2b2f-422c-b70e-b18ff918c2811033.mspx (http://technet2.microsoft.com/WindowsVista/en/library/00d04415-2b2f-422c-b70e-b18ff918c2811033.mspx)
    Por padrão, SUA inicia quando você executar o comando POSIX em um prompt de comando elevado.

Situação

A Microsoft confirmou que esse é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre SUA, visite o seguinte site:
http://technet2.microsoft.com/WindowsServer/en/Library/cd0e7ee9-05f0-4504-8caa-acc95c8c964b1033.mspx?mfr=true (http://technet2.microsoft.com/WindowsServer/en/Library/cd0e7ee9-05f0-4504-8caa-acc95c8c964b1033.mspx?mfr=true)
Para obter mais informações sobre utilitários e SDK para aplicativos baseados em UNIX, visite o seguinte site:
http://technet2.microsoft.com/WindowsServer/en/Library/ccb387e1-e686-43d1-acf6-2fc0d0eca6b91033.mspx?mfr=true (http://technet2.microsoft.com/WindowsServer/en/Library/ccb387e1-e686-43d1-acf6-2fc0d0eca6b91033.mspx?mfr=true)

A informação contida neste artigo aplica-se a:
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
Palavras-chave: 
kbmt kbexpertiseinter kbtshoot kbexpertisebeginner kbbug KB929713 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 929713  (http://support.microsoft.com/kb/929713/en-us/ )