Article ID: 929826 - Last Review: January 14, 2009 - Revision: 3.4

Error message when you try to activate Windows Vista Enterprise, Windows Vista Business, Windows 7, or Windows Server 2008: "Code 0x8007232b"

On This Page

Expand all | Collapse all

SYMPTOMS

When you try to activate Windows Vista Enterprise, Windows Vista Business, Windows 7 or Windows Server 2008, you may receive an error message that resembles the following:
Activation Error: Code 0x8007232b
DNS Name does not exist


For Windows 7, your error may resemble the following:
Windows could not be activated.
Key management services (KMS) host could not be located in domain name system (DNS), please have your system adminstrator verify that a KMS is published correctly in DNS.
Error: 0x80092328
Description:
DNS name does not exist.


This issue may occur if you use volume-licensed media to install Windows 7, Windows Vista Enterprise, Windows Vista Business, or Windows Server 2008.

CAUSE

This issue occurs if the activation wizard cannot connect to a Key Management Service (KMS) host computer.

RESOLUTION

To resolve this issue, use one of the following methods.

Method 1: Set up a KMS server

Configure a computer on the network to host the KMS software. Then, publish the Domain Name System (DNS) settings. For information about how to set up a KMS server and for instructions about how to publish the DNS addresses, visit the following Microsoft Web site:
http://www.microsoft.com/downloads/details.aspx?FamilyId=9893F83E-C8A5-4475-B025-66C6B38B46E3&displaylang=en (http://www.microsoft.com/downloads/details.aspx?FamilyId=9893F83E-C8A5-4475-B025-66C6B38B46E3&displaylang=en)

Method 2: Use a Multiple Activation Key

Change the product key to a Multiple Activation Key (MAK). To do this, follow these steps:
  1. Click Start
    Collapse this imageExpand this image
    the Start button
    , click All Programs, click Accessories, and then right-click Command Prompt.
  2. Click Run as administrator.

    Collapse this imageExpand this image
    User Access Control permission
    If you are prompted for an administrator password, type the password. If you are prompted for confirmation, click Continue.
  3. At the command prompt, type the following command, and then press ENTER:
    slmgr -ipk xxxxx-xxxxx-xxxxx-xxxxx-xxxxx
    Note In this command, xxxxx-xxxxx-xxxxx-xxxxx-xxxxx represents your MAK product key.

MORE INFORMATION

When you use volume-licensed media to install Windows 7, Windows Vista Enterprise, Windows Vista Business, or Windows Server 2008, the installation process uses a generic product key. When you then try to activate Windows 7, Windows Vista or Windows Server 2008, the activation wizard uses DNS to locate a Windows 7based, Windows Vista-based or Windows Server 2008-based computer that is running the KMS software. When the wizard queries DNS and does not find the DNS entry for the KMS host computer, the wizard reports the error message. If you have a KMS computer set up, the correct DNS entries are not seen by the client computer. If you do not have a KMS host computer set up, you must either set up a KMS host computer or switch to a MAK product key method to activate your volume license installation.

Microsoft Developer Network (MSDN) and TechNet supply volume-licensed media for Windows Server 2008 stock-keeping units (SKUs) and for Windows Vista Enterprise SKUs. The volume-licensed media will not prompt for a product key during installation. If you do not change the product key to the MSDN key, you will receive the error message when you try to activate the operating system. If you use MSDN media or TechNet media, you must change the product key to the MSDN product key. Use Method 2 in the "Resolution" section to change the product key.

Note The MSDN product key or the TechNet product key for Windows Server 2008 or for Windows Vista Enterprise is the MAK product key.

REFERENCES

For more information about Volume Activation for Windows Vista, click the following article number to view the article in the Microsoft Knowledge Base:
929712  (http://support.microsoft.com/kb/929712/ ) Volume Activation information for Windows Vista
For more information about volume licensing, visit the following Microsoft Web site:
http://www.microsoft.com/licensing/resources/vol/default.mspx (http://www.microsoft.com/licensing/resources/vol/default.mspx)
For more information about how to activate copies of Windows Vista or Windows Server 2008 that were installed by using volume-licensed media, visit the following Microsoft TechNet Web site:
http://www.microsoft.com/licensing/resources/vol/default.mspx (http://www.microsoft.com/licensing/resources/vol/default.mspx)

APPLIES TO
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Server 2008 Standard
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows 7 Enterprise
  • Windows 7 Enterprise N
Keywords: 
kbsurveynew kbvolumelicensing kbactivation kbtshoot kberrmsg kbprb KB929826
 

Article Translations