El recuento actual de KMS no aumenta al agregar nuevos equipos cliente basados en Windows Vista o Windows 7 a la red

En este artículo se proporciona ayuda para solucionar un problema por el que el número de clientes de un equipo de Servidor de administración de claves (KMS) no aumenta al agregar nuevos equipos cliente basados en Windows Vista a la red.

Se aplica a: Windows 7 Service Pack 1
Número de KB original: 929829

Síntomas

Al ejecutar el script de Slmgr.vbs en un equipo de Servidor de administración de claves (KMS), se comprueba que el número de equipos cliente no aumenta al agregar nuevos equipos cliente basados en Windows a la red. Además, puede ver el siguiente evento en el registro de eventos del servicio de administración de claves para cada nuevo equipo cliente basado en Windows que agregue a la red.

Al ejecutar el script de Slmgr.vbs junto con el -dli argumento , la información de recuento de equipos cliente no aumenta según lo esperado. En el siguiente evento que se registra en el registro de eventos de Key Management Service, el recuento actual sigue siendo el mismo.

Causa

Este problema puede producirse cuando los equipos cliente basados en Windows que se agregan a la red tienen identificadores de máquina cliente (CMID) de KMS idénticos. El número de recuento actual aumenta en un equipo KMS cuando los equipos cliente tienen distintos CMID. Dos o más equipos pueden tener los mismos CMID en cualquiera de los escenarios siguientes:

  • La imagen personalizada de Windows que se usa para instalar el equipo cliente se genera aunque no ejecute la herramienta preparación del sistema (Sysprep.exe) junto con la opción /generalize.
  • La imagen personalizada de Windows se genera junto con la opción /generalize. Sin embargo, especifique la <opción SkipRearm> en el archivo Unattended.xml.

Para comprobar que los equipos cliente tienen CMID idénticos, siga estos pasos:

  1. En uno de los equipos cliente basados en Windows, haga clic en Inicio, seleccione Programas, Accesorios, símbolo del sistema con el botón derecho y, a continuación, haga clic en Ejecutar como administrador. Si se le pide una contraseña de administrador o una confirmación, escriba la contraseña o haga clic en Permitir.

  2. En el símbolo del sistema, escriba el siguiente comando y presione ENTRAR: cscript c:\windows\system32\slmgr.vbs -dli

  3. Examine los resultados siguientes y anote el CMID.

  4. Repita los pasos del 1 al 4 en un segundo equipo cliente basado en Windows. Compruebe que el CMID del segundo equipo cliente es idéntico al CMID del primer equipo.

Solución

Se recomienda volver a generar la imagen base que se usa para implementar los equipos afectados en cuanto determine si tienen CMID idénticos.

Solución alternativa

La solución alternativa solo es válida si se usó la opción /generalize en la imagen que se usó para instalar clientes basados en Windows. Esta opción es necesaria al implementar varias imágenes. Para determinar si se usó la opción /generalize en la imagen, siga estos pasos:

  1. En uno de los equipos afectados, haga clic en Inicio y escriba C:\Windows\System32\sysprep\Panther\setupact.log.

  2. Examine las líneas "SYSPRP ParseCommands: Found" como se muestra en el siguiente archivo de registro de ejemplo:

    Info [0x0f004e] SYSPRP Initialized SysPrep log at C:\Windows\System32\sysprep\Panther

    Información [0x0f0054] SYSPRP ValidateUser:User tiene privilegios necesarios para la máquina sysprep
    Info [0x0f0056] SYSPRP ValidateVersion:OS version is okay
    Info [0x0f005c] SYSPRP ScreenSaver:Successfully disabled screen saver for sysprep
    Info [0x0f007e] SYSPRP FCreateTagFile:Tag file C:\Windows\System32\sysprep\Sysprep_succeeded.tag aún no existe, no es necesario eliminar nada
    Info [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'UNATTEND'
    Info [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'OOBE'
    Info [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'SHUTDOWN'
    Info [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'GENERALIZE'

  3. Si la opción /generalize está presente, confirme que esta opción se usó en el equipo que creó la imagen base.

  4. Si se usó la opción /generalize y tiene equipos que tienen CMID idénticos, siga estos pasos para reorganizar los equipos afectados y volver a generar la imagen base. Asegúrese de que no se usa la <configuración SkipRearm> :

    1. En uno de los equipos cliente base de Windows, haga clic en Inicio, seleccione Programas, Accesorios, símbolo del sistema con el botón derecho y, a continuación, haga clic en Ejecutar como administrador.

      Si se le pide una contraseña de administrador o una confirmación, escriba la contraseña o haga clic en Permitir.

    2. En el símbolo del sistema, escriba el siguiente comando y presione ENTRAR: cscript c:\windows\system32\slmgr.vbs -rearm

    3. Reinicie el equipo.

Si la imagen base no se generó mediante Sysprep con la opción /generalize, debe volver a generar la imagen base y, a continuación, volver a instalar Windows en los clientes. Si usa un archivo Unattended.xml al volver a generar la imagen base, asegúrese de que no se usa la <configuración SkipRearm> . Para obtener más información sobre la <configuración skiprearm>, consulte la documentación del Kit de instalación automatizada de Windows (AIK de Windows ).

Más información

Para restablecer el temporizador de activación y establecer un CMID único, el proceso Rearm debe ejecutarse en el equipo de destino. Este proceso se usa para restablecer el estado de activación. En Windows, el proceso Rearm se puede ejecutar mediante uno de los dos métodos siguientes:

  • Ejecute Sysprep junto con la opción /generalize en el equipo que se usa para compilar la imagen personalizada de Windows.
  • Forzar que se produzca el proceso de rearma mediante la ejecución del script de Slmgr.vbs en una ventana del símbolo del sistema con privilegios elevados. Por ejemplo, escriba: cscript c:\windows\system32\slmgr.vbs -rearm

Si el proceso de Rearm no se ejecutó porque Sysprep se ejecutó junto con la opción /generalize o porque usó la <configuración SkipRearm>1</SkipRearm> en el archivo Unattended.xml, los equipos cliente pueden tener CMID idénticos. Por lo tanto, la información de recuento de equipos no aumenta según lo esperado. La opción /generalize es necesaria al implementar varias imágenes. La <configuración SkipRearm> no debe usarse en un archivo desatendido al implementar equipos en un entorno de producción. Por lo tanto, en ambos casos, se recomienda volver a generar la imagen base.

Recolección de datos

Si necesita ayuda del soporte técnico de Microsoft, le recomendamos que recopile la información siguiendo los pasos mencionados en Recopilación de información mediante TSS para problemas relacionados con la implementación.