Het huidige aantal KMS wordt niet vergroot wanneer u nieuwe Windows Vista of Windows 7-clientcomputers aan het netwerk toevoegen

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 929829 - Bekijk de producten waarop dit artikel van toepassing is.
Alles uitklappen | Alles samenvouwen

Symptomen

Wanneer u het script Slmgr.vbs uitvoert op een computer met KMS (Key Management Server), moet u controleren of het aantal clientcomputers wordt niet vergroot wanneer u een nieuwe Windows-clientcomputers aan het netwerk toevoegen. Bovendien ziet u de volgende gebeurtenis in het gebeurtenislogboek Key Management Service voor elke nieuwe Windows-clientcomputer die u aan het netwerk toevoegen:


Logboeknaam: Key Management Service
Bron: Microsoft-Windows-beveiliging-Licensing-SLC
Gebeurtenis-ID: 12290
Niveau: informatie
Beschrijving: Een activeringsaanvraag is verwerkt.

Bij het uitvoeren van het script Slmgr.vbs samen met de?Dliargument client computer count informatie wordt niet vergroot. zoals verwacht. In de volgende gebeurtenis vastgelegd in de Key Management Gebeurtenislogboek, het huidige aantal blijft hetzelfde:


Naam: Windows(TM) Vista Enterprise edition
Beschrijving: Windows-besturingssysteem - Vista VOLUME_KMS kanaal
Gedeeltelijke productcode: XXXXX
Status van licentie: licentie

Key Management Service is ingeschakeld op deze computer
Huidige aantal: 1
Luisteren op poort: 1688
DNS-Publishing: ingeschakeld
KMS prioriteit: normaal

Oorzaak

Dit probleem kan optreden wanneer Windows-clientcomputers toevoegen aan het netwerk identieke KMS hebt clientcomputer id's (CMIDs). Het huidige aantal verhoogd op een KMS-computer als de clientcomputers verschillende CMIDs hebben. Twee of meer computers kunnen dezelfde CMIDs hebben in een van de volgende scenario's:
  • Aangepaste Windows-installatiekopie die u gebruikt voor de clientcomputer installeren wordt gegenereerd, hoewel het hulpprogramma voor systeemvoorbereiding (Sysprep.exe) niet wordt uitgevoerd samen met degeneralizeoptie.
  • Aangepaste Windows-installatiekopie wordt gegenereerd met degeneralizeoptie. Echter, geeft u de instelling <skiprearm> in de Bestand Unattended.XML.</skiprearm>
Controleren of clientcomputers hebt identieke CMIDs volgen deze stappen:
  1. Klik op een van de Windows-clientcomputersStart, wijsProgramma 's, wijsAccessoires, klik met de rechtermuisknopOpdrachtprompten Klik vervolgens opAls Administrator uitvoeren.

    Deze afbeelding samenvouwenDeze afbeelding uitklappen
    Gebruikersaccountbeheer

				machtiging
    Als u wordt gevraagd om een beheerderswachtwoord of voor bevestiging, typt u het wachtwoord of klikt u opToestaan.
  2. Typ de volgende opdracht bij de opdrachtprompt en vervolgens Druk op ENTER:
    cscript c:\windows\system32\slmgr.vbs ?dli
  3. De volgende resultaten te bekijken en noteer de CMID:

    Naam: Windows(TM) Vista Enterprise edition
    Beschrijving: Windows-besturingssysteem - Vista, kanaal VOLUME_KMSCLIENT
    Gedeeltelijke productcode: XXXXX
    Status van licentie: licentie
    Volume activering vervaldatum: 250467 minuten (173 dagen)

    Sleutelbeheer Informatie over client service
    Client computer-ID (CMID): e5a0da51-8882-4bd7-a248-c1b794a7a671
    KMS machine naam uit DNS: KMS-machine.domain.com:1688
    Interval voor activering: 120 minuten
    Vernieuwingsinterval: 90 minuten

  4. Herhaal stap 1 en 4 op een tweede Windows-clientcomputer. Controleer of CMID van de tweede client is identiek aan de CMID van de eerste computer.

Oplossing

Wij raden aan dat u de afbeelding die wordt gebruikt om opnieuw de betrokken computers implementeren als u bepalen of ze identieke hebben CMIDs.

Workaround

De oplossing is geldig als degeneralizeoptie werd gebruikt in de afbeelding waarmee clients met Windows installeren. Deze optie is vereist wanneer u meerdere afbeeldingen. Bepalen of degeneralizeoptie in de afbeelding is gebruikt, als volgt:
  1. Een op getroffen computersStart, en typC:\Windows\System32\sysprep\Panther\setupact.log.
  2. Onderzoek de "SYSPRP ParseCommands: gevonden ' regels zoals in het volgende voorbeeldlogboekbestand:
    Info       [0x0f004e] SYSPRP Initialized SysPrep log at C:\Windows\System32\sysprep\Panther
    
    Info       [0x0f0054] SYSPRP ValidateUser:User has required privileges to sysprep machine
    Info       [0x0f0056] SYSPRP ValidateVersion:OS version is okay
    Info       [0x0f005c] SYSPRP ScreenSaver:Successfully disabled screen saver for sysprep
    Info       [0x0f007e] SYSPRP FCreateTagFile:Tag file C:\Windows\System32\sysprep\Sysprep_succeeded.tag does not already exist, no need to delete anything
    Info       [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'UNATTEND'
    Info       [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'OOBE'
    Info       [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'SHUTDOWN'
    Info       [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'GENERALIZE'
  3. Als degeneralizeoptie aanwezig is, Controleer of deze optie is gebruikt op de computer waarop de installatiekopie wordt gemaakt.
  4. Als degeneralizeoptie is gebruikt en u computers identieke CMIDs hebt deze stappen opnieuw uitrusten met de betrokken computers en de afbeelding opnieuw. Zorg ervoor dat u niet gebruikt de <skiprearm> instelling niet gebruikt: </skiprearm>
    1. Klik op een van de clientcomputers Windows baseStart, wijsProgramma 's, wijsAccessoires, klik met de rechtermuisknopOpdrachtprompt, en Klik vervolgens opAls Administrator uitvoeren.

      Deze afbeelding samenvouwenDeze afbeelding uitklappen
      Gebruikersaccountbeheer

					 machtiging
      Als u wordt gevraagd om een beheerderswachtwoord of voor bevestiging, typt u het wachtwoord of klikt u opToestaan.
    2. Typ de volgende opdracht bij de opdrachtprompt en Druk op ENTER:
      cscript c:\windows\system32\slmgr.vbs ?rearm
    3. De computer opnieuw.
    Als de afbeelding niet is gegenereerd met behulp van Sysprep met degeneralizeoptie, moet u opnieuw de base image en installeer Windows opnieuw op de clients. Als u een Unattended.xml-bestand wanneer u het basisimage opnieuw samenstellen, Controleer of de instelling van de <skiprearm> wordt niet gebruikt. Voor meer informatie over de <skiprearm> instelling, Zie de documentatie van de Windows Automated Installation Kit (Windows AIK). </skiprearm></skiprearm>

Meer informatie

Opnieuw instellen van de activeringstimer en unieke CMID instellen, moet het proces opnieuw uitrusten uitvoeren op de doelcomputer. Dit proces wordt gebruikt om de activeringsstatus opnieuw. In Windows kan het proces opnieuw uitrusten met een van de volgende twee methoden worden uitgevoerd:
  • Voer Sysprep samen met degeneralizede optie op de computer die wordt gebruikt om de aangepaste Windows-installatiekopie.
  • Het proces opnieuw uitrusten optreden door de Slmgr.vbs forceren script in een opdrachtpromptvenster met verhoogde bevoegdheden. Typ bijvoorbeeld:
    cscript c:\windows\system32\slmgr.vbs ?rearm
Als het proces opnieuw uitrusten niet is uitgevoerd omdat Sysprep is uitgevoerd met degeneralizeoptie of omdat u de instelling <skiprearm>1</skiprearm> in het bestand Unattended.xml clientcomputers mogelijk identieke CMIDs. Daarom de telling van de computer informatie verhoogd niet als verwacht. Degeneralizeoptie is alleen vereist als u meerdere afbeeldingen. De <skiprearm> instelling niet in een bestand zonder toezicht moet worden gebruikt wanneer u computers in een productieomgeving implementeert. Voor beide gevallen dus we aanbevolen dat u opnieuw de base image.</skiprearm>

Eigenschappen

Artikel ID: 929829 - Laatste beoordeling: vrijdag 23 september 2011 - Wijziging: 3.0
De informatie in dit artikel is van toepassing op:
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows 7 Enterprise
  • Windows 7 Professional
Trefwoorden: 
kbtshoot kbprb kbmt KB929829 KbMtnl
Automatisch vertaald artikel
BELANGRIJK: Dit artikel is vertaald door de vertaalmachine software van Microsoft in plaats van door een professionele vertaler. Microsoft biedt u professioneel vertaalde artikelen en artikelen vertaald door de vertaalmachine, zodat u toegang heeft tot al onze knowledge base artikelen in uw eigen taal. Artikelen vertaald door de vertaalmachine zijn niet altijd perfect vertaald. Deze artikelen kunnen fouten bevatten in de vocabulaire, zinsopbouw en grammatica en kunnen lijken op hoe een anderstalige de taal spreekt en schrijft. Microsoft is niet verantwoordelijk voor onnauwkeurigheden, fouten en schade ontstaan door een incorrecte vertaling van de content of het gebruik ervan door onze klanten. Microsoft past continue de kwaliteit van de vertaalmachine software aan door deze te updaten.
De Engelstalige versie van dit artikel is de volgende:929829

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com