Het huidige aantal KMS neemt niet toe wanneer u nieuwe Windows Vista- of Windows 7-clientcomputers aan het netwerk toevoegt

Dit artikel biedt hulp bij het oplossen van een probleem waarbij het aantal clients op een KMS-computer (Key Management Server) niet toeneemt wanneer u nieuwe Windows Vista-clientcomputers aan het netwerk toevoegt.

Van toepassing op: Windows 7 Service Pack 1
Origineel KB-nummer: 929829

Symptomen

Wanneer u het Slmgr.vbs-script uitvoert op een KMS-computer (Key Management Server), controleert u of het aantal clientcomputers niet toeneemt wanneer u nieuwe Windows-clientcomputers aan het netwerk toevoegt. Daarnaast ziet u mogelijk de volgende gebeurtenis in het gebeurtenislogboek van de Key Management Service voor elke nieuwe Windows-clientcomputer die u aan het netwerk toevoegt.

Wanneer u het Slmgr.vbs script samen met het -dli argument uitvoert, neemt het aantal clientcomputergegevens niet toe zoals verwacht. In de volgende gebeurtenis die is vastgelegd in het gebeurtenislogboek van de Key Management Service, blijft het huidige aantal hetzelfde.

Oorzaak

Dit probleem kan optreden wanneer Windows-clientcomputers die u aan het netwerk toevoegt, identieke KMS-clientcomputer-id's (CMID's) hebben. Het huidige aantal wordt verhoogd op een KMS-computer wanneer de clientcomputers verschillende CMID's hebben. Twee of meer computers kunnen dezelfde CMID's hebben in een van de volgende scenario's:

  • De aangepaste Windows-installatiekopieën die u gebruikt om de clientcomputer te installeren, worden gegenereerd, hoewel u het hulpprogramma voor systeemvoorbereiding (Sysprep.exe) niet samen met de /generalize-optie uitvoert.
  • De aangepaste Windows-installatiekopieën worden samen met de optie /generalize gegenereerd. U geeft echter de <instelling SkipRearm> op in het Unattended.xml-bestand.

Voer de volgende stappen uit om te controleren of clientcomputers identieke CMID's hebben:

  1. Klik op een van de Windows-clientcomputers op Start, wijs Programma's aan, wijsAccessoires aan, klik met de rechtermuisknop op Opdrachtprompt en klik vervolgens op Als administrator uitvoeren. Als u wordt gevraagd om een beheerderswachtwoord of om een bevestiging, typt u het wachtwoord of klikt u op Toestaan.

  2. Typ de volgende opdracht bij de opdrachtprompt en druk op Enter: cscript c:\windows\system32\slmgr.vbs -dli

  3. Bekijk de volgende resultaten en noteer de CMID.

  4. Herhaal stap 1 tot en met 4 op een tweede Windows-clientcomputer. Controleer of de CMID van de tweede clientcomputer identiek is aan de CMID van de eerste computer.

Oplossing

U wordt aangeraden de basisinstallatiekopieën die wordt gebruikt voor het implementeren van de betrokken computers opnieuw op te bouwen zodra u hebt vastgesteld of ze identieke CMID's hebben.

Tijdelijke oplossing

De tijdelijke oplossing is alleen geldig als de /generalize-optie is gebruikt in de installatiekopieën die is gebruikt voor het installeren van Windows-clients. Deze optie is vereist wanneer u meerdere installatiekopieën implementeert. Voer de volgende stappen uit om te bepalen of de optie /generalize in de afbeelding is gebruikt:

  1. Klik op een van de betrokken computers op Start en typ C:\Windows\System32\sysprep\Panther\setupact.log.

  2. Bekijk de regels 'SYSPRP ParseCommands: Found', zoals weergegeven in het volgende voorbeeldlogboekbestand:

    Info [0x0f004e] SYSPRP Geïnitialiseerd SysPrep-logboek op C:\Windows\System32\sysprep\Panther

    Info [0x0f0054] SYSPRP ValidateUser:Gebruiker heeft vereiste bevoegdheden voor sysprep-machine
    Info [0x0f0056] SYSPRP ValidateVersion:OS-versie is in orde
    Info [0x0f005c] SYSPRP ScreenSaver:Screen Saver is uitgeschakeld voor sysprep
    Info [0x0f007e] SYSPRP FCreateTagFile:Tag-bestand C:\Windows\System32\sysprep\Sysprep_succeeded.tag bestaat nog niet, u hoeft niets te verwijderen
    Info [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'UNATTEND'
    Info [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'OOBE'
    Info [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'SHUTDOWN'
    Info [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'GENERALIZE'

  3. Als de optie /generalize aanwezig is, controleert u of deze optie is gebruikt op de computer die de basisinstallatiekopieën heeft gemaakt.

  4. Als de optie /generalize is gebruikt en u computers hebt met identieke CMID's, volgt u deze stappen om de betrokken computers opnieuw op te starten en de basisinstallatiekopieën opnieuw op te bouwen. Zorg ervoor dat u de <instelling SkipRearm> niet gebruikt:

    1. Klik op een van de Windows-basisclientcomputers op Start, wijs Programma's aan, wijs Accessoires aan, klik met de rechtermuisknop op Opdrachtprompt en klik vervolgens op Als administrator uitvoeren.

      Als u wordt gevraagd om een beheerderswachtwoord of om bevestiging, typt u het wachtwoord of klikt u op Toestaan.

    2. Typ de volgende opdracht bij de opdrachtprompt en druk op Enter: cscript c:\windows\system32\slmgr.vbs -rearm

    3. Start de computer opnieuw op.

Als de basisinstallatiekopieën niet zijn gegenereerd met behulp van Sysprep met de optie /generalize, moet u de basisinstallatiekopieën opnieuw bouwen en vervolgens Windows opnieuw installeren op de clients. Als u een Unattended.xml-bestand gebruikt wanneer u de basisinstallatiekopieën herbouwt, controleert u of de <instelling SkipRearm> niet wordt gebruikt. Zie de <windows AIK-documentatie (Windows AIK) voor meer informatie over de instelling SkipRearm> .

Meer informatie

Als u de activeringstimer opnieuw wilt instellen en een unieke CMID wilt instellen, moet het rearm-proces worden uitgevoerd op de doelcomputer. Dit proces wordt gebruikt om de activeringsstatus opnieuw in te stellen. In Windows kan het rearm-proces worden uitgevoerd met behulp van een van de volgende twee methoden:

  • Voer Sysprep samen met de /generalize-optie uit op de computer die wordt gebruikt om de aangepaste Windows-installatiekopieën te bouwen.
  • Dwing het rearm-proces af door het script Slmgr.vbs uit te voeren in een opdrachtpromptvenster met verhoogde bevoegdheid. Typ bijvoorbeeld: cscript c:\windows\system32\slmgr.vbs -rearm

Als het rearm-proces niet is uitgevoerd omdat Sysprep samen met de optie /generalize is uitgevoerd of omdat u de <instelling SkipRearm>1</SkipRearm> in het Unattended.xml-bestand hebt gebruikt, kunnen clientcomputers identieke CMID's hebben. Daarom neemt het aantal computergegevens niet toe zoals verwacht. De optie /generalize is vereist wanneer u meerdere installatiekopieën implementeert. De <instelling SkipRearm> mag niet worden gebruikt in een bestand zonder toezicht wanneer u computers implementeert in een productieomgeving. Daarom raden we u voor beide gevallen aan de basisinstallatiekopieën opnieuw op te bouwen.

Gegevensverzameling

Als u hulp nodig hebt van Microsoft-ondersteuning, raden we u aan de informatie te verzamelen door de stappen te volgen die worden vermeld in Informatie verzamelen met behulp van TSS voor implementatiegerelateerde problemen.