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A Windows Vista-based computer that uses a Mobile Intel 945GM Express Chipset may occasionally not wake from sleep

Article ID:929909
Last Review:August 29, 2007
Revision:2.1
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SYMPTOMS

A Windows Vista-based computer that uses a Mobile Intel 945GM Express Chipset may occasionally not wake from sleep. This problem may occur about one time for every ten times that you try to resume the computer from sleep.

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CAUSE

This problem occurs because of a race condition in the ATAportDeviceBusy function. The ATA miniport driver uses the ATAportDeviceBusy function to pause the device queues of the ATAport driver. When the race condition occurs, the queue can remain paused. This behavior causes the computer to stop responding.

This problem occurs if the computer is using the Microsoft Advanced Host Controller Interface (AHCI) chipset driver. The problem does not occur if the computer is using the Intel AHCI chipset driver.

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RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem, submit a request to Microsoft Online Customer Services to obtain the hotfix. To submit an online request to obtain the hotfix, visit the following Microsoft Web site:
http://go.microsoft.com/?linkid=6294451 (http://go.microsoft.com/?linkid=6294451)
Note If additional issues occur or any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. To create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Aliide.sys1.2.0.017,59208-Jan-200706:14x86
Amdide.sys6.0.6000.2050918,10408-Jan-200706:14x86
Atapi.sys6.0.6000.2050921,68808-Jan-200706:15x86
Ataport.sys6.0.6000.20509109,75208-Jan-200706:17x86
Cmdide.sys2.0.7.019,12808-Jan-200706:15x86
Intelide.sys6.0.6000.2050917,59208-Jan-200706:14x86
Msahci.sys6.0.6000.2050925,78408-Jan-200706:15x86
Pciide.sys6.0.6000.2050916,05608-Jan-200706:14x86
Pciidex.sys6.0.6000.2050945,24008-Jan-200706:16x86
Update.mumNot Applicable2,02308-Jan-200715:31Not Applicable
Viaide.sys5.1.3790.15020,15208-Jan-200706:15x86
X86_mshdc.inf_31bf3856ad364e35_6.0.6000.20509_none_dbe4850d3d78c736.manifestNot Applicable5,81808-Jan-200715:32Not Applicable
Windows Vista, 64-bit versions
File nameFile versionFile sizeDateTimePlatform
Aliide.sys1.2.0.018,61608-Jan-200709:50x64
Amd64_mshdc.inf_31bf3856ad364e35_6.0.6000.20509_none_38032090f5d6386c.manifestNot Applicable5,82008-Jan-200716:17Not Applicable
Amdide.sys6.0.6000.2050918,61608-Jan-200709:50x64
Atapi.sys6.0.6000.2050922,71208-Jan-200709:50x64
Ataport.sys6.0.6000.20509124,08808-Jan-200709:52x64
Cmdide.sys2.0.7.020,66408-Jan-200709:50x64
Intelide.sys6.0.6000.2050919,12808-Jan-200709:50x64
Msahci.sys6.0.6000.2050927,32008-Jan-200709:50x64
Pciide.sys6.0.6000.2050916,05608-Jan-200709:50x64
Pciidex.sys6.0.6000.2050951,38408-Jan-200709:51x64
Update.mumNot Applicable2,02308-Jan-200715:31Not Applicable
Viaide.sys5.1.3790.15020,66408-Jan-200709:50x64

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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MORE INFORMATION

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 (http://support.microsoft.com/kb/816915/) New file naming schema for Microsoft Windows software update packages
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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APPLIES TO
Windows Vista Ultimate
Windows Vista Starter
Windows Vista Home Premium
Windows Vista Home Basic
Windows Vista Enterprise
Windows Vista Business 64-bit Edition
Windows Vista Business
Windows Vista Ultimate 64-bit Edition
Windows Vista Home Premium 64-bit Edition
Windows Vista Home Basic 64-bit Edition
Windows Vista Enterprise 64-bit Edition

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Keywords: 
kbvistasp1fix kbfix kbbug kbhotfixserver kbqfe kbprb kbexpertiseinter KB929909

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