Article ID: 930142 - Last Review: January 8, 2007 - Revision: 1.1

DHCP scope options are missing when you create a DHCP reservation and then restart the DHCP Server service on a Windows Server 2003-based computer

System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.
Expand all | Collapse all

SYMPTOMS

Consider the following scenario. On a Microsoft Windows Server 2003-based computer, you add a DHCP reservation to a DHCP scope. Then, you restart the DHCP Server service. In this scenario, you experience the following issues:
  • Some of the scope options are missing.
  • The lease time is set to zero.
  • DHCP clients no longer receive the correct DHCP options.

CAUSE

This issue occurs if the following conditions are true:
  • There is an incorrect or incomplete reservation IP address.

    Note For example, in an incomplete reservation IP address, the last octet may be empty.
  • The reservation IP address matches the scope ID.
If the reservation IP address is incomplete, and then you restart the DHCP Server service, some of the scope options may be missing. Additionally, the lease time may be set to zero.

For example, the DHCP database does not differentiate between a scope ID of 192.168.1.0 and a reservation IP address of 192.168.1.0. Therefore, the DHCP database associates the scope options with the reservation. In this situation, all other non-reserved DHCP clients lose their scope options.

Note The DHCP Server service in Windows Server 2003 lets you create a reservation that has the same IP address as the scope ID.

WORKAROUND

To resolve this issue, make sure that you do not create incomplete or incorrect DHCP reservations that match the scope ID. If you are already experiencing this issue, remove the incorrect or incomplete reservation, and then restore the scope from backup. Otherwise, remove the incorrect or incomplete reservation, and then reconfigure the scope options.

APPLIES TO
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Keywords: 
kbexpertiseinter kbtshoot KB930142