Artikel-ID: 930193 - Geändert am: Dienstag, 20. Mai 2008 - Version: 3.1

Fehlermeldung, wenn Sie den Befehl Sysprep auf einem Windows Vista-Computer ausführen: "ein schwerwiegender Fehler aufgetreten"

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Problembeschreibung

Wenn Sie den Befehl Sysprep auf einem Vista-Computer ausführen, erhalten Sie eine Fehlermeldung etwa folgenden Inhalts angezeigt:
Schwerwiegender Fehler beim Versuch, Sysprep des Computers
Darüber hinaus wird ein Fehlercode, der etwa in der Datei Setupact.log protokolliert:
0x80070020
ERROR_SHARING_VIOLATION
Hinweis: Befindet sich die Setupact.log entlang des folgenden Pfades:
C:\Windows\Panther\Setupact.log

Ursache

Dieses Problem tritt auf, wenn der Anbieter Microsoft Distributed Transaction Coordinator (MSDTC) versucht, seine Protokoll zurückzusetzen. Die Fehlermeldung tritt auf, wenn der MSDTC-Prozess die Datei zugreifen kann nicht, da die Datei von einem anderen Prozess verwendet wird. Die 0x80070020 ERROR_SHARING_VIOLATION-Fehlercode angibt, dass ein anderer Prozess ein offenes Handle in die Protokolldatei hat.

Lösung

Informationen zu Service Packs

Installieren Sie das neueste Servicepack für Windows Vista, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
935791  (http://support.microsoft.com/kb/935791/ ) Wie Sie das neueste Windows Vista Servicepack erhalten

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Windows Vista x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Msdtcprx.dll2001.12.6930.20502500,22422-Dez. 200607: 22X 86
Xolehlp.dll2001.12.6930.2050230,20822-Dez. 200607: 32X 86
Windows Vista, 64-Bit-Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Msdtcprx.dll2001.12.6930.20502678,40022-Dez. 200607: 08X 64
Xolehlp.dll2001.12.6930.2050238,40022-Dez. 200607: 16X 64

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind. Dieses Problem wurde erstmals in Windows Vista Service Pack 1.

Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Vista Ultimate
  • Windows Vista Starter
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Enterprise
  • Windows Vista Business 64-bit edition
  • Windows Vista Business
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Enterprise 64-bit edition
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 930193  (http://support.microsoft.com/kb/930193/en-us/ )
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