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Error message when you run the Sysprep command on a Windows Vista-based computer: "A fatal error occurred"

Article ID:930193
Last Review:August 29, 2007
Revision:2.1
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SYMPTOMS

When you run the Sysprep command on a Windows Vista-based computer, you receive an error message that resembles the following:
A fatal error occurred while trying to sysprep the machine
Additionally, an error code that resembles the following is logged in the Setupact.log file:
0x80070020
ERROR_SHARING_VIOLATION
Note The Setupact.log file is located along the following path:
C:\Windows\Panther\Setupact.log

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CAUSE

This problem occurs when the Microsoft Distributed Transaction Coordinator (MSDTC) provider tries to reset its log. The error message occurs when the MSDTC process cannot access the file because the file is being used by another process. The 0x80070020 ERROR_SHARING_VIOLATION error code indicates that another process has an open handle to the log file.

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RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem, submit a request to Microsoft Online Customer Services to obtain the hotfix. To submit an online request to obtain the hotfix, visit the following Microsoft Web site:
http://go.microsoft.com/?linkid=6294451 (http://go.microsoft.com/?linkid=6294451)
Note If additional issues occur or any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. To create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Msdtcprx.dll2001.12.6930.20502500,22422-Dec-200607:22x86
Xolehlp.dll2001.12.6930.2050230,20822-Dec-200607:32x86
Windows Vista, 64-bit versions
File nameFile versionFile sizeDateTimePlatform
Msdtcprx.dll2001.12.6930.20502678,40022-Dec-200607:08x64
Xolehlp.dll2001.12.6930.2050238,40022-Dec-200607:16x64

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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APPLIES TO
Windows Vista Ultimate
Windows Vista Starter
Windows Vista Home Premium
Windows Vista Home Basic
Windows Vista Enterprise
Windows Vista Business 64-bit Edition
Windows Vista Business
Windows Vista Ultimate 64-bit Edition
Windows Vista Home Premium 64-bit Edition
Windows Vista Home Basic 64-bit Edition
Windows Vista Enterprise 64-bit Edition

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Keywords: 
kbvistasp1fix kbfix kbhotfixserver kbqfe kbprb kbexpertiseinter KB930193

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