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A computer uses an SiI PATA chip does not recognize an attached optical drive as a drive that supports recording after you install Windows Vista

Article ID:930194
Last Review:May 16, 2008
Revision:3.0
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SYMPTOMS

After you install Windows Vista on a computer that uses an SiI Parallel Advanced Technology Attachment (PATA) chip from Silicon Image, the computer does not recognize an attached optical drive as a drive that supports recording. Therefore, you cannot use the computer to burn CDs or DVDs.

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CAUSE

This problem occurs because the SCSIport driver does not populate the correct number of bytes for an IOCTL_STORAGE_QUERY_PROPERTY Request Packet (IRP) when the device does not return a correct serial number.

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RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 (http://support.microsoft.com/kb/935791/) How to obtain the latest Windows Vista service pack

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Update information

The following files are available for download from the Microsoft Download Center:

Windows Vista, 32-bit versions

DownloadDownload the 930194 package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=2E692102-D483-44B0-BBFF-FA87AE019CBE)

Windows Vista, 64-bit versions

DownloadDownload the 930194 package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=8476A5D8-6B12-4F7E-B80E-722D16D8D4ED)

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 (http://support.microsoft.com/kb/119591/) How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file. A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

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File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Scsiport.sys6.0.6000.20507140,39204-Jan-200710:12x86
Update.mumNot applicable2,08104-Jan-200720:11Not applicable
X86_microsoft.windows.s...scsi_port_driver.d_31bf3856ad364e35_6.0.6000.20507_none_6ee1f90d81295f90.manifestNot applicable78304-Jan-200720:11Not applicable
X86_microsoft.windows.s..se.scsi_port_driver_31bf3856ad364e35_6.0.6000.20507_none_e42a8a42460f9336.manifestNot applicable11,81904-Jan-200720:12Not applicable
Windows Vista, 64-bit versions
File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft.windows.s...scsi_port_driver.d_31bf3856ad364e35_6.0.6000.20507_none_cb0094913986d0c6.manifestNot applicable78704-Jan-200720:11Not applicable
Amd64_microsoft.windows.s..se.scsi_port_driver_31bf3856ad364e35_6.0.6000.20507_none_404925c5fe6d046c.manifestNot applicable11,83104-Jan-200720:59Not applicable
Scsiport.sys6.0.6000.20507170,08804-Jan-200710:38x64
Update.mumNot applicable2,08104-Jan-200720:11Not applicable

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

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MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products. For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 (http://support.microsoft.com/kb/816915/) New file naming schema for Microsoft Windows software update packages
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

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APPLIES TO
Windows Vista Ultimate
Windows Vista Starter
Windows Vista Home Premium
Windows Vista Home Basic
Windows Vista Enterprise
Windows Vista Business 64-bit Edition
Windows Vista Business
Windows Vista Ultimate 64-bit Edition
Windows Vista Home Premium 64-bit Edition
Windows Vista Home Basic 64-bit Edition
Windows Vista Enterprise 64-bit Edition

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Keywords: 
kbvistasp1fix atdownload kbfix kbbug kbhotfixserver kbqfe kbprb kbexpertiseinter KB930194

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