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Sintomas

O Microsoft SoftGrid cliente tenta iniciar uma aplicação. No entanto, a tentativa não tiver êxito e receberá uma mensagem de erro semelhante à seguinte:

O cliente de SoftGrid não conseguiu iniciar < nome_aplicação >.
O pacote de pedido não foi possível encontrar no arquivo de dados do sistema ou não foi possível encontrar os ficheiros associados este pacote no servidor. Comunique o seguinte código de erro para o administrador do sistema.
Código de erro: xxxxxx xxxxxx0A-20000194

Uma entrada semelhante à seguinte poderá ser apresentada no ficheiro de registo de cliente de SoftGrid (Sftlog.txt):
Uma entrada semelhante à seguinte poderá ser apresentada no ficheiro de registo de servidor de aplicação Virtual SoftGrid (Sft-Server):

Causa

Este comportamento pode ocorrer se uma ou mais das seguintes condições forem verdadeiras:

  • Está a tentar iniciar uma aplicação com capacidade de SoftGrid que não foi adicionada à consola de gestão de SoftGrid.

  • O ficheiro .sft especificado no ficheiro OSD não existe dentro da estrutura de directório de conteúdo.

  • O caminho ou o nome do ficheiro .sft especificado na entrada do Caminho relativo do ficheiro Softricity é inválido.

  • A política de fornecedor especificado no ficheiro OSD não existe.

Resolução

As seguintes informações fornecem resoluções para cada uma delas mencionada na secção "Causa".

  • Está a tentar iniciar uma aplicação com capacidade de SoftGrid que não foi adicionada à consola de gestão de SoftGrid

    Existem duas condições em que pode tentar iniciar com êxito uma aplicação com capacidade de SoftGrid que não foi adicionada à consola de gestão de SoftGrid:

    • Faça duplo clique sobre o ficheiro OSD de uma aplicação activada para SoftGrid.

    • Faça duplo clique sobre o atalho de uma aplicação activada SoftGrid que foi removido da gestão de clientes de SoftGrid.

      Nota O atalho não é removido quando a aplicação com capacidade de SoftGrid é removida da gestão de clientes de SoftGrid. O atalho não é removido se manualmente copiar o atalho para uma localização alternativa quando a aplicação é adicionada a gestão de clientes de SoftGrid. Quando a aplicação é posterior removido, gestão de clientes de SoftGrid não tem conhecimento da localização alternativa e o atalho não é removido.

  • O ficheiro .sft especificado no ficheiro OSD não existe dentro da estrutura de directório de conteúdo

    O ficheiro .sft não existe dentro da estrutura de directório de conteúdo. Este ficheiro de .sft é especificado no atributo HREF do elemento CODEBASE do ficheiro OSD.

    Considere o seguinte cenário. O ficheiro OSD é configurado como no exemplo seguinte:

    HREF="rtsp://%SFT_SOFTGRIDSERVER%:554/Softricity/sft_ea70.v1.sft"O directório de conteúdo está configurado como caminho de exemplo seguinte:

    C:\Program Files\Softricity\SoftGrid Server\contentNeste cenário, o Microsoft SoftGrid não é possível iniciar a aplicação se o ficheiro sft_ea70.v1.sft não existe no subdirectório Softricity no seguinte caminho do directório de conteúdo:

    C:\Program Files\Softricity\SoftGrid Server\content\Softricity.

  • O caminho ou o nome do ficheiro .sft especificado no "Softricity ficheiro caminho relativo" é inválido

    O Caminho relativo do ficheiro Softricity só pode conter o subdirectório do directório de conteúdo e o nome do ficheiro .sft. Por exemplo, o nome do ficheiro .sft é example.sft e existe dentro o subdirectório de Aplicações de exemplo do directório de conteúdo. Se o directório de conteúdo é c:\Programas\Microsoft Files\Softricity\SoftGrid Server\content, o Caminho relativo do ficheiro Softricity é Applications\example.sft de exemplo. Se o directório de conteúdo for \\SERVERNAME\content, o Caminho relativo do ficheiro Softricity ainda é Applications\example.sft de exemplo.

    Para verificar que o caminho relativo contém apenas o subdirectório do directório de conteúdo e o nome do ficheiro .sft, siga estes passos: os passos:

    1. Ferramentas administrativas, inicie a consola de gestão do SoftGrid.

    2. Expanda SoftGrid sistemas< nome_servidor > pacotes < versão do pacote de aplicação que não é iniciado > .

    3. Faça duplo clique sobre a versão do pacote da aplicação que não é iniciado.

    4. Certifique-se de que o Caminho relativo do ficheiro Softricity contém apenas o subdirectório do directório de conteúdo e o nome do ficheiro .sft.

  • A política de fornecedor especificado no ficheiro OSD não existe

    A política de fornecedor que ?Customer = Especifica não existe. Esta política de fornecedor é especificada no atributo HREF do elemento CODEBASE do ficheiro OSD

    Considere o seguinte cenário. O ambiente de SoftGrid tiver várias políticas de fornecedor, tais como o fornecedor predefinido e uma política personalizada de fornecedor com o nome anónimo. Além disso, tem de configurar um ficheiro OSD para utilizar a política de fornecedor anónimo. Neste cenário, o. Atributo HREF do elemento CODEBASE do ficheiro OSD têm de aparecer como no exemplo seguinte.

    HREF="rtsp://%SFT_SOFTGRIDSERVER%:554/Softricity/sft_ea70.v1.sft?Customer=Anonymous"Nota Se o nome da política de fornecedor que se segue ?Customer = não existir, Microsoft SoftGrid não é possível iniciar a aplicação.

Para mais informações sobre os termos de utilização, visite o seguinte Web site da Microsoft:

http://support.microsoft.com/tou/

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