ID do artigo: 930800 - Última revisão: terça-feira, 30 de outubro de 2007 - Revisão: 2.1

IDENTIFICAÇÃO de evento 9840 ou 9607 é registrada quando uma operação de backup VSS falha no Exchange 2007 ou no Exchange 2003

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Quando você tenta executar um backup VSS (serviço de cópias de sombra de volume) de um banco de dados de caixa de correio ou de banco de dados de um pasta pública no Microsoft Exchange Server 2007, a operação de backup falhará. Além disso, um dos seguintes eventos é registrado no log de eventos do sistema:

Identificação do evento: 9840
IDENTIFICAÇÃO bruto: 9840
Nr do Registro. 50522:
Categoria: Geral
Origem: MSExchangeIS
Tipo: Erro
Gerado: 12/8/2006 7:06:14 AM
Escrito: 12/8/2006 7:06:14 AM
Máquina: MachineName
Mensagem: preparar o armazenamento grupo ' sg2 ' para backup na tentativa porque o grupo de armazenamento já está no processo de backup. O código de erro é-2403. (Observe que se um backup tiver sido anulado recentemente, em seguida, ele pode levar alguns minutos para que o sistema detecte o backup anulado e inicie os procedimentos de limpeza backup, de modo que essa mensagem pode ser gerada se foi feita uma tentativa para backup grupo de um armazenamento antes de uma tentativa de backup anterior ser totalmente terminada.)

Tipo de evento: erro
Origem do evento: MSExchangeIS
Categoria do evento: geral
IDENTIFICAÇÃO de evento: 9840
Data: 11/9/2006
Tempo: 5:44:53 PM
Usuário: N/d
Computador: ComputerName
Descrição: preparar o armazenamento grupo ' sg3 ' para backup na tentativa porque o grupo de armazenamento já está no processo de backup. O código de erro é 1293. (Observe que se um backup tiver sido anulado recentemente, em seguida, ele pode levar alguns minutos para que o sistema detecte o backup anulado e inicie os procedimentos de limpeza backup, de modo que essa mensagem pode ser gerada se foi feita uma tentativa para backup grupo de um armazenamento antes de uma tentativa de backup anterior ser totalmente terminada.)

Quando você tenta executar um backup VSS de um banco de dados de caixa de correio ou de banco de dados de um pasta pública no Microsoft Exchange Server 2003, a operação de backup falhará. Além disso, o seguinte evento é registrado no log de eventos:

Tipo de evento: erro
Origem do evento: MSExchangeIS
Categoria do evento: O gravador VSS do Exchange
IDENTIFICAÇÃO de evento: 9607
Data: 6/15/2007
Tempo: 9:30:06 PM
Usuário: N/d
ComputerName do computador:
Descrição: Código de erro 0x50d ao se preparar para backup. Para obter mais informações, clique em http://www.microsoft.com/contentredirect.asp.
Dados: 0000: 42 61 63 6b 75 70 20 backup 69 i 0008: 6e 70 20 72 6f 72 67 65 n progre 0010: 73 73 2e 00 ss...

Causa

Esse problema pode ocorrer se as seguintes condições forem verdadeiras:
  • VSS usa o mecanismo de banco de dados Microsoft Jet para congelar ou descongelar um backup de instantâneo.
  • O mecanismo de banco de dados Jet encontra um erro.
  • O mecanismo de banco de dados Jet silenciosamente libera todos os grupos de armazenamento da sessão de instantâneo quando o erro ocorre.
Quando essas condições forem verdadeiras, o mecanismo de banco de dados Jet não informa o status correto desses grupos de armazenamento para o Exchange 2007 ou o Exchange 2003. Portanto, o Exchange não redefine o estado de backup em andamento. Se você tentar fazer backup do grupo de armazenamento afetado novamente, os sintomas descritos na seção "Sintomas" ocorrem.

Resolução

Para resolver esse problema, use um dos seguintes métodos, conforme apropriado para sua situação.

Método 1: Desmontar bancos de dados todas as no grupo de armazenamento

Use este método se o evento ID 9840 que foram registradas no servidor do Exchange 2007 contém código de erro 2403.

Para desmontar todos os bancos de dados no grupo de armazenamento, execute estas etapas:
  1. Clique em Iniciar , aponte para Todos os programas , aponte para o Exchange Server 2007 e, em seguida, clique em Console de gerenciamento do Exchange .
  2. Expanda Configuração do servidor e, em seguida, expanda o grupo de armazenamento é listado na mensagem de evento ID 9840 que foram registrada no servidor do Exchange 2007.
  3. Clique com o botão direito do mouse cada banco de dados no grupo de armazenamento e, em seguida, clique em Desmontar banco de dados .
  4. Clique em Sim para confirmar a operação.
  5. Depois que a operação de desmontagem estiver concluída, clique com o botão direito do mouse novamente o banco de dados e clique em Mount Database .
  6. Tente executar a operação de backup que resultou no evento ID 9840.
Se esse método não resolver o problema, tente o método 2.

Método 2: Reiniciar o serviço Microsoft Exchange Information Store

Use este método se o evento ID 9840 que foram registradas no servidor do Exchange 2007 contém código de erro 1293. Use este método se 9607 de identificação do evento foi registrado no Exchange 2003. Além disso, use esse método se o método 1 não resolver o problema.

Para reiniciar o serviço Microsoft Exchange Information Store, execute essas etapas:
  1. Clique em Iniciar , aponte para Todos os programas , aponte para Ferramentas administrativas e em seguida, clique em serviços .
  2. Clique com o botão direito do mouse Microsoft Exchange Information Store e clique em Reiniciar .
  3. Tente executar a operação de backup que resultou no evento ID 9840.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2003 Service Pack 2
Palavras-chave: 
kbmt kbexpertiseadvanced kbtshoot kbprb KB930800 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 930800  (http://support.microsoft.com/kb/930800/en-us/ )