El Administrador de dispositivos no muestra información actualizada del procesador en un equipo con Windows Vista

Seleccione idioma Seleccione idioma
Id. de artículo: 930861 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Después de reemplazar físicamente el procesador (CPU) con un modelo similar de procesador en un equipo con Windows Vista, la información del procesador anterior sigue apareciendo en el Administrador de dispositivos bajo Procesadores. Sin embargo, la información actualizada del procesador aparece correctamente en el Centro de bienvenida en Sistema y mantenimiento del Panel de control.

Causa

Este problema se produce porque Windows Vista no detecta que se ha instalado un nuevo procesador.

El Administrador de dispositivos lee una cadena del Registro para mostrar la información del procesador. El procesador rellena esta cadena del Registro cuando se instala el controlador del procesador. Puesto que Windows Vista no detecta que se ha instalado un nuevo procesador, el sistema no instala un nuevo controlador del procesador. Por tanto, la cadena del Registro no está actualizada. El Administrador de dispositivos lee la información de cadena del Registro correspondiente al procesador anterior.

Este problema se produce porque el instalador de clase de controlador del procesador no se puede invocar en Windows Vista si se reemplaza físicamente el procesador con un procesador diferente que es similar al procesador anterior. Cuando se produce este problema, la descripción del procesador que aparece bajo Procesadores en el Administrador de dispositivos no está actualizada. Este problema sólo es cosmético y no afecta al rendimiento del equipo.

Solución

Para actualizar la descripción del procesador bajo Procesadores en el Administrador de dispositivos para que se muestre el procesador correcto, utilice uno de los métodos siguientes.

Método 1: desinstale el procesador

Utilice el Administrador de dispositivos para desinstalar el procesador y reinicie el equipo. Cuando el equipo se reinicia, Windows Vista detecta el procesador y reinstala el controlador. Para desinstalar el procesador, siga estos pasos:
  1. Haga clic en Inicio
    Contraer esta imagenAmpliar esta imagen
    botón Inicio
    , escriba Devmgmt.msc en el cuadro Iniciar búsqueda y haga clic en Devmgmt.msc.

    Contraer esta imagenAmpliar esta imagen
     Permiso de Control de cuentas de usuario
    Si se le pide la contraseña del administrador o que confirme la acción, escriba su contraseña o haga clic en Continuar.
  2. En el Administrador de dispositivos, expanda el nodo Procesadores.
  3. Haga clic con el botón secundario en cada procesador que se muestre, haga clic en Desinstalar y, a continuación, haga clic en Aceptar.

    Nota: si aparecen varios procesadores bajo Procesadores, cancele la opción para reiniciar el equipo hasta que haya desinstalado todos los procesadores.
  4. Reinicie el equipo después de haber desinstalado todos los procesadores.
  5. Una vez reiniciado el equipo, se reinstalarán los controladores de los procesadores. Reinicie de nuevo el equipo cuando se le pida después de que el equipo haya terminado de instalar los controladores de los procesadores. Una vez reiniciado de nuevo el equipo, se mostrará la información del procesador correcta en el Administrador de dispositivos bajo Procesadores.

Método 2: reinstale el controlador del procesador

Utilice el Administrador de dispositivos para reinstalar el controlador del procesador y reinicie el equipo. Para ello, siga estos pasos:
  1. Haga clic en Inicio
    Contraer esta imagenAmpliar esta imagen
    botón Inicio
    , escriba Devmgmt.msc en el cuadro Iniciar búsqueda y haga clic en Devmgmt.msc.

    Contraer esta imagenAmpliar esta imagen
     Permiso de Control de cuentas de usuario
    Si se le pide la contraseña del administrador o que confirme la acción, escriba su contraseña o haga clic en Continuar.
  2. En el Administrador de dispositivos, expanda el nodo Procesadores y haga doble clic en el primer procesador que se muestra.
  3. Haga clic en la ficha Controlador.
  4. Haga clic en Actualizar controlador.
  5. Haga clic en Buscar software de controlador en el equipo.
  6. Haga clic en Elegir en una lista de controladores de dispositivo en el equipo.
  7. En Modelo, haga clic en el procesador que incluya el nombre del fabricante de su procesador. Por ejemplo, haga clic en el procesador correspondiente a Intel, AMD, VIA u otro fabricante. Haga clic en Siguiente.
  8. Haga clic en Cerrar.
  9. Repita los pasos 2 a 8 para cada procesador que se muestre bajo Procesadores.
  10. Reinicie el equipo. Una vez reiniciado el equipo, se mostrará la información del procesador correcta en el Administrador de dispositivos bajo Procesadores.

Más información

Esta información sólo es aplicable cuando reemplaza físicamente el procesador con un procesador similar. La información no se aplica cuando también reemplaza la placa base.

Para averiguar el tipo de procesador y su versión, siga estos pasos:
  1. Haga clic en Inicio, escriba centro de bienvenida en el cuadro Iniciar búsqueda y haga clic en Centro de bienvenida en la lista Programas. Si se pide una contraseña de administrador o que confirme la acción, escriba su contraseña o haga clic en Continuar.
  2. En Centro de bienvenida, examine la información del área superior para determinar el tipo de procesador que está instalado.
Si piensa implementar una imagen de Windows Vista en varios equipos utilizando la herramienta Sysprep, escriba Sysprep /generalize en el símbolo del sistema y presione Entrar. Este comando quita información específica del sistema. Por ejemplo, este comando quita de la imagen el Id. de seguridad único (SID) y otra configuración específica del hardware. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
302577 Cómo utilizar la herramienta Sysprep.exe para automatizar la correcta implementación de Windows XP

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a".

Propiedades

Id. de artículo: 930861 - Última revisión: jueves, 27 de diciembre de 2007 - Versión: 5.0
La información de este artículo se refiere a:
  • Windows Vista Ultimate
  • Windows Vista Starter
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Enterprise
  • Windows Vista Business 64-bit edition
  • Windows Vista Business
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Enterprise 64-bit edition
Palabras clave: 
kbtshoot kbbug kbnofix kbexpertiseinter KB930861

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com