Device Manager does not show updated processor information on a Windows Vista-based computer or on a Windows Server 2008-based computer

Article translations Article translations
Article ID: 930861 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

After you physically replace the processor (CPU) with a similar model of processor on a Windows Vista-based computer or on a Windows Server 2008-based computer, the old processor information may still appear in Device Manager under Processors. In Windows Vista, the updated processor information does correctly appear in the Welcome Center in System and Maintenance in Control Panel.

CAUSE

This problem occurs because the system does not detect that a new processor has been installed.

Device Manager reads a registry string to display the processor information. This registry string is populated by the processor when the processor driver is installed. Because the system does not detect that a new processor had been installed, the system does not install a new processor driver. Therefore, the registry string is not updated. Device Manager reads the registry string information for the previous processor.

This problem occurs because the processor driver class installer may not be invoked in the system if the processor is physically replaced with a different processor that is similar to the previous processor. When this problem occurs, the processor description under Processors in Device Manager may not be updated. This problem is only cosmetic, and it does not affect the performance of the computer.

RESOLUTION

To update the processor description under Processors in Device Manager so that the correct processor is listed, use one of the following methods.

Method 1: Uninstall the processor

Use Device Manager to uninstall the processor, and then restart the computer. When the computer restarts, the system detects the processor, and it reinstalls the driver. To uninstall the processor, follow these steps:
  1. Click Start
    Collapse this imageExpand this image
    Start button
    , type Devmgmt.msc in the Start Search box, and then click Devmgmt.msc.

    Collapse this imageExpand this image
    User Account Control permission
    If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
  2. In Device Manager, expand the Processors node.
  3. Right-click each processor that is listed, click Uninstall, and then click OK.

    Note If you have multiple processors listed under Processors, cancel the option to restart the computer until you have uninstalled all the processors.
  4. Restart the computer after you have uninstalled all the processors.
  5. After the computer is restarted, the processor drivers are reinstalled. Restart the computer again when you are prompted to do so after the computer has finished installing the processor drivers. After the computer is restarted again, the correct processor information is listed in Device Manager under Processors.

Method 2: Reinstall the processor driver

Use Device Manager to reinstall the processor driver, and then restart the computer. To do this, follow these steps:
  1. Click Start
    Collapse this imageExpand this image
    Start button
    , type Devmgmt.msc in the Start Search box, and then click Devmgmt.msc.

    Collapse this imageExpand this image
    User Account Control permission
    If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
  2. In Device Manager, expand the Processors node, and then double-click the first processor that is listed.
  3. Click the Driver tab.
  4. Click Update Driver.
  5. Click Browse my computer for driver software.
  6. Click Let me pick from a list of device drivers on my computer.
  7. Under Model, click the processor that includes the name of the manufacturer of your processor. For example, click the processor that corresponds to Intel, AMD, VIA, or another manufacturer. Click Next.
  8. Click Close.
  9. Repeat steps 2 through 8 for each processor that is listed under Processors.
  10. Restart the computer. After the computer is restarted, the correct processor information is listed in Device Manager under Processors.

MORE INFORMATION

This information applies only when you physically replace the processor with a similar processor. The information does not apply when you also replace the motherboard.

To determine your processor type and version, follow these steps:
  1. Click Start, type welcome center in the Start Search box, and then click Welcome Center in the Programs list. If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
  2. In Welcome Center, examine information in the upper area to determine the processor type that is installed.
If you plan to deploy an operating system image on multiple computers by using the Sysprep tool, type Sysprep /generalize at the command prompt, and then press ENTER. This command removes system-specific information. For example, this command removes the unique security ID (SID) and other hardware-specific settings from the image. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
302577 How to use the Sysprep tool to automate successful deployment of Windows XP

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 930861 - Last Review: August 2, 2007 - Revision: 5.2
APPLIES TO
  • Windows Vista Ultimate
  • Windows Vista Starter
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Enterprise
  • Windows Vista Business 64-bit Edition
  • Windows Vista Business
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Server 2008 Standard
  • Windows Server 2008 Enterprise
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 Standard without Hyper-V
Keywords: 
kbnofix kbbug kbtshoot kbexpertiseinter KB930861

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com