Artigo: 931311 - Última revisão: quinta-feira, 11 de Outubro de 2007 - Revisão: 1.8

A utilização de programas Winsock grossa poderá exaustão 'memória paginável' de um computador baseado no Windows Server 2003

Está disponível transferência de hotfixDisponível transferência de hotfix
Ver e solicitar transferências de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

A utilização de programas Winsock grossa poderá exaustão 'memória paginável' de um computador baseado no Microsoft Windows Server 2003. Este comportamento é provável que ocorrer se o programa de Winsock é lidar com "Tráfego de saída de banda (MSG_OOB)" e "tráfego de TCP padrão." Nesta situação, poderá receber várias mensagens de erro. Além disso, poderá detectar um desempenho fraco. Além disso, o sistema poderá deixar de responder (não reagir).

Causa

Se o programa de Winsock não ler os dados recebidos do Winsock, etiqueta"conjunto de AfdB" poderá da memória intermédia mais dados do é o ideal. Este comportamento poderá exaustão tudo "conjunto não paginado memória disponível."

Resolução

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Para aplicar esta correcção, o computador tem de ter um dos seguintes sistemas operativos:
  • Uma versão de 32 bits do Windows Server 2003 com Service Pack 1 (SP1) ou Service Pack 2 (SP2)
  • Uma versão baseada em Itanium do Windows Server 2003 com SP1 ou SP2
  • Uma versão x 64 do Windows

Requisito de reinício

Tem de reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui uma correcção disponibilizada anteriormente.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item Data e hora no painel de controlo.
Windows Server 2003, x 86 versões
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataformaRequisito de SPRamo de serviço
Afd.sys5.2.3790.2866152,57622 De Janeiro de 200711: 16x 86SP1Não aplicável
Afd.sys5.2.3790.4008150,52822 De Janeiro de 200715: 40x 86SP2SP2QFE
Updspapi.dll6.3.4.1379,18427 De Dezembro de 200607: 40x 86SP1Não aplicável
Windows Server 2003, versões baseadas em 64 x
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataformaRequisito de SPRamo de serviço
Afd.sys5.2.3790.2866299,00822 De Janeiro de 200721: 58x 64SP1Não aplicável
Afd.sys5.2.3790.4008292,35222 De Janeiro de 200722: 04x 64SP2SP2QFE
Updspapi.dll6.3.4.1462,12822 De Janeiro de 200722: 05x 64SP1Não aplicável
Windows Server 2003, versões baseadas em Itanium
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataformaRequisito de SPRamo de serviço
Afd.sys5.2.3790.2866583,68022 De Janeiro de 200721: 59IA-64SP1Não aplicável
Afd.sys5.2.3790.4008583,68022 De Janeiro de 200722: 03IA-64SP2SP2QFE
Updspapi.dll6.3.4.1655,15222 De Janeiro de 200722: 05IA-64SP1Não aplicável

Como contornar

Para contornar este problema, não utilize MSG_OOB dados no programa de Winsock. Utilize um socket separado para dados urgentes.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Para obter mais informações sobre a nomes a pacotes de correcções, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
816915  (http://support.microsoft.com/kb/816915/ ) Novo esquema de atribuição de nomes de ficheiro para pacotes de actualização de software do Microsoft Windows do
Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

Suporte técnico para versões baseadas em 64 do Microsoft Windows x

Se o hardware foi fornecido com uma edição x 64 do Microsoft Windows instalada, o fabricante do hardware fornece suporte técnico e assistência para a edição x 64 do Windows. Neste caso, o fabricante do hardware fornece suporte porque foi incluída com o hardware de uma edição x 64 do Windows. O fabricante do hardware pode ter personalizado a instalação da edição x 64 do Windows utilizando componentes exclusivos. Estes componentes exclusivos podem incluir controladores de dispositivo específicos ou podem incluir definições opcionais para maximizar o desempenho do hardware. A Microsoft fornecerá assistência razoável se necessitar de assistência técnica para uma edição x 64 do Windows. No entanto, poderá ter de contactar o fabricante directamente. O fabricante está melhor qualificado para suportar o software que o fabricante do instalado no hardware. Se tiver adquirido uma edição x 64 do Windows como o um Microsoft Windows Server 2003 x 64 edition, separadamente, contacte a Microsoft para obter suporte técnico.

Para obter informações sobre o Microsoft Windows XP Professional x 64 Edition, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/windowsxp/64bit/default.mspx (http://www.microsoft.com/windowsxp/64bit/default.mspx)
Para obter informações sobre versões baseadas em 64 do Microsoft Windows Server 2003 x, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx (http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx)

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Web Edition
Palavras-chave: 
kbmt kbautohotfix kbfix kbbug kbhotfixserver kbqfe kbprb kbexpertiseadvanced KB931311 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 931311  (http://support.microsoft.com/kb/931311/en-us/ )