ID do artigo: 931311 - Última revisão: quinta-feira, 11 de outubro de 2007 - Revisão: 1.8

O uso intenso de programas Winsock pode esgotar "memória pool não paginado e não" de um computador baseado no Windows Server 2003

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

O uso intenso de programas Winsock pode esgotar "memória pool não paginado e não" de um computador baseado no Microsoft Windows Server 2003. Esse comportamento é provável de ocorrer se o programa Winsock está lidando com "Tráfego fora de banda (MSG_OOB)" e "tráfego TCP padrão". Nessa situação, você pode receber diversas mensagens de erro. Além disso, você pode enfrentar um desempenho ruim. Além disso, o sistema pode parar de responder (travar).

Causa

Se o programa Winsock não ler dados de entrada do Winsock, "AfdB pool marca" pode buffer mais dados do que é ideal. Esse comportamento pode esgotar todos os "não-paginável memória disponível."

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, o computador deve estar executando um dos seguintes sistemas operacionais:
  • Uma versão de 32 bits do Windows Server 2003 com Service Pack 1 (SP1) ou Service Pack 2 (SP2)
  • Uma versão baseada em Itanium do Windows Server 2003 com SP1 ou SP2
  • Uma versão x 64 do Windows

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui um hotfix lançado anteriormente.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows Server 2003, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SPRamificação do serviço
Afd.sys5.2.3790.2866152,57622 De janeiro de 200711: 16x 86SP1Não aplicável
Afd.sys5.2.3790.4008150,52822 De janeiro de 200715: 40x 86SP2SP2QFE
Updspapi.dll6.3.4.1379,18427 De dezembro de 200607: 40x 86SP1Não aplicável
Windows Server 2003, versões com base em 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SPRamificação do serviço
Afd.sys5.2.3790.2866299,00822 De janeiro de 200721: 58x 64SP1Não aplicável
Afd.sys5.2.3790.4008292.35222 De janeiro de 200722: 04x 64SP2SP2QFE
Updspapi.dll6.3.4.1462,12822 De janeiro de 200722: 05x 64SP1Não aplicável
Windows Server 2003, versões com base em Itanium
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SPRamificação do serviço
Afd.sys5.2.3790.2866583,68022 De janeiro de 200721: 59IA-64SP1Não aplicável
Afd.sys5.2.3790.4008583,68022 De janeiro de 200722: 03IA-64SP2SP2QFE
Updspapi.dll6.3.4.1655,15222 De janeiro de 200722: 05IA-64SP1Não aplicável

Como Contornar

Para contornar esse problema, não use dados MSG_OOB no programa Winsock. Use um soquete separado para dados urgentes.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre como os pacotes de hotfix são nomeados, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
816915  (http://support.microsoft.com/kb/816915/ ) Novo esquema de nomeação de arquivo para pacotes de atualização de software do Microsoft Windows
Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

Suporte técnico para versões com base em 64 x do Microsoft Windows

Se o hardware veio com uma edição x 64 do Microsoft Windows instalada, o fabricante do hardware fornecerá suporte técnico e assistência para a edição x 64 do Windows. Nesse caso, o fabricante do hardware fornece suporte porque uma edição x 64 do Windows foi incluída com o hardware. O fabricante do hardware pode ter personalizado a instalação da edição x 64 do Windows do usando componentes exclusivos. Componentes exclusivos podem incluir drivers de dispositivo específico ou podem incluir configurações opcionais para maximizar o desempenho do hardware. A Microsoft fornecerá assistência razoável se você precisar de ajuda técnica com uma edição x 64 do Windows. No entanto, talvez você precise entrar em contato com o fabricante diretamente. O fabricante do seu melhor é qualificado para suportar o software que o fabricante do seu instalado no hardware. Se você comprou uma edição x 64 do Windows, como Microsoft Windows Server 2003 x 64 edition separadamente, contate a Microsoft para obter suporte técnico.

Para informações de produto sobre o Microsoft Windows XP Professional x 64 Edition, visite o seguinte site:
http://www.microsoft.com/windowsxp/64bit/default.mspx (http://www.microsoft.com/windowsxp/64bit/default.mspx)
Para informações de produto sobre versões com base em 64 x do Microsoft Windows Server 2003, visite o seguinte site:
http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx (http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx)

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
Palavras-chave: 
kbmt kbautohotfix kbfix kbbug kbhotfixserver kbqfe kbprb kbexpertiseadvanced KB931311 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 931311  (http://support.microsoft.com/kb/931311/en-us/ )