Error message when you start Windows XP unattended Setup by using Winnt.exe together with the /2 option: "Setup was unable to copy the following file: <FileName>"

Article translations Article translations
Article ID: 931532 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

You start Microsoft Windows XP unattended Setup by using the Winnt.exe command-line tool together with the /2 option. For example, you use the following command:
winnt.exe /u:c:\i386\unattend.txt /s:c:\i386 /rx:lang /2
In this case, Setup stops on every slipstreamed file during the Winnt.exe phase. Also, you receive the following error message:
Setup was unable to copy the following file: FileName
This problem occurs if the hotfixes and updates that were released after the release of Windows XP Service Pack 2 were slipstreamed into the i386 distribution folder by using the /integrate option.

CAUSE

This problem occurs because Winnt.exe creates directories in the target folder based on entries in the Dosnet.inf file. If the Dosnet.inf file is not manually modified to reflect new hotfixes and updates, Winnt.exe displays an error message whenever a target directory is missing.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Winnt.exeNot Applicable84,93921-Jan-200717:21Not Applicable
Note Extract the hotfix package. Then, manually copy the Winnt.exe file to the i386 folder on your shared distribution folder.

WORKAROUND

To work around this problem, add entries in the directories section of the Dosnet.inf file that resemble the following entries:
[Directories]
d5=\d1 = \I386d2 = \cmpnents\tabletpc\I386d3 = \cmpnents\mediactr\I386d4 = \cmpnents\netfx\I386d6 = \i386\langd7 = \i386\update
Add all the destination directories that Winnt.exe must create.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Typically, the /2 option is used to set up a Tablet PC.

For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 931532 - Last Review: October 8, 2011 - Revision: 4.0
APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Tablet PC Edition
Keywords: 
kbautohotfix kberrmsg kbhotfixserver kbqfe KB931532

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com