ID do artigo: 931619 - Última revisão: terça-feira, 19 de fevereiro de 2008 - Revisão: 3.2

Ao clicar no ícone Remover hardware com segurança no Windows Vista, o dispositivo em questão pode não ser removido conforme o esperado

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Ao clicar no ícone Remover hardware com segurança na área de notificação de um computador com base no Windows Vista e clicar em Remover Nome_do_dispositivo com segurança, o dispositivo pode não ser removido conforme o esperado. Além disso, não é exibida uma mensagem que verifica se o dispositivo foi removido com segurança.

Observação Esse problema ocorre apenas ao clicar com o botão esquerdo do mouse no ícone Remover hardware com segurança na área de notificação e clicar em Remover Nome_do_dispositivo com segurança.

Causa

Esse problema ocorre devido a um problema de temporização no qual a memória alocada pode ser liberada enquanto o sistema está removendo o dispositivo selecionado. Quando esse comportamento ocorre, o sistema não pode mais encontrar as informações sobre o dispositivo selecionado. Por isso, o dispositivo não é removido.

Resolução

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Testes adicionais podem ser realizados nesse hotfix. Por isso, se esse problema não o prejudicar seriamente, é recomendável que você aguarde o próximo service pack que contenha esse hotfix.

Para resolver esse problema, envie uma solicitação para o Atendimento ao Cliente Online Microsoft para obter o hotfix. Para enviar a solicitação online para obter o hotfix, visite o seguinte site da Microsoft:
http://support.microsoft.com/gp/CUHotFix_LandingPage_Request (http://go.microsoft.com/?linkid=6294451)
Observação Se outros problemas ocorrerem ou se uma solução de problema for requisitada, pode ser necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não se qualifiquem a esse hotfix. Para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

Pré-requisitos

Não há pré-requisitos.

Necessidade de reinicialização

É necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui nenhum outro.

Informações sobre o arquivo

A versão em inglês desse hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horários destes arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário no item Data e hora do Painel de Controle.
Windows Vista, versões com base em x86
Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataforma
Stobject.dll6.0.6000.20550586.240 06-mar-200702:56x86
Versões de 64 bits do Windows Vista
Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataforma
Stobject.dll6.0.6000.20550756.736 06-mar-200704:01x64

Como Contornar

Como solução alternativa para esse problema, use um dos seguintes métodos:
  • Clique duas vezes no ícone Remover hardware com segurança na área de notificação, clique no dispositivo e clique em Parar.
  • Clique com o botão direito do mouse no ícone Remover hardware com segurança na área de notificação, clique em Remover hardware com segurança, clique no dispositivo e em Parar.

Situação

A Microsoft confirmou que este é um problema nos produtos Microsoft que estão listados na seção "Aplica-se a".

Mais Informações

Para obter informações adicionais sobre a terminologia padrão que a Microsoft está adotando para descrever as atualizações de software, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft (a página pode estar em inglês):
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft

A informação contida neste artigo aplica-se a:
  • Windows Vista Ultimate
  • Windows Vista Starter
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Enterprise
  • Windows Vista Business 64-bit edition
  • Windows Vista Business
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Enterprise 64-bit edition
Palavras-chave: 
kbvistasp1fix kbwinvistapostrtmfix kbbug kbfix kbhotfixserver kbqfe kbpubtypekc kbexpertisebeginner KB931619