Das Tool "Chkdsk.exe" kann nicht fehlerhafte Cluster oder fehlerhafte Sektoren auf einem Windows Server 2003-Computer erkennen, wenn die Größe einer komprimierten Datei größer als 4 Gigabyte (GB) ist

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Problembeschreibung

Wenn Sie ein Volume auf einem Windows Server 2003-Computer mit den Befehl Chkdsk/r scannen, erhalten Sie eine Statusmeldung, die die folgenden ähnelt:
CHKDSK is verifying file data (stage 4 of 5)...
0 percent completed. 
1 percent completed. 
2 percent completed. 
3 percent completed. 
Windows replaced bad clusters in file <number>
of name <file name>.
100 percent completed. 
File data verification completed.
CHKDSK is verifying free space (stage 5 of 5)...
Diese Statusmeldung gibt fälschlicherweise an, dass es sich bei Windows um fehlerhafte Cluster ersetzt. Diese Statusmeldung kann auftreten, wenn die folgenden Bedingungen erfüllt sind:
  • Der aktuelle Datenträger hat eine komprimierte Datei.
  • Die Größe der komprimierten Datei ist größer als 4 Gigabyte (GB).

Ursache

Während eine Oberflächenanalyse versucht das Tool "Chkdsk.exe", um den Inhalt aller komprimierten Dateien auf dem Volume zu lesen. Ein Fehler beim Lesen von ein oder mehrere Cluster in einer Datei bedeutet, dass ein Fehler aufgetreten ist, wenn die "Chkdsk.exe" Tool die Daten auf dem Datenträger lesen.

Wenn das Tool "Chkdsk.exe" eine komprimierte Datei, die größer als 4 GB ist erkennt, tritt ein arithmetischer Fehler, die die Überprüfung der 4 GB komprimierte Datei beendet. Wenn dieses Problem auftritt, wird das Tool "Chkdsk.exe" davon ausgegangen, dass ein Fehler aufgetreten, ist Wenn das Tool "Chkdsk.exe" versuchte, die Daten auf dem Datenträger zu lesen.

Lösung

Informationen zu Service Packs

Um dieses Problem zu beheben, beziehen Sie das neueste Servicepack für Windows Vista. Weitere Informationen finden Sie die folgende KB-Artikelnummer:
935791So erhalten Sie das neueste Servicepack für Windows Vista

Hotfix-Informationen

Ein unterstützter Hotfix ist von Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des Problems das in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix wird möglicherweise zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Normale Servicegebühren werden jedoch für weitere Fragen und Problemlösungen, die für diesen bestimmten Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf folgender Website von Microsoft:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen, die für die der Hotfix verfügbar ist. Wenn Sie Ihre Sprache nicht angezeigt werden, liegt dies daran, dass ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Dieser Hotfix erfordert, dass Microsoft Windows Server 2003 mit Service Pack 1 (SP1) oder ein höheres Servicepack auf dem Computer installiert ist.
889100So erhalten Sie das neueste Servicepack für Windows Server 2003

Neustartanforderung

Sie müssen den Computer neu zu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind aufgelistet, in Coordinated Universal Time (UTC). Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC-Zeit und lokaler Zeit zu ermitteln, verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung.
Windows Server 2003 mit Service Pack 1 (SP1), x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
UNTFS.dll5.2.3790.2866319,48822-Jan 200721: 10X 86
Windows Server 2003 mit Service Pack 2 (SP2), x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
UNTFS.dll5.2.3790.4008320,00022-Jan 200721: 25X 86
Windows Server 2003 x 64-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP AnforderungServicebereich
UNTFS.dll5.2.3790.2866461,31222-Jan 200705: 45X 64SP1Nicht anwendbar
Wuntfs.dll5.2.3790.2866319,48822-Jan 200705: 45X 86SP1WOW
Windows Server 2003 mit Service Pack 2 (SP2), x 64-Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP AnforderungServicebereich
UNTFS.dll5.2.3790.4008467,96822-Jan 200705: 50X 64SP2Nicht anwendbar
Wuntfs.dll5.2.3790.4008320,00022-Jan 200705: 50X 86SP2WOW
Windows Server 2003 mit Service Pack 1 (SP1), Itanium-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP AnforderungServicebereich
UNTFS.dll5.2.3790.2866943,61622-Jan 200705: 45IA-64SP1Nicht anwendbar
Wuntfs.dll5.2.3790.2866319,48822-Jan 200705: 45X 86SP1WOW
Windows Server 2003 mit Service Pack 2 (SP2), Itanium-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP AnforderungServicebereich
UNTFS.dll5.2.3790.4008943,61622-Jan 200705: 49IA-64SP2Nicht anwendbar
Wuntfs.dll5.2.3790.4008320,00022-Jan 200705: 49X 86SP2WOW

Status

Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind. Dieses Problem wurde erstmals in Windows Vista Service Pack 1 behoben.

Weitere Informationen

Nachdem Sie diesen Hotfix installieren, und Sie den Befehl Chkdsk/r ausführen, erhalten Sie eine Meldung etwa folgenden Inhalts angezeigt:
CHKDSK is verifying files (stage 1 of 5)...
File verification completed.
CHKDSK is verifying indexes (stage 2 of 5)...
Index verification completed.
CHKDSK is verifying security descriptors (stage 3 of 5)...
Security descriptor verification completed.
CHKDSK is verifying file data (stage 4 of 5)...
File data verification completed
, Um Hilfeinformationen häufige System-Wartungsaufgaben in Windows Vista finden Sie auf der folgenden Microsoft-Webseite:
Fix problems with common system maintenance tasks

Eigenschaften

Artikel-ID: 931689 - Geändert am: Mittwoch, 21. Mai 2008 - Version: 2.3
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
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Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 931689
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