Mensaje de error cuando intenta conectarse a una impresora compartida en Windows Vista: "el controlador de impresora no es compatible con una directiva habilitada en el equipo que bloquea 4.0 controladores"

Seleccione idioma Seleccione idioma
Id. de artículo: 931719 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Cuando intenta conectarse a una impresora compartida en Windows Vista, recibirá el siguiente mensaje de error:
Windows no puede conectarse a la impresora. El controlador de impresora no es compatible con la directiva habilitada en el equipo que bloquea controladores NT 4.0.
Experimenta este comportamiento si se cumplen las condiciones siguientes:
  • Utilizar la característica Windows Point and Print para conectar la impresora compartida.

    Nota La característica Point and Print permite imprimir a una impresora compartida sin instalar manualmente un nuevo controlador. Para obtener más información acerca de esta característica, consulte la sección "Más información".
  • La impresora compartida utiliza un controlador de impresora de modo de núcleo.

Causa

Este problema se produce porque Windows no admite la instalación de controladores de impresora de modo kernel. Windows sólo admite la instalación de controladores de impresora de modo de usuario.

Cuando intenta conectarse a una impresora compartida en Windows Vista, sucede lo siguiente:
  • Si un controlador de modo de usuario está alojado en el equipo basado en Windows NT 4.0, Windows instalará correctamente el controlador de Point and Print.
  • Si un controlador en modo núcleo está alojado en el equipo basado en Windows NT 4.0, Windows intenta localizar un controlador de impresora de modo de usuario compatible. En este escenario, se produce el comportamiento siguiente:
    • Si Windows puede asignar un controlador de impresora de modo de usuario compatible del controlador de impresora de modo núcleo que está alojado en el equipo basado en Windows NT 4.0, Windows instala a la impresora correctamente.
    • Si Windows no puede asignar un controlador de impresora de modo de usuario compatible del controlador de impresora de modo núcleo que está alojado en el equipo basado en Windows NT 4.0, Windows no instala a la impresora.
Microsoft Windows NT 4.0 admite los siguientes tipos de controladores de impresora:
  • Controladores de impresora de modo de núcleo

    Nota Éstos son también conocidos como controladores de impresora 2 versión. Este tipo de controlador incluye muchos de los controladores de impresora se incluyen con Windows NT 4.0.
  • Controladores de impresora de modo de usuario

    Nota Éstos son también conocidos como controladores de impresora 3 versión.

Solución

Para evitar este comportamiento, intente obtener e instalar a un controlador de impresora de modo de usuario en el equipo basado en Windows NT 4.0. Si no puede obtener el controlador de impresora de modo de usuario en particular, intente obtener un controlador de impresora de modo de usuario que es compatible con el controlador de impresora de modo de núcleo que está alojado en el equipo basado en Windows NT 4.0. Para obtener un controlador de impresora actualizado para el dispositivo de impresión, póngase en contacto con el fabricante de la impresora.

Para obtener información sobre el fabricante del hardware, visite el siguiente sitio Web:
http://support.microsoft.com/gp/vendors/en-us
Microsoft proporciona información de contacto con otros proveedores para ayudarle a encontrar soporte técnico. Esta información de contacto puede cambiar sin previo aviso. Microsoft no ofrece ninguna garantía con respecto a la exactitud de esta información de contacto con otros proveedores.

Estado

Este comportamiento es por diseño.

Más información

Para obtener más información acerca de la característica Point and Print, visite el siguiente sitio Web de Microsoft:
http://www.microsoft.com/windowsserver2003/techinfo/overview/pointandprint.mspx
Los productos de terceros que se analizan en este artículo están fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, sobre el rendimiento o confiabilidad de estos productos.

Propiedades

Id. de artículo: 931719 - Última revisión: sábado, 17 de marzo de 2007 - Versión: 1.4
La información de este artículo se refiere a:
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Starter
Palabras clave: 
kbmt kbprint kbexpertisebeginner kbtshoot kbprb KB931719 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 931719

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com