Visual Studio 2005'te kod erişimi güvenlik ilkesi aracını kullanan bir Windows ınstaller paketi oluşturma hakkında

Makale çevirileri Makale çevirileri
Makale numarası: 931867 - Bu makalenin geçerli olduğu ürünleri görün.
Hepsini aç | Hepsini kapa

Bu Sayfada

Giriş

Bu makalede, Microsoft Visual Studio 2005'te kod erişimi güvenlik ilkesi aracını kullanan bir Microsoft Windows ınstaller paketi oluşturma.

Daha fazla bilgi

Kod erişimi güvenlik ilkesi aracı, aşağıdaki ilke düzeyi için güvenlik ilkesi'ni değiştirmek için kullanabilirsiniz:
  • Makine ilkesi düzeyi
  • Kullanıcı ilke düzeyi
  • Kuruluş ilke düzeyi
Güvenlik ilkesinde değişiklik yapar, bir Windows ınstaller paketi oluşturmak için Microsoft .NET Framework 2.0 Yapılandırma aracını kullanın. Bunu yapmak için şu adımları izleyin:
  1. Başlat ' ı tıklatın, Çalıştır ' ı tıklatın, control admintoolskutusuna yazın ve Tamam ' ı tıklatın.
  2. Yönetim Araçları ' nda Microsoft .NET Framework 2.0 yapılandırması ' nı çift tıklatın.
  3. .NET Framework 2.0 yapılandırma iletişim kutusunda, Bilgisayarım ' ı genişletin, Çalışma zamanı güvenlik ilkesi ' ni tıklatın ve sonra Dağıtım paketi oluştur) tıklatın.
Bu adımları izlediğinizde, tam bir ilke düzeyi değiştirilir.

Güvenlik ilkesi için belirli bir değişiklik yapmak ve diğer ilkeleri üzerine yazmasını engellemek için aşağıdaki adımları izleyin.

1. Adım: varolan ilke ayarlarını belirleme

Herhangi bir değişiklik yapmadan önce varolan ilke ayarlarını belirler. Bunu yapmak için şu adımları izleyin:
  1. Başlat ' ı tıklatın, Çalıştır ' ı tıklatın, control admintoolskutusuna yazın ve Tamam ' ı tıklatın.
  2. Yönetim Araçları ' nda Microsoft .NET Framework 2.0 yapılandırması ' nı çift tıklatın.
  3. .NET Framework 2.0 yapılandırma iletişim kutusunda, Bilgisayarım ' ı genişletin ve sonra da Çalışma zamanı güvenlik ilkesi ' ni genişletin.
  4. Makine genişletin Kod grupları ' nı genişletin ve sonra All_Code genişletin.

    Not Bu bilgisayara herhangi bir grubu eklemek, All_Code grubu aşağıdaki varsayılan bölge içerir:
    • My_Computer_Zone
    • LocalInternet_Zone
    • Internet_Zone
    • Restricted_Zone
    • Trusted_Zone

2. Adım: temel bir Windows ınstaller paketi oluşturmak için kullan Visual Studio 2005

Temel bir Windows ınstaller paketi oluşturmak için aşağıdaki adımları izleyin:
  1. Visual Studio 2005'i başlatın.
  2. Dosya menüsünden Yeni ' yi tıklatın ve sonra Project ' i tıklatın.
  3. Yeni proje) iletişim kutusunda, Project Types altındaki Diğer Project Types ' ı genişletin, kurulumu ve dağıtımı'nı tıklatın ve Kur ProjectVisual Studio'nun yüklü şablonlar altında'yı tıklatın.
  4. Ad kutusuna Caspol.msi yazın.
  5. Konum kutusundaki Caspol.msi dosyasının konumunu yazın ve Tamam ' ı tıklatın.
  6. Görünüm menüsünde Düzenleyicisi ' ni tıklatın ve Başlatma için koşullar ' ı tıklatın.
  7. Başlatma koşulları sekmesinde, Arama hedef makinegereksinimleri Hedef makinedeki altında'ı sağ tıklatın ve Ekle Dosya Ara ' yı tıklatın.
  8. Yeni bir düğüm adı Caspol-arama yazın.
  9. Caspol-arama ' ı sağ tıklatın ve sonra da Properties Windows ' ı tıklatın.
  10. Caspol-arama Başlat koşul özellikler iletişim kutusunda, aşağıdaki değerleri belirtir:
    • Derinliği</a0> kutusunda, 10 yazın.
    • FilesName kutusuna caspol.exe yazın.
    • Klasör kutusuna [WindowsFolder]'ı tıklatın.
    • MinVersion kutusuna 2.0 yazın.

      Not Bu ayar, hedef bilgisayarda .NET Framework'un bu ayardan daha önceki bir sürümünü kullanacak şeklide gereklidir.
Genellikle, bir proje bir çözümde oluşturduğunuz temel Windows ınstaller paketini ekleyebilirsiniz var. Bir proje yoksa derleme imzalamanız gerekir. Bunu yapmak için şu adımları izleyin:
  1. Visual Studio 2005'i başlatın.
  2. Dosya menüsünde, Ekle ' yi tıklatın ve sonra da New Project ' i tıklatın.
  3. Yeni proje Ekle iletişim kutusunda, Visual C# ' nı genişletin, Windows ' u tıklatın ve Visual Studio'nun yüklü şablonlar altında Windows uygulama ' yı tıklatın.
  4. Adı kutusuna bir ad yazın.
  5. Konum kutusundaki konumu yazın ve Tamam ' ı tıklatın.
  6. Yeni bir anahtar dosyası kullanarak derleme oturum açmak için <a0></a0>, WindowsApplication1Solution Explorer'da (Çözüm Gezgini) sağ tıklatın ve sonra da Properties ' i tıklatın.
  7. WindowsApplication1 sekmesinde imzalama ' ı tıklatın.
  8. <a1>Oturum</a1> derleme onay kutusunu seçmek için tıklatın.
  9. Yeni bir anahtar dosyası belirtmek için <a0></a0>, <new>Ek Yardım düğmesini tıklatın. listesinde Kesin ad anahtar dosyası seçin.

    Not Yeni anahtar dosyaları her zaman .pfx biçiminde oluşturulabilir.
  10. Kesin ad anahtar oluştur iletişim kutusuna bir ad yazın, sonra da bir parola yazın ve Tamam ' ı tıklatın.
  11. Başlat'ı hata ayıklamaHata Ayıkla menüsünde tıklatın.
  12. Visual Studio 2005'ten çıkın.

3. Adım: özel eylemler eklemek için bu Orca aracı (Orca.exe) kullanın.

Not Bu bölüm, Orca Aracı'nın yüklü olduğu varsayılır. Orca aracı hakkında daha fazla bilgi için "Başvurular" bölümüne bakın.

Özel eylemler eklemek için Orca aracını kullanmak için aşağıdaki adımları izleyin:
  1. Microsoft Windows Gezgini'nde Caspol.msi dosyasını bulun, sonra da Caspol.msi dosyasını sağ tıklatın ve sonra da <a2>Orca ile Düzenle</a2>'ı tıklatın.
  2. Orca aracında CustomAction altında Tablolar ' ı tıklatın, sonra da Tablolar menüsünü ve Ekle satır ' ı tıklatın.
  3. Ekle satır iletişim kutusunda, aşağıdaki değerleri belirtin:
    • Ad sütununda, Eylem ' i tıklatın ve sonra da sütunu altında <a1>Eylem</a1> kutusunda CASPOLTURNOFFMESSAGES yazın.
    • Adı sütunundaki türü ' nü tıklatın ve sonra da 3122sütunu altında <a1>türü</a1> kutusunda yazın.
    • Ad sütununda, kaynağı ' nı tıklatın ve sonra da FILEEXISTS1sütun altındaki <a1>kaynak</a1> kutusuna yazın.
    • Ad sütununda, hedef tıklatın ve sonra yazın -Kapalı ppsütunu altında <a1>hedef</a1> kutusundaki.
  4. <a0>Add satır</a0> iletişim kutusunu kapatmak için Tamam ' ı tıklatın.
  5. Orca aracında CustomAction altında Tablolar ' ı tıklatın, sonra da Tablolar menüsünü ve Ekle satır ' ı tıklatın.
  6. Ekle satır iletişim kutusunda, aşağıdaki değerleri belirtin:
    • Ad sütununda, Eylem ' i tıklatın ve sonra da sütunu altında <a1>Eylem</a1> kutusunda CASPOLPERFORMACTION yazın.
    • Adı sütunundaki türü ' nü tıklatın ve sonra da 3122sütunu altında <a1>türü</a1> kutusunda yazın.
    • Ad sütununda, kaynağı ' nı tıklatın ve sonra da FILEEXISTS1sütun altındaki <a1>kaynak</a1> kutusuna yazın.
    • Ad sütununda, hedef ' ı tıklatın ve sonra da sütunu altında <a1>hedef</a1> kutusunda aşağıdaki komutu yazın:
      -1 - güçlü - addgroup "Bu kod grubu eklenen tarafından caspol komut satırından bizim sınama Windows ınstaller paketini." "[TARGETDIR]MyNewCaspolTest.exe" MyReferenceAssemblyName - noversion <a1>Yürütme</a1>-MyCaspolCodeGroupName adı - açıklama dosyası
    Not Önekli [TARGETDIR] özelliği ve .exe dosya adı tırnak işaretleri içine alınır. Önekli [TARGETDIR] özelliği ve .exe dosya adı bir ters eğik çizgi (\) yok. Kod erişimi güvenlik ilkesi aracı için seçenekler hakkında daha fazla bilgi için aşağıdaki Microsoft Developer Network (MSDN) Web sitesini ziyaret edin:
    http://msdn2.microsoft.com/en-us/library/cb6t8dtz(VS.80).aspx
  7. <a0>Add satır</a0> iletişim kutusunu kapatmak için Tamam ' ı tıklatın.
  8. Orca aracında CustomAction altında Tablolar ' ı tıklatın, sonra da Tablolar menüsünü ve Ekle satır ' ı tıklatın.
  9. Ekle satır iletişim kutusunda, aşağıdaki değerleri belirtin:
    • Ad sütununda, Eylem ' i tıklatın ve sonra da sütunu altında <a1>Eylem</a1> kutusunda CASPOLUNINSTALL yazın.
    • Adı sütunundaki türü ' nü tıklatın ve sonra da 3122sütunu altında <a1>türü</a1> kutusunda yazın.
    • Ad sütununda, kaynağı ' nı tıklatın ve sonra da FILEEXISTS1sütun altındaki <a1>kaynak</a1> kutusuna yazın.
    • Ad sütununda, hedef tıklatın ve sonra yazın -remgroup MyCaspolCodeGroupNamesütunu altında <a1>hedef</a1> kutusundaki.
    Not Bilgileri bu adımda, bu eylem, yüklemeyi geri yardımcı olur.
  10. <a0>Add satır</a0> iletişim kutusunu kapatmak için Tamam ' ı tıklatın.
  11. Orca aracında InstallExecuteSequence altında Tablolar ' ı tıklatın, sonra da Tablolar menüsünü ve Ekle satır ' ı tıklatın.
  12. Ekle satır iletişim kutusunda, aşağıdaki değerleri belirtin:
    • Ad sütununda, Eylem ' i tıklatın ve sonra da sütunu altında <a1>Eylem</a1> kutusunda CASPOLTURNOFFMESSAGES yazın.
    • Ad sütununda, koşulu tıklatın ve sonra NOT yüklüsütun altındaki <a1>koşul</a1> kutusuna yazın.
    • Ad sütununda, sırası ' nı tıklatın ve sonra da 6500sütun altındaki <a1>sıra</a1> kutusuna yazın.
  13. <a0>Add satır</a0> iletişim kutusunu kapatmak için Tamam ' ı tıklatın.
  14. Orca aracında InstallExecuteSequence altında Tablolar ' ı tıklatın, sonra da Tablolar menüsünü ve Ekle satır ' ı tıklatın.
  15. Ekle satır iletişim kutusunda, aşağıdaki değerleri belirtin:
    • Ad sütununda, Eylem ' i tıklatın ve sonra da sütunu altında <a1>Eylem</a1> kutusunda CASPOLPERFORMACTION yazın.
    • Ad sütununda, koşulu tıklatın ve sonra NOT yüklüsütun altındaki <a1>koşul</a1> kutusuna yazın.
    • Ad sütununda, sırası ' nı tıklatın ve sonra da 6510sütun altındaki <a1>sıra</a1> kutusuna yazın.
  16. <a0>Add satır</a0> iletişim kutusunu kapatmak için Tamam ' ı tıklatın.
  17. Orca aracında InstallExecuteSequence altında Tablolar ' ı tıklatın, sonra da Tablolar menüsünü ve Ekle satır ' ı tıklatın.
  18. Ekle satır iletişim kutusunda, aşağıdaki değerleri belirtin:
    • Ad sütununda, Eylem ' i tıklatın ve sonra da sütunu altında <a1>Eylem</a1> kutusunda CASPOLUNINSTALL yazın.
    • Adı sütunundaki koşulu tıklatın ve sonra da yüklüsütunu altında <a1>koşul</a1> kutusunda yazın.
    • Ad sütununda, sırası ' nı tıklatın ve sonra da 6520sütun altındaki <a1>sıra</a1> kutusuna yazın.
    Not Bilgileri bu adımda, bu eylem, yüklemeyi geri yardımcı olur.
  19. <a0>Add satır</a0> iletişim kutusunu kapatmak için Tamam ' ı tıklatın.

Adım 4: Orca aracı Visual Studio 2005 yapılan ayarları onaylamak için kullanın.

Visual Studio 2005 yapılan ayarları doğrulamak için şu adımları izleyin:
  1. Orca aracında, Tables altında imza ' yı tıklatın.

    NotDosyaadı sütun CASPOL.EXE|caspol.exe görüntüler ve 2.0MinVersion sütun görüntüler.
  2. Orca aracında DrLocator altında Tablolar ' ı tıklatın.

    NotYol sütun [WindowsFolder] görüntüler.
  3. Dosya menüsünde Kaydet ' i tıklatın.
  4. Orca Aracı'ndan çıkmak için Çık ' ı tıklatın.

Adım 5: Caspol.msi dosyası yüklenir ve sonra Caspol.msi dosyanın değiştirilmiş ayarları onaylayın

Caspol.msi dosyasını yüklemek için ayarlarını doğrulamak için şu adımları izleyin:
  1. Caspol.msi dosyasını yüklemek için <a0></a0>, Başlat ' ı tıklatın, Çalıştır ' ı tıklatın, kutusuna aşağıdaki komutu yazın ve Tamam ' ı tıklatın:
    "DriveLetter: \ <path> \caspol.msi "ALLUSERS 2/passive =
    Not Komut seçenekleri büyük/küçük harf duyarlıdır. Use ALLUSERS = 2 tek bir bilgisayar üzerinde dosya yükleme seçeneği. / Passive seçeneği en alt düzeyde kullanıcı girdisi gerektirir.
  2. Caspol.msi dosyanın değiştirilmiş ayarları doğrulamak için şu adımları izleyin:
    1. Başlat ' ı tıklatın, Çalıştır ' ı tıklatın, control admintoolskutusuna yazın ve Tamam ' ı tıklatın.
    2. Yönetim Araçları ' nda Microsoft .NET Framework 2.0 yapılandırması ' nı çift tıklatın.
    3. .NET Framework 2.0 yapılandırma iletişim kutusunda, Bilgisayarım ' ı genişletin ve sonra da Çalışma zamanı güvenlik ilkesi ' ni genişletin.
    4. Makine genişletin Kod grupları ' nı genişletin ve sonra All_Code genişletin.
    5. LocalIntranet_Zone ' ı sağ tıklatın ve sonra da Properties ' i tıklatın.
    6. LocalIntranet_Zone özellikler iletişim kutusunda, İzin kümesi sekmesini Nothingizin kümesi altında görüntülendiğini bildirimi tıklatın.
Caspol.msi dosyayı kaldırmak için <a0></a0>, Caspol.msi ' ı sağ tıklatın ve sonra Kaldır ' ı tıklatın. Caspol.msi dosya kaldırılırsa doğrulamak için şu adımları izleyin:
  1. Başlat ' ı tıklatın, Çalıştır ' ı tıklatın, control admintoolskutusuna yazın ve Tamam ' ı tıklatın.
  2. Yönetim Araçları ' nda Microsoft .NET Framework 2.0 yapılandırması ' nı çift tıklatın.
  3. .NET Framework 2.0 yapılandırma iletişim kutusunda, Bilgisayarım ' ı genişletin ve sonra da Çalışma zamanı güvenlik ilkesi ' ni genişletin.
  4. Makine genişletin Kod grupları ' nı genişletin ve sonra All_Code genişletin.
  5. LocalIntranet_Zone ' ı sağ tıklatın ve sonra da Properties ' i tıklatın.
  6. LocalIntranet_Zone özellikler iletişim kutusunda, İzin kümesi sekmesini LocalIntranetizin kümesi altında görüntülendiğini bildirimi tıklatın.

Referanslar

<a1>Bölümü</a1> Microsoft Windows Server 2003 Service Pack 1 (SP1) Platform Software Development Kit'e (SDK), Orca aracıdır. Windows Server 2003 SP1 Platform SDK hakkında daha fazla bilgi için aşağıdaki Microsoft Web sitesini ziyaret edin:
http://www.microsoft.com/downloads/details.aspx?familyid=A55B6B43-E24F-4EA3-A93E-40C0EC4F68E5
Kod erişimi güvenlik ilkesi aracı hakkında daha fazla bilgi için aşağıdaki MSDN Web sitesini ziyaret edin:
http://msdn2.microsoft.com/en-us/library/cb6t8dtz(vs.80).aspx

Özellikler

Makale numarası: 931867 - Last Review: 9 Mayıs 2007 Çarşamba - Gözden geçirme: 1.2
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft .NET Framework 2.0
  • Microsoft Visual Studio 2005 Standard Edition
  • Microsoft Visual Studio 2005 Professional
Anahtar Kelimeler: 
kbmt kbinfo kbhowto KB931867 KbMttr
Machine-translated Article
ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.
Makalenin İngilizcesi aşağıdaki gibidir:931867

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com