Windows Vista incorrectly detects the miniport edge of PassThru as a WLAN adapter when you use the PassThru Intermediate Driver from the Windows Driver Kit

Article translations Article translations
Article ID: 932030 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

You create a device driver that is based on the Microsoft PassThru Network Driver Interface Specification (NDIS) Intermediate Driver from the Windows Driver Kit (WDK). Then, you install this device driver on a computer that is running Windows Vista. When you restart the computer, Windows Vista incorrectly detects the miniport edge of the PassThru driver as a wireless local area network (WLAN) adapter.

Therefore, if you access the WLAN adapter manually, you may be unable to connect to a wireless access point.

CAUSE

This problem occurs because the WLAN API incorrectly returns the intermediate driver as an interface that is not in a ready state.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required to apply this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, 32-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Report.system.wireless.xmlNot Applicable59,62007-Jan-200705:38Not Applicable
Rules.system.wireless.xmlNot Applicable164,68007-Jan-200705:38Not Applicable
Wlansvc.dll6.0.6000.20522502,78425-Jan-200705:16x86
Wlanmsm.dll6.0.6000.20522290,81625-Jan-200705:16x86
Wlansec.dll6.0.6000.20522297,98425-Jan-200705:16x86
Wlanhlp.dll6.0.6000.2052267,58425-Jan-200705:16x86
Wlanapi.dll6.0.6000.2052247,10425-Jan-200705:16x86
Windows Vista, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wlansec.dll6.0.6000.20522372,22425-Jan-200706:24x64
Wlanmsm.dll6.0.6000.20522350,20825-Jan-200706:24x64
Wlansvc.dll6.0.6000.20522603,64825-Jan-200706:24x64
Wlanhlp.dll6.0.6000.2052297,79225-Jan-200706:24x64
Wlanapi.dll6.0.6000.2052262,97625-Jan-200706:24x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 932030 - Last Review: October 8, 2011 - Revision: 4.0
APPLIES TO
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Starter
Keywords: 
kbautohotfix kbvistasp1fix kbexpertiseadvanced kbbug kbfix kbHotfixServer kbqfe KB932030

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com