Při práci s položkami ve velkém souboru PST nebo OST v aplikaci Outlook 2007 může dojít k problémům s výkonem

Překlady článku Překlady článku
ID článku: 932086 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Aplikace Microsoft Office Outlook 2007 během obvyklých operací na chvíli přestane odpovídat. Mezi tyto operace patří čtení, přesouvání a odstraňování e-mailů.

Tyto příznaky jsou nejnápadnější při doručování pošty nebo během synchronizace. Tyto příznaky se čím dál výrazněji projevují se vzrůstající velikostí úložiště. Blíží-li se velikost soboru PST nebo OST ke 2 GB, je jejich výskyt pravděpodobnější. Ještě důrazněji se projeví při skutečně velkých souborech PST nebo OST s velikostí 4 GB nebo vyšší.

Poznámka: Když provádíte stejné operace s dřívějšími verzemi aplikace Outlook, velikost souboru PST nebo OST nevede ke stejným problémů s výkonem.

Příčina

Aplikace Outlook 2007 přináší novou datovou strukturu souborů PST a OST, díky které lze používat nové funkce. Frekvence zápisu dat na pevný disk se v této nové datové struktuře zvyšuje se zvyšováním počtu položek v souborech PST a OST.

Poznámka: Bez této nové datové struktury nelze vytvořit soubor PST nebo OST.

Řešení

Chcete-li tento problém vyřešit, nainstalujte aktualizaci popsanou v následujícím článku znalostní báze Microsoft Knowledge Base:
933493 Popis aktualizace pro aplikaci Outlook 2007: 13. dubna 2007 (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
Za účelem obecného zrychlení reakce aplikace Outlook 2007 během běžných operací je k dispozici aktualizace 933493. Mezi tyto operace patří čtení, přesouvání, odstraňování a stahování e-mailových zpráv u těch uživatelů, jejichž soubory poštovních schránek v počítači (soubory PST a OST) jsou velké. Z technického hlediska tato aktualizace optimalizuje vzorec chování, podle kterého aplikace Outlook 2007 zapisuje do velkého souboru PST nebo OST. Výsledkem je snížení objemu práce s diskem (počet přístupů).

Tato aktualizace pro aplikaci Outlook 2007 je součástí naší trvalé snahy o zlepšování práce zákazníků s našimi produkty. Jsme si vědomi, že u některých zákazníků došlo při používání aplikace Outlook 2007 k problémům s výkonem. Tato aktualizace obsahuje několik vylepšení výkonu. Touto aktualizací se provedou následující změny:
  • Sníží se doba potřebná ke zkopírování nebo přesunutí zpráv z jedné složky do druhé.
  • Dojde ke zvýšení rychlosti stahování při stahování zpráv.
  • Sníží se doba potřebná k odstranění zpráv.

Další informace

Pomocí jedné z následujících metod můžete tento problém vyřešit či minimalizovat.

Metoda 1: Snížení velikosti poštovní schránky na serveru Exchange

Pokud snížíte velikost poštovní schránky na serveru Exchange, dojde také ke snížení velikosti souboru OST. Chcete-li snížit velikost poštovní schránky na serveru Exchange, postupujte takto:
  • Odstraňte položky v poštovní schránce.
  • Archivujte položky poštovní schránky do jednoho nebo více souborů PST.
Položky lze odstraňovat i archivovat ručně. Můžete také použít nástroj Vyčištění poštovní schránky. Chcete-li použít nástroj Vyčištění poštovní schránky v aplikaci Outlook 2007, klepněte v nabídce Nástroje na příkaz Vyčištění poštovní schránky. V dialogovém okně Vyčištění poštovní schránky lze použít následující funkce:
  • Zobrazit velikost schránky.
  • Najít položky starší než zadaný počet dní.
  • Najít položky větší než zadaná velikost.
  • Klepnutím na tlačítko Automaticky archivovat přesunout staré položky do souboru archivu.
  • Vyprázdnit složku s odstraněnými položkami.
  • Odstranit všechny alternativní verze položek v poštovní schránce.

Metoda 2: Použití profilu v režimu online místo profilu v režimu s mezipamětí

Profily v režimu s mezipamětí používají soubor OST pro ukládání poštovní schránky místně na pevný disk. Pokud je velikost vaší poštovní schránky na serveru Exchange velká, bude velikost souboru OST ještě větší. Je-li například velikost poštovní schránky 350 megabajtů (MB), velikost souboru OST může být 475 MB nebo i větší.

Metoda 3: Rozdělení velkého souboru PST do několika menších souborů PST

Aplikace Outlook 2007 nemá vestavěnou funkci rozdělení souboru PST do více souborů PST. Chcete-li proto rozdělit velký soubor PST, je třeba postupovat takto:
  1. Pomocí funkce Archivovat přesuňte položky do nového souboru PST. Postupujte následujícím způsobem:
    1. V aplikaci Outlook 2007 vyberte v navigačním podokně svůj soubor PST.
    2. V nabídce Soubor klepněte na příkaz Archivovat.
    3. V dialogovém okně Archivovat zaškrtněte políčko Archivovat složku se všemi podsložkami a potom klepněte na složku ze seznamu.
    4. V rozvíracím seznamu Archivovat položky starší než klepněte na datum.
    5. Klepněte na tlačítko Procházet, zadejte cestu a název nového souboru PST a potom klepněte na tlačítko OK.

      Poznámka: Nový soubor PST je zobrazen v seznamu Poštovní složky jako Složky archivu.
    Pokud chcete změnit zobrazovaný název tohoto souboru PST, postupujte takto:
    1. Klepněte pravým tlačítkem myši na položku Složky archivu a potom klepněte na příkaz Vlastnosti.
    2. V dialogovém okně Vlastnosti – Složky archivu klepněte na tlačítko Upřesnit.
    3. Do pole Název v dialogovém okně Osobní složky zadejte nový název složky.
    4. Chcete-li se vrátit do aplikace Outlook, klepněte dvakrát na tlačítko OK.
  2. Pomocí funkce Přesunout do složky přesunete položky do nového souboru PST. Postupujte následujícím způsobem:
    1. V nabídce Soubor přejděte na příkaz Nový a potom klepněte na položku Datový soubor aplikace Outlook.
    2. V dialogovém okně Nový datový soubor aplikace Outlook klepněte na položku Soubor osobních složek (PST) aplikace Office Outlook a potom klepněte na tlačítko OK.
    3. Zadejte cestu a název nového souboru PST.
    4. Do pole Název v dialogovém okně Vytvořit osobní složky zadejte zobrazovaný název souboru PST. Tento název používá aplikace Outlook v seznamu Poštovní složky.
    5. Ve složce obsahující položky, které chcete přesunout do nového souboru PST, klepněte na jednu či více položek určených k přesunutí.
    6. V nabídce Úpravy klepněte na příkaz Přesunout do složky.
    7. V dialogovém okně Přesunout položky klepněte na tlačítko Nová.
    8. V dialogovém okně Vytvořit novou složku zadejte název nové složky do pole Název.
    9. V seznamu Vyberte umístění složky klepněte na nový soubor PST a potom klepněte na tlačítko OK.
    10. V dialogovém okně Přesunout položky zkontrolujte, zda je v novém souboru PST vybraná nová složka, a potom klepněte na tlačítko OK.

Metoda 4: Omezení položek synchronizovaných ze serveru Exchange do souboru OST pomocí filtru

Chcete-li nakonfigurovat filtr synchronizace na konkrétní složku poštovní schránky na serveru Exchange, postupujte takto:
  1. Klepněte na tuto složku pravým tlačítkem myši a poté klepněte na příkaz Vlastnosti.
  2. V dialogovém okně Vlastnosti klepněte na kartu Synchronizace.
  3. Na kartě Synchronizace klepněte na tlačítko Filtr.
  4. V dialogovém okně Filtr zadejte kritéria pro synchronizaci nových položek, které chcete dostávat do této složky.
  5. Chcete-li se vrátit do aplikace Outlook, klepněte dvakrát na tlačítko OK.
Poznámka: Tato metoda sníží aktuální velikost souboru OST. Při příští synchronizaci této složky budou z místní kopie souboru OST odebrány dříve synchronizované položky nacházející se v této složce. Budou odebrány položky, které nesplňují kritéria filtru. Před zobrazením poklesu velikosti souboru OST bude možná třeba počkat, než proběhne komprese na pozadí. Případně můžete také klepnutím na tlačítko Komprimovat v upřesňujících nastaveních e-mailového účtu provést ruční kompresi souboru OST.

Používáte-li filtr synchronizace, můžete zobrazit položky nesynchronizované se souborem OST pomocí aplikace Microsoft Outlook Web Access nebo pomocí klienta aplikace Outlook, který je nakonfigurovaný na režim online v profilu aplikace Outlook.

Pokud používáte přenosný počítač

Pokud používáte přenosný počítač, můžete se s těmito problémy setkat dříve, než byste se s nimi setkali ve stolním počítači. K těmto problémům dochází dříve, protože pevné disky v přenosných počítačích bývají obecně pomalejší než pevné disky ve stolních počítačích. Problémy s výkonem přímo souvisejí s rychlostí pevného disku. Pokud do počítače přidáte další paměť RAM, nebude to mít na tento problém žádný účinek.

Odkazy

Další informace o souborech PST aplikace Outlook naleznete v následujících článcích znalostní báze Microsoft Knowledge Base:
830336 Soubor PST má v aplikacích Outlook 2007 a Outlook 2003 jiný formát a limit velikosti složky
832925 Konfigurace limitu velikosti pro soubory PST a OST v aplikacích Outlook 2007 a Outlook 2003
Poznámka: Cesta v registru použitá v článku 832925 je určená pro aplikaci Outlook 2003. Pro aplikaci Outlook 2007 použijte cestu \12.0, nikoli cestu \11.0 uvedenou v článku.

Vlastnosti

ID článku: 932086 - Poslední aktualizace: 11. ledna 2008 - Revize: 4.1
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Office Outlook 2007
Klíčová slova: 
kbtshoot kbbug kbfix kbprb kbemail kbpubtypekc kbexpertisebeginner kboffice2007postrtmfix KB932086

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com