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You cannot install some programs after you restore Windows Vista by using a Windows Complete PC Backup and Restore image

Article ID:932142
Last Review:August 29, 2007
Revision:4.2
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SYMPTOMS

After you restore a Windows Vista-based computer by using a Windows Complete PC Backup and Restore image, you may be unable to install certain programs. When this problem occurs, you may receive the following error message:
The Directory Name is Invalid.

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CAUSE

This problem occurs because the Temp folder (%temp%) is not restored after you restore the backup. Typically, the Temp folder is found in the following location:
C:\Windows\Temp

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RESOLUTION

To resolve this problem after the problem has occurred

To resolve this problem after the problem has occurred, you must re-create the Temp folder. Also, you must make sure that the Temp folder has the correct permissions. To do this, follow these steps:
1.Click Start Start button , click All Programs, and then click Accessories.
2.Right-click Command Prompt, and then click Run as Administrator.

 User Account Control permission If you are prompted for an administrator password or confirmation, type your password or click Continue.
3.Type the following command at the command prompt, and then press ENTER:
md %windir%\temp
Note Leave the Command Prompt window open, because you must use it again.
4.Click Start Start button , type %windir% in the Start Search box, and then click Windows in the Programs list.
5.Right-click the Temp folder, and then click Properties.
6.Click the Security tab, click Advanced, and then click Edit.

 User Account Control permission If you are prompted for an administrator password or confirmation, type your password or click Continue.
7.Click to clear the Include inheritable permissions from this object's parent check box.
8.Click Remove, and then click OK.
9.You will receive two warning messages. Click Yes in each warning message.
10.Click OK two times to close the Advanced Security Settings dialog box and the folder properties dialog box.
11.Open the Command Prompt window again.
12. Type the following command at the command prompt, and then press ENTER:
icacls %windir%\temp /grant "BUILTIN\Users:(CI)(S,WD,AD,X)" "BUILTIN\Administrators:(F)" "BUILTIN\Administrators:(OI)(CI)(IO)(F)" "NT AUTHORITY\SYSTEM:(F)" "NT AUTHORITY\SYSTEM:(OI)(CI)(IO)(F)" "CREATOR OWNER:(OI)(CI)(IO)(F)"
Note you must type the command on a single line exactly as it appears here, and you must include all quotation marks.

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To prevent this problem

To prevent this problem, install the hotfix that is mentioned in this Microsoft Knowledge Base article.

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Hotfix information

A supported hotfix is now available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem, submit a request to Microsoft Online Customer Services to obtain the hotfix. To submit an online request to obtain the hotfix, visit the following Microsoft Web site:
http://go.microsoft.com/?linkid=6294451 (http://go.microsoft.com/?linkid=6294451)
Note If additional issues occur or any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. To create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Update-bf.mumNot Applicable1,93530-Jan-200716:45Not Applicable
Update.mumNot Applicable2,65130-Jan-200716:42Not Applicable
Wbengine.exe6.0.6000.16427562,17630-Jan-200702:59x86
Windows6.0-kb932142-x86.psfNot Applicable611,12530-Jan-200717:25Not Applicable
Wbengine.exe6.0.6000.20525562,17630-Jan-200701:43x86
X86_microsoft-windows-blb-engine-main.d_31bf3856ad364e35_6.0.6000.16427_none_906e276ee2b42a25.manifestNot Applicable70730-Jan-200716:42Not Applicable
X86_microsoft-windows-blb-engine-main.d_31bf3856ad364e35_6.0.6000.20525_none_90f5c3a5fbd39741.manifestNot Applicable70730-Jan-200716:42Not Applicable
X86_microsoft-windows-blb-engine-main_31bf3856ad364e35_6.0.6000.16427_none_e1ed15b402a346dd.manifestNot Applicable11,30830-Jan-200716:45Not Applicable
X86_microsoft-windows-blb-engine-main_31bf3856ad364e35_6.0.6000.20525_none_e274b1eb1bc2b3f9.manifestNot Applicable11,30830-Jan-200716:45Not Applicable
Windows Vista, 64-bit versions
File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-blb-engine-main.d_31bf3856ad364e35_6.0.6000.16427_none_ec8cc2f29b119b5b.manifestNot Applicable71130-Jan-200716:42Not Applicable
Amd64_microsoft-windows-blb-engine-main.d_31bf3856ad364e35_6.0.6000.20525_none_ed145f29b4310877.manifestNot Applicable71130-Jan-200716:42Not Applicable
Amd64_microsoft-windows-blb-engine-main_31bf3856ad364e35_6.0.6000.16427_none_3e0bb137bb00b813.manifestNot Applicable11,33630-Jan-200716:49Not Applicable
Amd64_microsoft-windows-blb-engine-main_31bf3856ad364e35_6.0.6000.20525_none_3e934d6ed420252f.manifestNot Applicable11,33630-Jan-200716:49Not Applicable
Update-bf.mumNot Applicable1,93530-Jan-200716:45Not Applicable
Update.mumNot Applicable2,65130-Jan-200716:42Not Applicable
Wbengine.exe6.0.6000.16427702,97630-Jan-200704:45x64
Windows6.0-kb932142-x64.psfNot Applicable807,55730-Jan-200717:25Not Applicable
Wbengine.exe6.0.6000.20525702,97630-Jan-200701:59x64

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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MORE INFORMATION

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 (http://support.microsoft.com/kb/816915/) New file naming schema for Microsoft Windows software update packages
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

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APPLIES TO
Windows Vista Ultimate
Windows Vista Enterprise
Windows Vista Business
Windows Vista Ultimate 64-bit Edition
Windows Vista Enterprise 64-bit Edition

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Keywords: 
kbvistasp1fix kbexpertiseinter kbfix kbhotfixserver kbqfe kbexpertisebeginner KB932142

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