ID do artigo: 932142 - Última revisão: quinta-feira, 21 de fevereiro de 2008 - Revisão: 4.4

Não é possível instalar alguns programas depois de restaurar o Windows Vista usando uma "Imagem de backup e restauração do Windows Complete PC"

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Depois de restaurar um computador com base no Windows Vista usando "Imagem de backup e restauração do Windows Complete PC", talvez não seja possível instalar determinados programas. Quando esse problema ocorre, a seguinte mensagem de erro é exibida:
O nome do diretório é inválido.

Causa

Esse problema ocorre porque a pasta Temp (%temp%) não é restaurada após a restauração do backup. Normalmente, a pasta Temp é encontrada no seguinte local:
C:\Windows\Temp

Resolução

Para resolver esse problema depois que ele já tiver ocorrido

Para resolver esse problema depois que ele tiver ocorrido, é necessário recriar a pasta Temp. Além disso, é necessário verificar se a pasta Temp tem as permissões corretas. Para fazer isto, execute as seguintes etapas:
  1. Clique em Iniciar
    Recolher esta imagemExpandir esta imagem
     Botão Iniciar
    , clique em Todos os programas, e clique em Acessórios.
  2. Clique com o botão direito do mouse em Prompt de Comando e clique em Executar como administrador.

    Recolher esta imagemExpandir esta imagem
    Permissão Controle de Conta de
				Usuário
    Caso seja solicitada a senha de administrador ou a confirmação, digite a senha ou clique em Continuar.
  3. Digite o seguinte comando no prompt de comando e pressione ENTER:
    md %windir%\temp
    Observação Deixe a janela do prompt de comando aberta, pois você deve usá-la novamente.
  4. Clique em Iniciar
    Recolher esta imagemExpandir esta imagem
    botão Iniciar
    , digite %windir% na caixa Iniciar pesquisa, em seguida, clique em Windows na lista Programas.
  5. Clique com o botão direito do mouse na pasta Temp e clique em Propriedades.
  6. Clique na guia Segurança, em Avançadas e clique em Editar.

    Recolher esta imagemExpandir esta imagem
    Permissão Controle de Conta de
				Usuário
    Caso seja solicitada a senha de administrador ou a confirmação, digite a senha ou clique em Continuar.
  7. Desmarque a caixa de seleção Incluir permissões herdáveis provenientes do pai deste objeto.
  8. Clique em Remover e em OK.
  9. Duas mensagens de aviso são exibidas. Clique em Sim para cada mensagem de aviso.
  10. Clique em OK duas vezes para fechar a caixa de diálogo Configurações de segurança avançadas e a caixa de diálogo das propriedades da pasta.
  11. Abra a janela do prompt de comando novamente.
  12. Digite o seguinte comando no prompt de comando e pressione ENTER:
    icacls %windir%\temp /grant "BUILTIN\Users:(CI)(S,WD,AD,X)" "BUILTIN\Administrators:(F)" "BUILTIN\Administrators:(OI)(CI)(IO)(F)" "NT AUTHORITY\SYSTEM:(F)" "NT AUTHORITY\SYSTEM:(OI)(CI)(IO)(F)" "CREATOR OWNER:(OI)(CI)(IO)(F)"
    Observação É necessário digitar o comando em uma única linha exatamente como aparece aqui e incluir todas as aspas.

Para evitar esse problema

Para evitar esse problema, instale o hotfix mencionado no artigo da Base de Dados de Conhecimento Microsoft.

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Testes adicionais podem ser realizados nesse hotfix. Por isso, se esse problema não o prejudicar seriamente, é recomendável que você aguarde o próximo service pack que contenha esse hotfix.

Para resolver esse problema, envie uma solicitação para o Atendimento ao Cliente Online Microsoft para obter o hotfix. Para enviar a solicitação online para obter o hotfix, visite o seguinte site da Microsoft:
http://support.microsoft.com/gp/CUHotFix_LandingPage_Request (http://go.microsoft.com/?linkid=6294451)
Observação Se outros problemas ocorrerem ou se uma solução de problema for requisitada, pode ser necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não sejam específicos deste hotfix.Para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

Informações sobre o arquivo

A versão em inglês desse hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horários destes arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário no item Data e hora do Painel de Controle.
Windows Vista, versões com base em x86
Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataforma
Update-bf.mumNão aplicável1.93530.01.200716:45Não aplicável
Update.mumNão aplicável2.65130.01.200716:42Não aplicável
Wbengine.exe6.0.6000.16427562.17630-Jan-200702:59x86
Windows6.0-kb932142-x86.psfNão aplicável611.12530-Jan-200717:25Não aplicável
Wbengine.exe6.0.6000.20525562.17630-Jan-200701:43x86
X86_microsoft-windows-blb-engine-main.d_31bf3856ad364e35_6.0.6000.16427_none_906e276ee2b42a25.manifestNão aplicável70730-Jan-200716:42Não aplicável
X86_microsoft-windows-blb-engine-main.d_31bf3856ad364e35_6.0.6000.20525_none_90f5c3a5fbd39741.manifestNão aplicável70730-Jan-200716:42Não aplicável
X86_microsoft-windows-blb-engine-main_31bf3856ad364e35_6.0.6000.16427_none_e1ed15b402a346dd.manifestNão aplicável11.30830-Jan-200716:45Não aplicável
X86_microsoft-windows-blb-engine-main_31bf3856ad364e35_6.0.6000.20525_none_e274b1eb1bc2b3f9.manifestNão aplicável11.30830-Jan-200716:45Não aplicável
Versões de 64 bits do Windows Vista
Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataforma
Amd64_microsoft-windows-blb-engine-main.d_31bf3856ad364e35_6.0.6000.16427_none_ec8cc2f29b119b5b.manifestNão aplicável71130-Jan-200716:42Não aplicável
Amd64_microsoft-windows-blb-engine-main.d_31bf3856ad364e35_6.0.6000.20525_none_ed145f29b4310877.manifestNão aplicável71130-Jan-200716:42Não aplicável
Amd64_microsoft-windows-blb-engine-main_31bf3856ad364e35_6.0.6000.16427_none_3e0bb137bb00b813.manifestNão aplicável11.33630-Jan-200716:49Não aplicável
Amd64_microsoft-windows-blb-engine-main_31bf3856ad364e35_6.0.6000.20525_none_3e934d6ed420252f.manifestNão aplicável11.33630-Jan-200716:49Não aplicável
Update-bf.mumNão aplicável1.93530-Jan-200716:45Não aplicável
Update.mumNão aplicável2.65130-Jan-200716:42Não aplicável
Wbengine.exe6.0.6000.16427702.97630-Jan-200704:45x64
Windows6.0-kb932142-x64.psfNão aplicável807.55730-Jan-200717:25Não aplicável
Wbengine.exe6.0.6000.20525702.97630-Jan-200701:59x64

Situação

A Microsoft confirmou que este é um problema nos produtos Microsoft que estão listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre como os pacotes de hotfix são nomeados, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
816915  (http://support.microsoft.com/kb/816915/ ) Novo esquema para nomeação de arquivos para os pacotes de atualização de software do Microsoft Windows
Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft

A informação contida neste artigo aplica-se a:
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Enterprise 64-bit edition
Palavras-chave: 
kbvistasp1fix kbexpertiseinter kbfix kbhotfixserver kbqfe kbexpertisebeginner KB932142