หมายเลขบทความ (Article ID): 932156 - รีวิวครั้งสุดท้าย: 16 มกราคม 2554 - Revision: 4.0

คุณไม่สามารถดูข้อมูลใบรับรอง ใน Windows Internet Explorer 7 หรือในตัว จัดการใบรับรองหลังจากที่คุณนำเข้าใบรับรองบนคอมพิวเตอร์ที่ใช้ Windows Vista เสร็จเรียบร้อยแล้ว

เคล็ดลับของระบบThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.

เนื้อหาบนหน้านี้

ขยายทั้งหมด | ยุบทั้งหมด

อาการ

หลังจากที่คุณนำสำเร็จเข้าใบรับรองบนคอมพิวเตอร์ที่ใช้ Windows Vista คุณไม่สามารถดูข้อมูลใบรับรอง ใน Windows Internet Explorer 7 หรือในตัว จัดการใบรับรอง

สาเหตุ

ปัญหานี้เกิดขึ้นหากคุณไม่มีสิทธิ์ในการอ่านสำหรับคีย์ย่อยของรีจิสทรีต่อไปนี้:
HKEY_CURRENT_USER\Software\Microsoft\SystemCertificates\Root\ProtectedRoots

การแก้ไข

ข้อมูลการดาวน์โหลด

<a0>$$$$</a0>Microsoft::

การปรับปรุงสำหรับ Windows Vista
ยุบรูปภาพนี้ขยายรูปภาพนี้
ดาวน์โหลด
ดาวน์โหลดแพคเกจโปรแกรมปรับปรุงสำหรับ Windows Vista (KB932156) (http://www.microsoft.com/downloads/details.aspx?FamilyId=7A0FF471-ACE1-4B82-8CD8-1529B9B03AEF)

การปรับปรุงสำหรับ Windows Vista สำหรับ x ระบบที่ใช้ x64
ยุบรูปภาพนี้ขยายรูปภาพนี้
ดาวน์โหลด
ดาวน์โหลดการปรับปรุงสำหรับ Windows Vista สำหรับ x 64-แพ็คเกจตามระบบ (KB932156) ในขณะนี้ (http://www.microsoft.com/downloads/details.aspx?FamilyId=49CD3BDD-2B60-4480-86C3-3D0658F6704D)

หมายเหตุ:หลังจากที่คุณใช้การปรับปรุงไปยังคอมพิวเตอร์ ค้นหาแฟ้ม Portreg.exe ในเส้นทางต่อไปนี้:
<drive>: เครื่อง \Program Files\Microsoft Corporation\Microsoft ProtectedRoots การปรับปรุงรีจิสทรีคีย์มือ (KB932156)</drive>
เมื่อต้องการเปิดการใช้งานโปรแกรมแก้ไขด่วนนี้ คลิกสองครั้งที่แฟ้ม Portreg.exe

หากต้องการทราบข้อมูลเพิ่มเติมเกี่ยวกับการดาวน์โหลดไฟล์การสนับสนุนของไมโครซอฟท์ โปรดคลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base::
119591  (http://support.microsoft.com/kb/119591/ ) วิธีรับแฟ้มการสนับสนุนของไมโครซอฟท์จากบริการออนไลน์
Microsoft สแกนแฟ้มนี้เพื่อหาไวรัส Microsoft ใช้ซอฟต์แวร์ตรวจสอบไวรัสล่าสุด ณ วันที่มีการประกาศแฟ้มนั้นๆ แฟ้มดังกล่าวจะถูกจัดเก็บในเซิร์ฟเวอร์เพิ่มการรักษาความปลอดภัย ซึ่งช่วยป้องกันการเปลี่ยนแปลงแฟ้มโดยไม่ได้รับอนุญาต

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการแก้ไขปัญหานี้ ให้คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
942543  (http://support.microsoft.com/kb/942543/ ) คุณไม่สามารถดูข้อมูลใบรับรอง ใน Windows Internet Explorer 7 หรือในตัว จัดการใบรับรองถ้าคุณใช้แฟ้มคำตอบที่มีการทำงานอัตโนมัติการติดตั้ง Windows Vista

วิธีการแก้ไขปัญหานี้ โดยการปรับเปลี่ยนรีจิสทรี

สิ่งสำคัญนี้ส่วน วิธี หรืองานประกอบด้วยขั้นตอนที่บอกวิธีการแก้ไขรีจิสทรี อย่างไรก็ตาม ปัญหาร้ายแรงอาจเกิดขึ้นหากคุณปรับเปลี่ยนรีจิสทรีไม่ถูกต้อง ดังนั้น โปรดตรวจสอบให้แน่ใจว่าคุณได้ทำตามขั้นตอนเหล่านี้อย่างระมัดระวัง สำหรับการป้องกันเพิ่มเติม ให้สำรองรีจิสทรีก่อนทำการปรับเปลี่ยน เพื่อที่คุณจะสามารถคืนค่ารีจิสทรีได้หากมีปัญหาเกิดขึ้น สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการสำรองข้อมูลและคืนค่ารีจิสทรี โปรดคลิกที่หมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
322756  (http://support.microsoft.com/kb/322756/ ) วิธีการสำรองข้อมูลและคืนค่ารีจิสทรีใน Windows


เมื่อต้องการแก้ไขปัญหานี้ กำหนดสิทธิ์สำหรับอ่าน
ProtectedRoots
คีย์รีจิสทรีไปยังผู้ใช้ที่อยู่ในขณะนี้สู่คอมพิวเตอร์ โดยให้ทำตามขั้นตอนต่อไปนี้::
  1. คลิกเริ่มการทำงาน
    ยุบรูปภาพนี้ขยายรูปภาพนี้
    เริ่มการทำงานของปุ่ม
    ประเภท:regeditในการเริ่มการค้นหากล่อง แล้วคลิกregedit.exeในการโปรแกรมรายการ

    ยุบรูปภาพนี้ขยายรูปภาพนี้
    สิทธิ์ในการควบคุมบัญชีผู้ใช้
    ถ้าคุณได้รับการพร้อมท์ สำหรับรหัสผ่านของผู้ดูแลระบบ หรือยืนยัน พิมพ์รหัสผ่านของคุณ หรือคลิกดำเนินการต่อ.
  2. ค้นหาและคลิกขวาที่คีย์ย่อยของรีจิสตรีต่อไปนี้::
    HKEY_CURRENT_USER\Software\Microsoft\SystemCertificates\Root\ProtectedRoots
  3. คลิกPermissions:.
  4. ใช้วิธีการอย่างใดอย่างหนึ่งต่อไปนี้::
    • ถ้าผู้ใช้ที่อยู่ในขณะนี้สู่คอมพิวเตอร์อยู่ในนั้นชื่อกลุ่มหรือผู้ใช้กล่อง คลิกชื่อของผู้ใช้ คลิกเพื่อเลือกนั้นReadกล่องกาเครื่องหมายที่อยู่ในนั้นอนุญาตให้คอลัมน์ แล้วคลิกตกลง.
    • ถ้าผู้ใช้ที่อยู่ในขณะนี้สู่เครื่องคอมพิวเตอร์ไม่มีอยู่ในนั้นชื่อกลุ่มหรือผู้ใช้กล่อง ทำตามขั้นตอนเหล่านี้:
      1. คลิกadd.
      2. พิมพ์ชื่อของผู้ใช้ที่อยู่ในขณะนี้สู่เครื่องคอมพิวเตอร์ และจากนั้น คลิกตกลง.
      3. ในการชื่อกลุ่มหรือผู้ใช้กล่อง เลือกชื่อผู้ใช้ คลิกเพื่อเลือกนั้นReadกล่องกาเครื่องหมายที่อยู่ในนั้นอนุญาตให้คอลัมน์ แล้วคลิกตกลง.
  5. ออกจาก "ตัวแก้ไขรีจิสทรี"
หมายเหตุ:ถ้าผู้ใช้โดเมนจะเข้าสู่ระบบ โดยใช้ข้อมูลประจำตัวที่แคช และไม่ได้เชื่อมต่อกับโดเมน ผู้ใช้โดเมนจะไม่สามารถเพิ่มสิทธิ์สำหรับบัญชีผู้ใช้โดเมนของตนไปยังรีจิสทรีคีย์ในขั้นตอนเหล่านี้ คุณต้องเข้าสู่ระบบคอมพิวเตอร์ที่ใช้อยู่ และเพิ่มบัญชีผู้ใช้ท้องถิ่นให้ใช้สิทธิ์สำหรับคีย์รีจิสทรี คุณสามารถแล้วติดสำเร็จตั้งใบรับรอง

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "การใช้งาน"
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use (http://go.microsoft.com/fwlink/?LinkId=151500) for other considerations.

ใช้กับ
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
Keywords: 
kbharmony kbbug kbexpertiseinter kbexpertisebeginner kbtshoot kbmt KB932156 KbMtth
แปลโดยคอมพิวเตอร์แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:932156  (http://support.microsoft.com/kb/932156/en-us/ )