Artigo: 932206 - Última revisão: sexta-feira, 23 de Maio de 2008 - Revisão: 2.1

Mensagem de erro quando tenta instalar automaticamente uma impressora com um controlador de impressora desconhecido no Windows Vista: "STATUS_ACCESS_VIOLATION (0xc0000005)"

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

No Windows Vista, poderá receber a mensagem de erro seguinte quando tentar instalar automaticamente uma impressora que tenha um controlador de impressora desconhecido:
STATUS_ACCESS_VIOLATION (0xc0000005)

Causa

Este problema ocorre porque o processo Rundll32.exe não funciona correctamente.

Resolução

Informações sobre a correcção

A Microsoft tem já disponível uma correcção suportada para este problema. Contudo, esta correcção destina-se apenas a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá ser submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde o próximo Service Pack que contenha esta correcção.

Para resolver este problema, submeta um pedido ao Serviço de Suporte ao Cliente Online da Microsoft para obter a correcção. Para submeter um pedido online para obter a correcção, visite o seguinte Web site da Microsoft :
http://go.microsoft.com/?linkid=6294451 (http://go.microsoft.com/?linkid=6294451)
Nota: caso ocorram problemas adicionais ou seja necessário efectuar algum procedimento para resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas e questões de suporte adicionais, não incluídos nesta correcção específica. Para criar um pedido de assistência separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

Pré-requisitos

Para aplicar esta correcção, tem de ter a versão original do Windows Vista instalada.

Necessidade de reinício

É necessário reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções.

Informações sobre os ficheiros

A versão inglesa desta correcção tem os atributos de ficheiro listados na tabela que se segue (ou atributos de ficheiro posteriores). As datas e horas destes ficheiros são indicadas no formato UTC (Coordinated Universal Time). Ao visualizar as informações dos ficheiros, estas serão convertidas na hora local. Para determinar a diferença entre a hora UTC e a hora local, utilize o separador Fuso Horário do item Data e Hora do Painel de Controlo.
Windows Vista, versões de 32 bits
Reduzir esta tabelaExpandir esta tabela
Nome do ficheiroVersão do ficheiroTamanho do ficheiroDataHoraPlataforma
Printui.dll6.0.6000.20530857,60006-Fev-200703:40x86
Windows Vista, versões de 64 bits
Reduzir esta tabelaExpandir esta tabela
Nome do ficheiroVersão do ficheiroTamanho do ficheiroDataHoraPlataforma
Printui.dll6.0.6000.20530975,36006-Fev-200704:43x64
Printui.dll6.0.6000.20530857,60006-Fev-200703:40x86

Ponto Da Situação

A Microsoft confirmou que este problema ocorre nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Para obter mais informações sobre a terminologia utilizada para descrever actualizações de software, clique no número de artigo que se segue para visualizar o artigo na Base de Dados de Conhecimento Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

A informação contida neste artigo aplica-se a:
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise 64-bit edition
Palavras-chave: 
kbvistasp1fix kbexpertiseinter kbfix kbhotfixserver kbqfe kbpubtypekc KB932206