El UUID crear en Windows XP sólo es único en el equipo local

Seleccione idioma Seleccione idioma
Id. de artículo: 932380 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando se crea un identificador único universal (UUID) en un equipo que ejecuta Microsoft Windows XP, el UUID que cree sólo es único en el equipo local. Este problema se produce si un dispositivo de basado 5.0 de Microsoft Windows Mobile está conectado al equipo mediante un conector USB.

En concreto, si utiliza la función UuidCreateSequential para crear un UUID, la función UuidCreateSequential devuelve un valor RPC_S_UUID_LOCAL_ONLY . Este valor indica que el UUID se garantiza que único sólo en el equipo local. Si utiliza la herramienta uuidgen.exe para crear un UUID, la herramienta uuidgen.exe devuelve un UUID y la herramienta uuidgen.exe muestra el mensaje de advertencia siguiente:
Advertencia: No se puede determinar su dirección de red. El UUID generado es único en sólo este equipo. No debe utilizarse en otro equipo.
Nota Este problema no se produce si un dispositivo basado en Microsoft Windows Mobile 2003 está conectado al equipo.

Causa

Este problema se produce porque la conexión con el dispositivo basado en 5.0 de Windows Mobile crea un adaptador de especificación de interfaz de controlador de red remoto (RNDIS). El adaptador RNDIS es un adaptador pseudo-network. Este adaptador RNDIS contiene una dirección de control (MAC) de acceso de medios que no es universalmente única. La función UuidCreateSequential utiliza incorrectamente esta dirección MAC para generar el UUID.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener instalado en el equipo Windows XP Service Pack 2 (SP2). Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el service pack más reciente de Windows XP

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Rpcss.dll5.1.2600.3082399,36013 De febrero de 200712: 51x 86

Solución

Para evitar este problema, desconecte el dispositivo basado en 5.0 de Windows Mobile al crear el UUID.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

La función UuidCreateSequential devuelve un valor RPC_S_UUID_LOCAL_ONLY en lugar de un valor RPC_S_OK cuando el equipo no tiene una dirección Ethernet o una dirección de token ring. Para obtener más información al respecto, visite el siguiente sitio Web de Microsoft:
http://msdn2.microsoft.com/en-us/library/aa379322.aspx
La herramienta uuidgen.exe está disponible en Microsoft Platform Software Development Kit (SDK). Puede utilizar esta herramienta para crear un UUID. Para obtener más información al respecto, visite el siguiente sitio Web de Microsoft:
http://msdn2.microsoft.com/en-us/library/aa373930.aspx
Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 932380 - Última revisión: miércoles, 29 de agosto de 2007 - Versión: 2.1
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Palabras clave: 
kbmt kbautohotfix kbexpertiseinter kbwinxppresp3fix kbfix kbbug kbhotfixserver kbqfe kbpubtypekc KB932380 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 932380

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com