Messaggio di errore quando si esegue il programma di installazione per installare Windows Small Business Server 2003 R2: "L'installazione ha incontrato un errore ed Impossibile continuare"

Traduzione articoli Traduzione articoli
Identificativo articolo: 932441 - Visualizza i prodotti a cui si riferisce l?articolo.
importante Vengono fornite informazioni su come modificare il Registro di sistema. Assicurarsi di backup del Registro di sistema prima di modificarlo. Verificare che come ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
256986Descrizione del Registro di sistema di Microsoft Windows
Espandi tutto | Chiudi tutto

Sintomi

Quando si esegue il programma di installazione per installare Microsoft Windows Small Business Server 2003 R2, il programma di installazione si blocca. Inoltre, viene visualizzato il seguente messaggio di errore:
Errore
Il programma di installazione ha riscontrato un errore e non può continuare.
Quando si fa clic su OK , viene visualizzato il seguente messaggio di errore:
Setup.exe si è verificato un errore e deve chiudere.
Se si sceglie di visualizzare il contenuto del report di errore per visualizzare il contenuto del file Setup.crash, verranno visualizzate informazioni analoghe alle seguenti:
[Information arresto anomalo del sistema]
ReportVersion = 1 MainBinary = Drive: \CD6\sbs\setup.exe
MainBinaryVersion = 5.2.3580.0
CrashTime = Date Time UTC
Exception=System.InvalidOperationException
HResult = 80131509
ExceptionMessage = prestazione thread contatore è disattivato, l'operazione richiesta non può essere eseguita.

[Analisi dello stack]
IP = 0x7b2b31a8 + 1a5 System.Diagnostics.NtProcessManager.GetProcessInfos (System.Diagnos tics.PerformanceCounterLib libreria)
IP = 0x7b2b30e8 + System.Diagnostics.NtProcessManager.GetProcessInfos(System.String machineName, System.Boolean isRemoteMachine) a4
IP = 0x7b2b16c0 + 29 System.Diagnostics.ProcessManager.GetProcessInfos(System.String machineName)
IP = 0x7b2aed70 + 116 System.Diagnostics.Process.EnsureState (stato System.Diagnostics.Process+ stato)
IP = 0x7b2ae240 + 11 System.Diagnostics.Process.get_ProcessName()
IP = 0x02e307f8 + 1ce2 R2_SetupWizard.MainClass.Main (System.String [] args)

Cause

Questo problema si verifica se i contatori di prestazioni Perfproc sono disattivati, risultano mancanti o non funzionano correttamente.

Risoluzione

avviso Può causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

Per risolvere il problema, assicurarsi che siano attivati i contatori di prestazioni Perfproc. Quindi eseguire di nuovo il programma di installazione. Per attivare i contatori di prestazioni Perfproc, attenersi alla seguente procedura:
  1. Fare clic su Start , scegliere Esegui , digitare regedit e quindi fare clic su OK .
  2. Individuare e selezionare la seguente sottochiave:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PerfProc\Performance
  3. Fare clic con il pulsante destro del mouse Disable Performance Counters e quindi fare clic su Modifica .
  4. Nella casella dati valore digitare 0 (zero) e quindi fare clic su OK .
  5. Uscire dall'editor del Registro di sistema.

Informazioni

Per ulteriori informazioni su Windows Small Business Server 2003 R2, visitare il sito di Web di Microsoft:
risorse tecniche per Windows Small Business Server 2003
http://www.microsoft.com/windowsserver2003/sbs/techinfo/default.mspx

Proprietà

Identificativo articolo: 932441 - Ultima modifica: giovedì 22 febbraio 2007 - Revisione: 1.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows Small Business Server 2003 R2 Premium Edition
  • Microsoft Windows Small Business Server 2003 R2 Standard Edition
Chiavi: 
kbmt kberrmsg kbtshoot kbexpertiseinter kbprb KB932441 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 932441
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com