FIX: Messaggio di errore quando si tenta di aprire o creare un documento XPS protetto utilizzando il Visualizzatore XPS incluso in .NET Framework 3.0: "Impossibile aprire questo documento poiché le autorizzazioni sono scadute."

Traduzione articoli Traduzione articoli
Identificativo articolo: 932471 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si tenta di aprire o per creare un documento XPS (XML Paper Specification) protetto con il Visualizzatore XPS incluso in Microsoft .NET Framework 3.0, viene visualizzato il seguente messaggio di errore:
Impossibile aprire il documento poiché le autorizzazioni sono scadute.
Nota Il Visualizzatore XPS è un componente di Microsoft .NET Framework 3.0. .NET Framework 3.0 è incluso in Windows Vista.

Cause

Il Visualizzatore XPS utilizza la funzionalità di Rights Management Services (RMS) in Microsoft Windows per creare e aprire documenti XPS protetti da RMS. RMS utilizza un file di manifesto XML per memorizzare le informazioni di configurazione.

Il problema descritto nella sezione "Sintomi" si verifica perché il file manifesto imposta una data di scadenza non corretta per la funzionalità RMS del Visualizzatore XPS. Se la data di sistema è successiva alla data di scadenza che imposta il file manifesto, è visualizzato il messaggio di errore menzionato nella sezione "Sintomi". Questo problema si verifica, ad esempio, se il file manifesto imposta la data di scadenza per 31 dicembre 2006 e la data di sistema è successiva a 31 dicembre 2006.

Risoluzione

Informazioni sull'hotfix

Un aggiornamento rapido (hotfix) è incluso in .NET Framework 3.5 e in .NET Framework 3.5 Service Pack 1. Per risolvere immediatamente questo problema, installare la versione più recente di .NET Framework utilizzando Windows Update dei comandi. In alternativa, scaricare la versione più recente del service pack dal seguente sito Web:
http://www.microsoft.com/downloads/details.aspx?familyid=AB99342F-5D1A-413D-8319-81DA479AB0D7&displaylang=en

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni sulla terminologia di aggiornamento software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Proprietà

Identificativo articolo: 932471 - Ultima modifica: mercoledì 10 settembre 2008 - Revisione: 2.0
Le informazioni in questo articolo si applicano a:
  • Microsoft .NET Framework 3.0
  • Microsoft .NET Framework 3.5 Service Pack 1
Chiavi: 
kbmt kbvistasp1fix kbhotfixserver kbqfe kbpubtypekc KB932471 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 932471
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com