コールアウトを使用してプログラムでは、Microsoft Dynamics CRM 3. 0 で電子メール メッセージを送信するワークフロー ルールを実行する場合は、ワークフロー モニターでのエラー メッセージ:"0X800404cc"

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文書番号: 932476 - 対象製品
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現象

コールアウトを使用してプログラムでは、Microsoft Dynamics CRM 3. 0 で電子メール メッセージを送信するワークフロー ルールを実行すると、ワークフロー ルールは期待どおり実行されます。 ただし、電子メール メッセージが送信されない、し、ワークフロー モニターで、次のエラー メッセージを受信しました。
0X800404cc
詳細については、例、この資料の後半の「関連情報」「を参照してください。

原因

この問題は、以下のいずれか 1 つ、または複数の状況に該当する場合に発生することがあります:
  • Microsoft CRM ワークフロー サービスがローカル システム アカウントまたはネットワーク サービス アカウントで実行されています。 Microsoft CRM ワークフロー サービスがこれらのアカウントのいずれかで構成されている場合は電子メール メッセージを送信するアクセス許可、ユーザーに基づいています。 この問題が発生すると、アカウントには、Microsoft Dynamics CRM 3. 0 で電子メール メッセージを送信するアクセス許可がありません。
  • CRMAppPool アプリケーション プールと、Microsoft CRM ワークフロー サービスは、下の 2 つの異なるアカウント実行しています。 ワークフロー ルールに、コールアウトからの資格情報を渡すと、CRMAppPool アプリケーション プールと、Microsoft CRM ワークフロー サービスの両方する必要があります、同じアカウントで実行されます。
  • CRMAppPool のアプリケーション プールと、Microsoft CRM ワークフロー サービスを実行してはアカウントに、次のグループのメンバーでないです。
    • Microsoft Dynamics CRM サーバー上のローカル管理者グループ
    • Microsoft Dynamics CRM サーバー上の IIS_WPG グループ
    • Microsoft Dynamics CRM サーバー上の CRM_WPG グループ
    • Active Directory 内の PrivUserGroup
    • Active Directory での SQLAccessGroup グループ

解決方法

この問題を解決するには、次の手順に従います。 ない場合アクティビティ サーバー上でユーザーは、Microsoft Dynamics CRM 3. 0 サーバーへの接続を失うため、手順を完了します。 Microsoft Dynamics CRM にログオンする前のすべての手順のステップ間でのエラー メッセージを受け取ることがあるためにが完了したらする必要があります。

手順 1: システム管理者ロールを持つ Microsoft Dynamics CRM ユーザーとして、Microsoft CRM ワークフロー サービスを開始します。

  1. 開始 ] をクリックして 実行 ] をクリックして、 services.msc ファイルを開く ] と入力して [OK] をクリックします。
  2. Microsoft CRM ワークフロー サービス ] を右クリックし、 プロパティ を実行します。
  3. [ ログオン ] タブをクリックします。
  4. このアカウント をクリックして [Microsoft Dynamics CRM 3. 0 に管理者アカウントの資格情報を入力します。
  5. Microsoft CRM ワークフロー サービスのプロパティ ] ダイアログ ボックスを閉じます [OK] をクリックします。
  6. Microsoft CRM ワークフロー サービス を再開します。

手順 2: Microsoft CRM ワークフロー サービスを実行している同じアカウントで実行する CRMAppPool アプリケーション プールを設定します。

  1. 開始 ] をクリックして、 すべてのプログラム ] をポイントし、 管理ツール ] をポイントして [ インターネット インフォメーション サービス (IIS) マネージャー ] をクリックします。
  2. Microsoft Dynamics CRM 3. 0 サーバー名を展開します。
  3. アプリケーション プール を展開します。
  4. CRMAppPool ] を右クリックし、 プロパティ を実行します。
  5. [ ユーザー ] タブをクリックします。
  6. 構成可能な をクリックして、ユーザーは、 Microsoft CRM ワークフロー サービス を実行してユーザーの資格情報を入力します。
  7. [ CRMAppPool のプロパティ ] ダイアログ ボックスを閉じます [OK] をクリックします。

手順 3: CRMAppPool アプリケーション プールと、Microsoft CRM ワークフロー サービス実行しているユーザーを追加します。

次のグループを実行して、CRMAppPool のアプリケーション プールと、Microsoft CRM ワークフロー サービスのいるユーザーを追加する必要があります。
  • Microsoft Dynamics CRM サーバー上のローカル管理者グループ
  • Microsoft Dynamics CRM サーバー上の IIS_WPG グループ
  • Microsoft Dynamics CRM サーバー上の CRM_WPG グループ
  • Active Directory 内の PrivUserGroup
  • Active Directory での SQLAccessGroup グループ
これを行うには、次の手順を実行します。
  1. Microsoft Dynamics CRM サーバー上で 開始 ] をクリックし、 [マイ コンピューター ] 右クリックし [ 管理 ] をクリックします。
  2. ローカル ユーザーとグループ を展開し、 グループ を実行します。
  3. Administrators グループをダブルクリックして、管理者アカウントをメンバーとして追加します。
  4. IIS_WPG グループをダブルクリックして、管理者アカウントをメンバーとして追加します。
  5. [ CRM_WPG ] </a0> グループをダブルクリックして、管理者アカウントをメンバーとして追加します。
  6. 開始 ] をクリックして 実行 ] をクリックして、 iisreset と入力して [OK] をクリックします。
  7. ドメイン コントローラーで 開始 ] をクリックして 実行 ] をクリックして、 dsa.msc ファイルを開く ] と入力して [OK] をクリックします。
  8. PrivUserGroup グループを右クリックして [ プロパティ ] をクリックします。
  9. [ メンバー ] タブをクリックします。
  10. Microsoft CRM ワークフロー サービスと CRMAppPool のアプリケーション プールを実行しているユーザーを追加する [ 追加 ] をクリックし、 [OK] をクリックします。

    メモ ユーザーが既に存在する場合、次の手順に進みます。
  11. SQLAccessGroup グループを右クリックして [ プロパティ ] をクリックします。
  12. [ メンバー ] タブをクリックします。
  13. Microsoft CRM ワークフロー サービスと CRMAppPool のアプリケーション プールを実行しているユーザーを追加する [ 追加 ] をクリックし、 [OK] をクリックします。

    メモ ユーザーが既に存在する場合、変更する必要はありません。 複数のドメイン コントローラーがある場合は、すべてのサーバーにレプリケートする、変更のいくつかの時間がかかります。
メモ Microsoft Dynamics CRM にログオンすると、次のエラー メッセージが表示されます可能性があります。
このページを表示する権限がありません。 HTTP エラー 401.1 - 権限がありません : 資格情報が無効のため、アクセスが拒否されました。
このエラー メッセージを受け取った場合は「サポート技術情報」(Microsoft Knowledge Base の資料 917818 手順を完了します。 関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください:
917818Microsoft Dynamics CRM Web サイトにアクセスしようとすると、エラー メッセージ:「権限がありませんこのページを表示する」

詳細

次の使用例

マイクロソフトは提供プログラミング言語の使用方法の一例としてのみ、姿表現または暗黙に提供します。 これはに含まれますに、黙示または商品性および特定目的に対する適合性の黙示保証は一切制限はありません。 この資料ではであると見なすは、例示されているプログラミング言語を作成したりプロシージャをデバッグするためのツールと使い慣れた。 マイクロソフト サポート エンジニア、特定のプロシージャの機能の説明に役立ちます。 ただし、これらの追加機能を提供する手順を特定の要件を構築例変更は行って。

この問題は、次の使用例のようなワークフロー ルールを実行する吹き出しがある場合に発生する可能性があります。
// Set up the CRM Service.
CrmService service = new CrmService();
service.Credentials = System.Net.CredentialCache.DefaultCredentials;

// Create the request.
ExecuteWFProcessRequest request = new ExecuteWFProcessRequest();
request.ProcessId = new Guid("{8DC95CE2-1A27-4CEA-9E6A-8F6BCC4B658D}");
request.EntityMoniker = new Moniker();
request.EntityMoniker.Id = createdId;
request.EntityMoniker.Name = EntityName.account.ToString();

// Execute the request.
ExecuteWFProcessResponse response = (ExecuteWFProcessResponse) service.Execute(request);

プロパティ

文書番号: 932476 - 最終更新日: 2007年8月15日 - リビジョン: 2.5
この資料は以下の製品について記述したものです。
  • Microsoft CRM 3.0
キーワード:?
kberrmsg kbtshoot kbprb kbmbsmigrate kbmbsworkflow kbmbscrm40no kbmt KB932476 KbMtja
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英語版 KB:932476
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