Article ID: 932513 - Last Review: May 16, 2008 - Revision: 2.0

Exchange System Manager in Exchange Server 2003 stops responding when you try to access Exchange Help after you install Internet Explorer 7

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SYMPTOMS

In Microsoft Exchange Server 2003, you may experience the following symptoms:
  • Consider the following scenario.
    • You are using Exchange Server 2003 on a computer that is running Windows Server 2003 Service Pack 1 (SP1).
    • You install Windows Internet Explorer 7 on the computer that is running Exchange System Manager.
    • You try to access Exchange Help in Exchange System Manager.
    In this scenario, Exchange System Manager stops responding because of an access violation.
  • You install Internet Explorer 7 on the server that is running Exchange Server 2003. Then, you try to view the MAPI public folder content in the instance of Exchange System Manager that is running on the Exchange Server 2003 server. When you do this, you may receive the following message:
    The operation completed successfully
    Facility: Win32
    ID no: c0070000 Exchange System Manager
    In this case, you can view the public folders. However, when you try to view the content in Exchange System Manager, you see only a gray screen where the content should be.

CAUSE

This problem occurs because of a conflict between the newer version of the Psapi.dll file that Internet Explorer 7 uses and the older version that Exchange System Manager uses.

WORKAROUND

To work around this problem, you must rename the Psapi.dll file in the Exchsrvr\Bin directory so that the Exchange services use the Psapi.dll file from the %Windir%\System32 directory. To do this, follow the steps that are appropriate for your situation.

You have installed Internet Explorer 7 on the Exchange server that also has Exchange System Manager installed

If you have installed Internet Explorer 7 on the Exchange server that also has Exchange System Manager installed, follow these steps:
  1. Stop all Exchange and Internet Information Services (IIS) services.
    1. Open the Services snap-in.
    2. Stop the Microsoft Exchange System Attendant service.

      Important Note the list of dependent services that will be stopped. For example, the list of dependent services may resemble the following:
      • Microsoft Exchange Information Store
      • Microsoft Exchange MTA Stacks
    3. Stop the IIS Admin Service.

      Important Note the list of dependent services that will be stopped. For example, the list of dependent services may resemble the following:
      • World Wide Web Publishing Service
      • Simple Mail Transfer Protocol (SMTP)
      • HTTP SSL
      • AntigenIMC
  2. Rename the Psapi.dll file. To do this, follow these steps:
    1. Open a command prompt.
    2. Move to the following directory:
      Drive_Letter:\Program Files\Exchsrvr\bin
    3. Change the name of the Psapi.dll file to Psapi.dll.old.
    4. Close the Command Prompt window.
  3. Restart the Exchange services and the IIS services. This includes the dependent services that were stopped.

You have installed Internet Explorer 7 on a workstation that also has Exchange System Manager installed

If you have installed Internet Explorer 7 on a workstation that also has Exchange System Manager installed, follow these steps:
  1. Stop all IIS services. To do this, open the Services snap-in, and then stop the IIS Admin Service.

    Important Note the list of dependent services that will be stopped. For example, the list of dependent services may resemble the following:
    • World Wide Web Publishing Service
    • HTTP SSL
  2. Rename the Psapi.dll file.
    1. Open a command prompt.
    2. Move to the following directory:
      Drive_Letter:\Program Files\Exchsrvr\bin
    3. Change the name of the Psapi.dll file to Psapi.dll.old.
    4. Close the Command Prompt window.
  3. Restart the IIS services. This includes the dependent services that were stopped.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
Keywords: 
kbdll kbcrashes kbexchesm kbexpertiseadvanced kbtshoot kbprb KB932513