Microsoft キーボードの動作していないホット キーまたはボリュームのコントロール キーを解決します。

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文書番号: 932875 - 対象製品
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目次

現象

ホット キーまたはボリューム コントロール キーを Microsoft キーボードで期待どおりには動作しません。いくつかのホット キーが期待どおりには、動作可能性がありますが、そうでないです。

ヒューマン インターフェイス サービスを開始しようとすると、次のようなエラー メッセージが表示されることがあります。
エラー コード 126
エラー 2

原因

この問題は、コンピューター上の USB 接続に問題がある場合に発生します。この問題は、サード パーティ製のキーボード制御ユーティリティがコンピューターに実行されている場合にも発生します。サード パーティ製のキーボード制御ユーティリティの例は次のとおりです。
  • Compaq の容易なアクセス
  • E コンピューターを電子ボードの
  • Gateway MultiFunction Keyboard
  • ヒューレット ・ パッカード社のマルチ メディア キーボード ユーティリティ
  • IBM の迅速なアクセス ? logitech (ロジクール) キーの指揮官
  • Packard ベル MediaSelect
サード パーティ製のキーボード制御ユーティリティも Acer、ゲートウェイ 2000年およびソニー製のマルチ メディア コンピューターが提供されます。

この問題は、キーボードから発行されたスキャン コードがキーボード制御ユーティリティによって異なって解釈されるために発生します。これもことができます予期しない既定または再定義のプログラム割り当てキー。さまざまな既定の割り当ては、インストールされている場合は、特定のプログラムがあること、または、サポートされている電子メール プログラム、インターネット ブラウザーやメディア プレーヤーを使用していることが必要です。

サポートされているプログラムがあるない場合は、キーを再割り当てすることによってキーを使用できます。

解決方法

各方法の実行後、キーをテストの方法下の順序で実行してください。問題が引き続き発生する場合は、するには、次の方法に進みます。

方法 1: 別の USB ポートを使用します。

キーボードを別の USB ポートに接続し、キーボードの動作を確認します。(このメソッドはポート固有の問題をテストします。)

メモ ポート レプリケーターの USB ハブ、KVM スイッチ、やなどをバイパスします。受信機は、コンピューターのポートに直接接続します。

方法 2: 無効にするか、以前にインストールされたキーボード ソフトウェアをアンインストールします。

このコンピューターにインストールされている他のキーボード制御ソフトウェアを無効にしてから、キーの再割り当てください。


関数キーに割り当てる方法の詳細については、マイクロソフト サポート技術情報の資料を参照する次の資料番号をクリックします。
237179マクロまたは関数をキーボード上のキーに割り当てる


問題が引き続き発生する場合は、キーボード ソフトウェアがコンピューターでを削除します。IntelliPoint、logitech (ロジクール)、またはその他のキーボード ソフトウェアをアンインストールするのには、次の手順を実行します。
  1. 次のいずれかの操作を行います。
    • Windows Vista または Windows 7 を使用します。
      1. 矢印キーを使用してを検索するのには 検索を開始します。 ボックス型 appwiz.cpl、し、ENTER キーを押します。
      2. プログラムの一覧で、方向キーを使用する] を選択するのには プログラムと機能、し、ENTER キーを押します。
      3. 矢印キーを使用してくださいソフトウェアを制御するキーボードを検索を検索するのには、TAB キーを押してして 削除、し、ENTER キーを押します。他のマウス ソフトウェアがあるインストールされて場合は、そのソフトウェアをアンインストールします。
    • Windows XP およびそれ以前のバージョンの Windows で。
      1. クリックしてください。 スタート[ Exchange Server 2010 SP1 をインストールした後 Outlook クライアント アプリケーションがパブリック フォルダーに接続できない] appwiz.cpl 続いて と入力して [ ].
      2. 矢印キーを使用してくださいソフトウェアを制御するキーボードを検索を検索するのには、TAB キーを押してして 削除、し、ENTER キーを押します。
  2. これを行うにメッセージが表示されたら、コンピューターを再起動します。
  3. 最新版の IntelliType ソフトウェアをダウンロードしてください。詳細については、次のマイクロソフト Web サイトを参照してください。
    http://www.microsoft.com/hardware/download/download.aspx?category=MK

方法 3: HID ヒューマン インターフェイス サービスを再起動します。

自分でこの問題を解決するのには、次の手順を実行します。
  1. Microsoft 管理コンソール (MMC) スナップインを開きます。
    • Windows Vista または Windows 7 をクリックしてください。 スタート
      元に戻す画像を拡大する
      [スタート] ボタン
      ] 「services.msc」 続いて 検索を開始します。 ボックスをオンにし、ENTER キーを押します。

      元に戻す画像を拡大する
      ユーザー アカウント制御の許可
      管理者のパスワードまたは確認を求められたら、パスワードを入力またはをクリックしてください 続行.
    • Windows XP をクリックしてください。 スタート[ Exchange Server 2010 SP1 をインストールした後 Outlook クライアント アプリケーションがパブリック フォルダーに接続できない] 「services.msc」 続いて と入力して [ ].
  2. サービスの一覧で、 詳細 ウィンドウをダブルクリックします HID ヒューマン インターフェイス サービス、ことを確認します、 [スタートアップの種類 設定されています。 自動.
HID ヒューマン インターフェイス サービスを開始しようとすると、エラー コードが表示される場合は、方法 4 を試してください。エラー コード 126 またはエラー コード 2 が表示される場合は、ただし、次の手順のいずれかを試してください。
  • 126 のエラー コードが表示される場合は、Hidserv.dll ファイルを抽出します。これを行うには、次の手順を実行します。
    1. システム ドライブで Hidserv.dll を検索します。システム ドライブを見つけられない場合は、Windows の CD 上のファイルを検索します。
    2. 矢印キーを使用してを選択します。 抽出、し、ENTER キーを押します。
    3. フォルダー C:\Windows\System32 を選択する方向キーを使用し、リンク先として [このフォルダー] を選択します。
    4. コンピューターを再起動します。
  • エラー コード 2 が表示される場合は、レジストリの設定を変更します。これを行うには、次の手順を実行します。

    メモ この問題はレジストリ設定で変更されたのために発生します。

    重要このセクション、方法、またはタスクには、レジストリの変更方法が記載されています。レジストリを誤って変更すると、深刻な問題が発生することがあります。そのため、この手順を慎重に実行するようにしてください。万一に備えて、編集の前にレジストリをバックアップしてください。そうすることで、問題が発生した場合でもレジストリを復元できます。レジストリをバックアップおよび復元する方法の詳細については、以下のサポート技術情報番号をクリックしてください。
    322756 Windows でレジストリをバックアップおよび復元する方法
    この問題を解決するのには、HID コンピューターでサービスを有効にします。これを行うには、次の手順を実行します。
    1. レジストリ エディターを起動します。
      • Windows Vista または Windows 7 をクリックしてください。 スタート
        元に戻す画像を拡大する
        [スタート] ボタン
        ] regedit 続いて 検索を開始します。 ボックスをオンにし、ENTER キーを押します。

        元に戻す画像を拡大する
        ユーザー アカウント制御の許可
        管理者のパスワードまたは確認を求められたら、パスワードを入力またはをクリックしてください 続行.
      • Windows XP をクリックしてください。 スタート[ Exchange Server 2010 SP1 をインストールした後 Outlook クライアント アプリケーションがパブリック フォルダーに接続できない,種類 regedit 続いて と入力して [].
    2. 次のレジストリ キーを見つけて、クリックします。
      HKEY_LOCAL_MACHINE/System
    3. 展開 システム.
    4. 展開 ControlSet001.
    5. 展開 サービスプロパティ HidServ.
    6. 右側のウィンドウで右クリックします。 種類プロパティ 変更.
    7. で、 [値のデータ ボックスで、値に設定されているかどうかを確認 20プロパティ ].
    8. 展開 HidServプロパティ パラメーター.

      メモ パラメーターのレジストリ キーが存在しない場合は、次の手順を実行します。
      1. クリックしてください。 HidServ.
      2. で、 編集 メニューをポイントするには 新しいプロパティ キー.
      3. 種類 パラメーター、し、ENTER キーを押します。
    9. 右側のウィンドウで右クリックします。 プロパティ 変更.

      メモ つのレジストリ値が存在しない場合は、次の手順を実行します。
      1. クリックしてください。 パラメーター.
      2. で、 編集 メニューをポイントするには 新しいプロパティ 展開可能な文字列値.
      3. 種類 、し、ENTER キーを押します。
    10. で、 [値のデータ ボックスで、値に設定されていることを確認 %SystemRoot%\System32\hidserv.dll.(がない前に、後、またはこの値にはスペースを確認)。値がない場合%SystemRoot%\System32\hidserv.dll] %SystemRoot%\System32\hidserv.dll 続いて [値のデータ [ ].
    11. 「コントロール」のキー名にを含むレジストリ キーごとに手順 5 〜 10 を繰り返します。修正またはが ControlSet002 という名前のレジストリ キーがある場合は、たとえば、クリックします。 修正 またはをクリックしてください ControlSet002.次に、手順 5 〜 10 を繰り返します。
    12. レジストリ エディターを終了し、コンピューターを再起動します。

方法 4: テスト用の別のコンピューター

問題が引き続き発生する場合は、キーボードを別のコンピューターをテストします。キーボードは、他のコンピューターでは正しく動作しませんの場合は、交換用キーボードを取得するのには、我々 順序デスクトップに問い合わせてください。これを行うには、(800) 360-7561 します。

詳細については、以下の記事番号をクリックして、マイクロソフト サポート技術情報資料を参照してください。
326246紛失、破損、または不足しているマイクロソフト ソフトウェアまたはハードウェアを交換する方法

詳細

オーディオ/サウンド ハードウェアを変更したときのオーディオ設定のリセットの問題の詳細については、マイクロソフト サポート技術情報の資料を参照する次の資料番号をクリックします。
266680ユーザーの既定のサウンド設定は、Windows の既定の設定に復元されます。
問題は、コンピューターを再起動すると、ボリュームの設定が失わの詳細については、マイクロソフト サポート技術情報の資料を参照する次の資料番号をクリックします。
273033ボリューム コントロールの設定、コンピューターを再起動しても解決しないことがあります。

プロパティ

文書番号: 932875 - 最終更新日: 2013年5月25日 - リビジョン: 6.0
この資料は以下の製品について記述したものです。
  • マイクロソフト ベーシック ワイヤレス オプティカル デスクトップ
  • マイクロソフト コンフォート カーブ キーボード 2000
  • Microsoft Digital Media Keyboard 3000
  • マイクロソフト デジタル メディア プロ キーボード
  • Microsoft Multimedia Keyboard
  • Microsoft Natural Ergonomic Desktop 7000
  • マイクロソフト ナチュラル エルゴノミック キーボード 4000
  • マイクロソフト ナチュラル マルチメディア キーボード
  • Microsoft Wireless Entertainment Desktop 8000
  • Microsoft Wireless Entertainment Desktop 7000
  • Microsoft Wireless Laser Desktop 7000
  • マイクロソフト ワイヤレス レーザー デスクトップ 6000 v2
  • マイクロソフト ワイヤレス レーザー デスクトップ 6000
  • Microsoft Wireless Laser Desktop 5000
  • Microsoft Wireless Laser Desktop 4000
  • Microsoft Wireless Laser Desktop 3000
  • Microsoft Wireless Optical Desktop 5000
  • マイクロソフト ワイヤレス オプティカル デスクトップ コンフォート エディション
  • マイクロソフト ワイヤレス オプティカル デスクトップ 3000
  • Microsoft Wireless Optical Desktop 2000
  • マイクロソフト オプティカル デスクトップ エリート フォー ブルートゥース
  • Microsoft Wireless Optical Desktop 700 v2.0
  • Microsoft Wireless Optical Desktop 700
  • マイクロソフト ワイヤレス オプティカル デスクトップ プロ
  • マイクロソフト ワイヤレス オプティカル デスクトップ エリート
  • マイクロソフト レーザー マウス 6000
  • マイクロソフト オプティカル マウス
  • マイクロソフト オプティカル マウス バイ スタルク
  • マイクロソフト ワイヤレス インテリマウス エクスプローラ フォー ブルートゥース
  • マイクロソフト ワイヤレス レーザー マウス 8000
  • マイクロソフト ワイヤレス レーザー マウス 6000
  • マイクロソフト ワイヤレス ノートブック レーザー マウス 6000
  • マイクロソフト ワイヤレス ノートブック オプティカル マウス 4000
  • マイクロソフト ワイヤレス オプティカル マウス 2.0
  • マイクロソフト ワイヤレス オプティカル マウス 5000
  • マイクロソフト ワイヤレス ノートブック プレゼンター マウス 8000
  • マイクロソフト ワイヤレス オプティカル デスクトップ 1000
  • マイクロソフト ワイヤレス オプティカル デスクトップ フォー ブルートゥース
  • Microsoft Wireless Laser Desktop for Mac
  • Microsoft Wireless Optical Desktop Pro 1.0
  • マイクロソフト オプティカル デスクトップ ウィズ フィンガープリント リーダー
キーワード:?
dftsdahomeportal kbtshoot kbprb kbmt KB932875 KbMtja
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英語版 KB:932875
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