คุณไม่สามารถค้นหาแฟ้มได้เมื่อคุณค้นหาในคอมพิวเตอร์ที่ใช้ Windows Vista แม้ว่าแฟ้มมีอยู่บนคอมพิวเตอร์

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 932989 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้

การสนับสนุนสำหรับ Windows Vista โดยไม่มีการติดตั้ง service pack จะสิ้นสุดภายใน 13 เมษายน 2010 เมื่อต้องการดำเนินการได้รับการปรับปรุงการรักษาความปลอดภัยสำหรับ Windows ตรวจสอบให้แน่ใจว่า คุณกำลังเรียกใช้ Windows Vista มี Service Pack 2 (SP2) สำหรับข้อมูลเพิ่มเติม โปรดดูที่หน้าเว็บของ Microsoft ต่อไปนี้::การสนับสนุนกำลังจะสิ้นสุดลงสำหรับ Windows บางรุ่น

ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

สรุป

บทความนี้อธิบายถึงปัญหาที่คุณไม่พบแฟ้มเมื่อคุณค้นหาในคอมพิวเตอร์ที่ใช้ Windows Vista แม้ว่าแฟ้มมีอยู่บนคอมพิวเตอร์ บทความนี้แสดงวิธีการที่คุณสามารถใช้เพื่อแก้ไขปัญหานี้ เมื่อคุณค้นหาตำแหน่งที่ตั้ง และ เมื่อคุณค้นหาในดัชนี

สำหรับความช่วยเหลือเกี่ยวกับปัญหาในการค้นหาของ Windows ใน Windows Vista โดยอัตโนมัติ คลิเรียกใช้เดี๋ยวนี้ปุ่มจากหน้าอัตโนมัติบริการแก้ไขปัญหาเบื้องต้น และทำตามขั้นตอนในตัวช่วยสร้างนี้:

อาการ

คุณพบปัญหาเมื่อคุณพยายามค้นหาแฟ้มบนคอมพิวเตอร์ที่ใช้ Windows Vista ตัวอย่างเช่น เมื่อคุณค้นหาแฟ้ม โดยใช้การค้นหา คุณไม่สามารถค้นหาแฟ้มที่คุณคาดว่าจะค้นหา รายการไม่ปรากฏในผลลัพธ์การค้นหา คุณพบอาการนี้แม้ว่าแฟ้มมีอยู่บนคอมพิวเตอร์

สาเหตุ

ปัญหานี้อาจเกิดขึ้นในสถานการณ์สมมติต่อไปนี้
  • เมื่อคุณค้นหาตำแหน่งที่ตั้ง คุณอาจพบอาการต่าง ๆ ในส่วน "อาการ" หากมีเงื่อนไขใด ๆ ต่อไปนี้เป็นจริง:
    • แฟ้มไม่อยู่ในตำแหน่งที่ตั้งที่คุณกำลังค้นหาในขณะนี้
    • แฟ้มที่อยู่ในโฟลเดอร์ระบบ
    • แฟ้มมีแฟ้มที่ซ่อน
    • แฟ้มไม่ปรากฏในรายการ thousand ห้าครั้งแรกที่แสดงในผลลัพธ์การค้นหา
    • แฟ้มประกอบด้วยคำค้นหา ในคุณสมบัติของอย่างใดอย่างหนึ่ง และไม่ได้อยู่ ในชื่อแฟ้ม
  • เมื่อคุณค้นหาดัชนี คุณอาจพบอาการต่าง ๆ ในส่วน "อาการ" หากมีเงื่อนไขใด ๆ ต่อไปนี้เป็นจริง:
    • แฟ้มไม่อยู่ในสถานที่จัดทำดัชนีไว้
    • ชนิดแฟ้มของแฟ้มไม่ถูกทำดัชนี
    • แฟ้มมีคุณสมบัติที่ป้องกันไม่ให้มีการจัดทำดัชนีไว้
    • ตัวสร้างดัชนีที่ไม่ได้แทรกแฟ้มลงในดัชนี
    • ตัวสร้างดัชนีที่มี overlooking แฟ้ม
    • รายการที่อยู่ในผลลัพธ์การค้นหาไม่ตรงกับแฟ้มที่คุณกำลังค้นหา
Windows Vista includes new methods that enable faster searching of files. However, these new methods may be unfamiliar and cause some confusion to users who are not familiar with them.

การแก้ไข

To resolve this issue, use one or more of the following methods, as appropriate for your situation.

When you search any location

This section lists methods that you can use to help you resolve this issue when you search any location for a file. Each method corresponds to an item that is listed in the "Cause" section.

Cause 1: The file is not in the location that you are currently searching

Make sure that the file that you want to find is within the scope of the location that you are searching. To determine the location that you are currently searching, follow these steps:
  1. ภายใต้Did you find what you were looking for?at the bottom of the search results window, clickการค้นหาขั้นสูง.
  2. ในการการค้นหาขั้นสูงarea, note the location that you are currently searching.
The location that you are searching must contain the file that you are looking for.
Search everywhere on the computer
To search everywhere on the computer, clickEverywhereในการตำแหน่ง:กล่อง และคลิกเพื่อเลือกนั้นInclude non-indexed, hidden, and system files (might be slow)กล่องกาเครื่องหมาย
Search only indexed locations
To search only indexed locations, clickIndexed Locationsในการตำแหน่ง:กล่อง

Cause 2: The file is located in a system folder

By default, when you try to find a file that is located on your computer, Windows Vista does not search system folders. System folders include the Program Files folder and the Windows folder. To search a system folder, use one of the following methods.
วิธีที่ 1:

Search within the system folder that contains the file. For example, if you want to find theShell32.dllfile, do not search by using theEverywhereตัวเลือก Instead, locate theไดรฟ์:\Windows folder, and then search for theShell32.dllแฟ้ม:
วิธีที่ 2

คลิกจัดระเบียบแล้ว คลิกFolder and Search Options. ในการตัวเลือกโฟลเดอร์กล่องโต้ตอบ คลิกการค้นหาแท็บ และจากนั้นภายใต้When searching non-indexed locationsคลิกเพื่อเลือกนั้นInclude system directoriesกล่องกาเครื่องหมาย
วิธีที่ 3

ในการการค้นหาขั้นสูงพื้นที่ คลิกเพื่อเลือกนั้นInclude non-indexed, hidden, and system files (might be slow)กล่องกาเครื่องหมาย

Cause 3: The file is a hidden file

To display hidden files in the search results, use one of the following methods.
วิธีที่ 1:

คลิกจัดระเบียบแล้ว คลิกFolder and Search Options. ในการตัวเลือกโฟลเดอร์กล่องโต้ตอบ คลิกการมุมมองแท็บ และจากนั้นภายใต้ซ่อนแฟ้มและโฟลเดอร์คลิกแสดงแฟ้มที่ซ่อนไว้และโฟลเดอร์.
วิธีที่ 2

ในการการค้นหาขั้นสูงพื้นที่ คลิกเพื่อเลือกนั้นInclude non-indexed, hidden, and system files (might be slow)กล่องกาเครื่องหมาย

Cause 4: The file does not appear in the first five thousand items that are listed in the search results

If Windows Vista finds more than five thousand search results, you receive the following message:
There are more results than will fit in this view. Narrow your results with the Search box or click to see all results…
You can show all the search results. To do this, click the message. Or you can reduce the number of items that appear in the search results. To do this, add more search terms. For example, add the file type as a search term. To use more advanced methods to filter search results, use the options that are available in theการค้นหาขั้นสูงพื้นที่

Cause 5: The file contains the search term in one of its properties and not in the file name

When you type a term in theค้นหาbox, Windows Vista always searches file names. If the file is in the index, Windows Vista also searches the file properties. File properties include the file type, the author, content such as words and phrases in the file, and comments that were added to pictures. To search for content in a file if the file is not in the index, use one of the following methods.
วิธีที่ 1:

คลิกจัดระเบียบแล้ว คลิกFolder and Search Options. ในการตัวเลือกโฟลเดอร์กล่องโต้ตอบ คลิกการค้นหาtab, and then click to select theAlways search filenames and contents (might be slow)กล่องกาเครื่องหมาย
วิธีที่ 2

If you search a location that is not in the index, underDid you find what you were looking for?at the bottom of the search results window, clickSearch in File Contents.

When you search the index

This section lists methods that you can use to help you resolve this issue when you search the index for a file. Each method corresponds to an item that is listed in the "Cause" section.

Cause 1: The file is not in an indexed location

ถ้าคุณคลิกIndexed Locationsto search indexed locations, the location of the item that you want to find must be in the index. To determine whether files and folders that you expect to appear in the search results are located in the index, follow these steps:
  1. คลิกเริ่มการทำงาน
    ยุบรูปภาพนี้ขยายรูปภาพนี้
    เริ่มการทำงานของปุ่ม
    คลิกแผงควบคุมแล้ว คลิกระบบและการบำรุงรักษา.
  2. คลิกตัวเลือกการจัดทำดัชนี. The folders that are indexed are listed underIncluded Locationsในการตัวเลือกการจัดทำดัชนีกล่องโต้ตอบ
  3. To view the path of the folders that are in the index, clickปรับเปลี่ยนand then clickShow all locations. ภายใต้Summary of selected locations, click the item that you want to view.
เมื่อต้องการเพิ่มตำแหน่งที่ตั้งในดัชนี ใช้รายการใดรายการหนึ่งในขั้นตอนต่อไปนี้:
  • ใช้ตัวเลือกในการตัวเลือกการจัดทำดัชนีกล่องโต้ตอบเพิ่ม ลบ หรือแยกตำแหน่งที่ตั้งจากดัชนี
  • ในสถานการณ์ที่คุณค้นหาตำแหน่งที่ตั้งที่ไม่ได้อยู่ในดัชนี ได้รับข้อความต่อไปนี้:
    ค้นหาอาจใช้เวลานานในตำแหน่งที่ตั้งที่ไม่ได้จัดทำดัชนี:ตำแหน่ง:. คลิกเพื่อเพิ่ม index…
    เมื่อต้องการเพิ่มตำแหน่งที่ตั้งในดัชนี คลิกข้อความ
คุณเท่านั้นสามารถเพิ่มตำแหน่งที่ตั้งบนคอมพิวเตอร์ที่ใช้อยู่ในดัชนี ถ้าคุณค้นหาคอมพิวเตอร์บนเครือข่ายที่ใช้ Windows Vista ตำแหน่งที่ตั้งที่จัดทำดัชนีที่มีการกำหนดค่าบนเครื่องคอมพิวเตอร์ระยะไกลใช้ Windows Vista จะใช้ในการค้นหา

คุณสามารถเพิ่มโฟลเดอร์จากคอมพิวเตอร์บนเครือข่ายที่ไม่ทำงาน Windows Vista ลงในดัชนี ก่อนที่คุณเพิ่มโฟลเดอร์ลงในดัชนี คุณต้องใช้การFolderNameคุณสมบัติกล่องโต้ตอบเพื่อทำให้โฟลเดอร์พร้อมใช้งานแบบออฟไลน์บนคอมพิวเตอร์ระยะไกล

สาเหตุที่ 2: การชนิดแฟ้มของแฟ้มจะไม่ทำดัชนี

แฟ้มบางชนิดจะไม่รวมอยู่ในดัชนี เมื่อต้องการดูชนิดของแฟ้มที่จะรวมอยู่ในดัชนี ดำเนินการดังต่อไปนี้:
  1. คลิกเริ่มการทำงาน
    ยุบรูปภาพนี้ขยายรูปภาพนี้
    เริ่มการทำงานของปุ่ม
    คลิกแผงควบคุมแล้ว คลิกระบบและการบำรุงรักษา.
  2. คลิกตัวเลือกการจัดทำดัชนีแล้ว คลิกขั้นสูง.

    ยุบรูปภาพนี้ขยายรูปภาพนี้
    สิทธิ์ในการควบคุมบัญชีผู้ใช้
    ถ้าคุณได้รับการพร้อมท์สำหรับรหัสผ่านของผู้ดูแลระบบหรือยืนยัน พิมพ์รหัสผ่านของคุณ หรือคลิกดำเนินการต่อ.
  3. คลิกการชนิดของแฟ้มแท็บ และดูรายการของชนิดแฟ้ม ถ้าเลือกกล่องกาเครื่องหมายที่อยู่ถัดจากนามสกุลของแฟ้ม ชนิดของแฟ้มถูกรวมในดัชนี ถ้าไม่ได้เลือกกล่องกาเครื่องหมายที่อยู่ถัดจากนามสกุลของแฟ้ม ชนิดแฟ้มไม่รวมอยู่ในดัชนี
หมายเหตุ:คุณยังสามารถกำหนด ว่าคุณต้องการจัดทำดัชนีคุณสมบัติของชนิดแฟ้มที่ระบุเท่านั้น หรือไม่ ว่าคุณต้องการจัดทำดัชนีคุณสมบัติและเนื้อหาของชนิดแฟ้มที่ระบุ การจัดทำดัชนีในคุณสมบัติของชนิดแฟ้ม คลิกทำดัชนีคุณสมบัติเท่านั้น. การจัดทำดัชนีคุณสมบัติและเนื้อหาของแฟ้มเฉพาะชนิด คลิกทำดัชนีคุณสมบัติและเนื้อหาแฟ้ม.

สาเหตุที่ 3: แฟ้มมีคุณสมบัติที่ป้องกันไม่ให้มีการจัดทำดัชนีไว้

แฟ้มสามารถมีคุณสมบัติที่ป้องกันไม่ให้แฟ้มมีการจัดทำดัชนีไว้ แฟ้มจะไม่เพิ่มลงในดัชนีหากมีเงื่อนไขใด ๆ ต่อไปนี้เป็นจริง:
  • กระบวนการการจัดทำดัชนีแฟ้มนี้สำหรับการค้นหาที่รวดเร็วขึ้นไม่มีเลือกกล่องกาเครื่องหมาย (เมื่อต้องการค้นหาตำแหน่งของกล่องกาเครื่องหมายนี้ ให้คลิกขวาแฟ้ม คลิกคุณสมบัติแล้ว คลิกขั้นสูง.)
  • แฟ้มมีการกำหนดค่าการใช้คุณลักษณะการซ่อนและแอตทริบิวต์ของระบบ แฟ้มที่สองสามมากใช้คุณลักษณะเหล่านี้ทั้งสอง แฟ้ม Desktop.ini เป็นตัวอย่างของแฟ้มที่ใช้แอตทริบิวต์ทั้งสอง
เมื่อต้องการค้นหาแฟ้มเหล่านี้ ใช้วิธีการต่อไปนี้อย่างใดอย่างหนึ่ง
วิธีที่ 1:

เอาคุณสมบัติหรือแอตทริบิวต์ที่ป้องกันไม่ให้แฟ้มมีการจัดทำดัชนีไว้
วิธีที่ 2

ในการการค้นหาขั้นสูงพื้นที่ คลิกเพื่อเลือกนั้นรวมไม่ได้จัดทำดัชนี ซ่อน และแฟ้มระบบ (อาจจะช้า)กล่องกาเครื่องหมาย
วิธีที่ 3

คลิกจัดระเบียบแล้ว คลิกตัวเลือกการค้นหาและโฟลเดอร์. ในการตัวเลือกโฟลเดอร์กล่องโต้ตอบ คลิกการค้นหาแท็บ และจากนั้นภายใต้วิธีการค้นหาคลิกเพื่อเลือกนั้นไม่ใช้ดัชนีเมื่อค้นหาแฟ้มระบบ (อาจจะช้า)กล่องกาเครื่องหมาย

สาเหตุที่ 4: ตัวสร้างดัชนีที่ไม่ได้แทรกแฟ้มลงในดัชนี

แฟ้มจะไม่ทันทีแทรกลงในดัชนี โดยที่ตัวสร้างดัชนี เมื่อไม่มีกิจกรรมของผู้ใช้ ตัวสร้างดัชนีการใช้ทรัพยากรการประมวลผล backlog ของแฟ้มที่มีไม่ได้ถูกทำดัชนี ตัวอย่างเช่น คุณเปิดในตัวเลือกการจัดทำดัชนีกล่องโต้ตอบ และจากนั้นคุณไม่ใช้เมาส์หรือแป้นพิมพ์ 45 วินาที ในการตัวเลือกการจัดทำดัชนีกล่องโต้ตอบ คุณจะเห็นว่า ตัวสร้างดัชนีที่เพิ่มความเร็วในการทำดัชนีเพื่อจบการทำดัชนีรายการ กระบวนการตัวเลือกการจัดทำดัชนีกล่องโต้ตอบจะแสดงว่า การจัดทำดัชนีเสร็จสมบูรณ์ ในสถานการณ์ที่คุณเพิ่มจำนวนมากแฟ้มใหม่ไปยังคอมพิวเตอร์ ตรวจสอบให้แน่ใจว่า การจัดทำดัชนีเสร็จสมบูรณ์

สาเหตุที่ 5: ตัวสร้างดัชนีที่มี overlooking แฟ้ม

หากคุณสงสัยว่า ปัญหาที่มีอยู่ในตัวสร้างดัชนีที่ไม่ประกอบด้วยแฟ้มหรือแฟ้มที่ควรประกอบด้วย จัดทำดัชนีใหม่ เมื่อต้องการให้เราในการสร้างดัชนีสำหรับคุณ ไป "แก้ไขปัญหาให้กับฉัน"ส่วน ถ้าคุณต้องการสร้างดัชนีด้วยตนเอง ไป "ให้ฉันแก้ไขด้วยตนเอง"ส่วน

แก้ไขปัญหาให้กับฉัน


เมื่อต้องสร้างดัชนีโดยอัตโนมัติ คลิกการแก้ไขปัญหานี้การเชื่อมโยง คลิกเรียกใช้ในการดาวน์โหลดแฟ้มกล่องโต้ตอบกล่อง และทำตามขั้นตอนในการแก้ไขปัญหาดังกล่าว wizard


แก้ไขปัญหานี้
Microsoft Fix it 50201


หมายเหตุ:ตัวช่วยสร้างนี้อาจมีเฉพาะในภาษาอังกฤษเท่านั้น อย่างไรก็ตาม การแก้ไขอัตโนมัติยังสามารถใช้ได้กับ Windows รุ่นภาษาอื่นด้วย

หมายเหตุ:ถ้าคุณไม่อยู่บนคอมพิวเตอร์ที่มีปัญหา คุณสามารถบันทึกการแก้ไขอัตโนมัติแฟลชไดรฟ์ หรือซีดีเพื่อให้คุณสามารถเรียกใช้บนคอมพิวเตอร์ที่มีปัญหา

thanks ไปAnand Khanse MVPสำหรับการสนับสนุนนี้แก้ไขได้

ขั้นตอนถัดไป ไป "สามารถแก้ไขปัญหาได้หรือไม่"ส่วน



ให้ฉันแก้ไขด้วยตนเอง


เมื่อต้องการจัดทำดัชนีใหม่ ดำเนินการดังต่อไปนี้:
  1. คลิกเริ่มการทำงาน
    ยุบรูปภาพนี้ขยายรูปภาพนี้
    เริ่มการทำงานของปุ่ม
    คลิกแผงควบคุมแล้ว คลิกระบบและการบำรุงรักษา.
  2. คลิกตัวเลือกการจัดทำดัชนีแล้ว คลิกขั้นสูง.

    ยุบรูปภาพนี้ขยายรูปภาพนี้
    สิทธิ์ในการควบคุมบัญชีผู้ใช้
    ถ้าคุณได้รับการพร้อมท์สำหรับรหัสผ่านของผู้ดูแลระบบหรือยืนยัน พิมพ์รหัสผ่านของคุณ หรือคลิกดำเนินการต่อ.
  3. คลิกสร้างใหม่. เมื่อคุณได้รับการพร้อมท์ให้ยืนยันว่า คุณต้องการสร้างดัชนี คลิกตกลง.
  4. เมื่อ Rebuild ที่เสร็จสมบูรณ์ รีคอมพิวเตอร์ของคุณ
rebuilding ดัชนีอาจใช้เวลาสิ้นสุดลง During the rebuild operation, the indexer tries to reinsert all items into the index.

สามารถแก้ไขปัญหาได้หรือไม่

ตรวจสอบว่าปัญหาได้รับการแก้ไขแล้วหรือไม่ ถ้าปัญหาได้รับการแก้ไขแล้ว คุณสามารถสิ้นสุดส่วนนี้ได้ หากปัญหาไม่ได้รับการแก้ไข คุณสามารถติดต่อฝ่ายสนับสนุน.

Cause 6: The items in the search results do not match the file that you are searching for

เมื่อคุณใช้การค้นหาbox to search the index, the search includes properties such as author, artist, tags, and file contents. ใช้แบบการค้นหาขั้นสูงarea to specify what you are looking for.

For more information about how to search for files by using advanced query syntax, see Windows Vista Help.

คุณสมบัติ

หมายเลขบทความ (Article ID): 932989 - รีวิวครั้งสุดท้าย: 26 กันยายน 2554 - Revision: 3.0
ใช้กับ
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Business 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Starter
Keywords: 
kbsurveynew kbmsifixme kbfixme kbexpertisebeginner kbprb kbtshoot kbmt KB932989 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:932989

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com