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Error message during an unattended installation of Windows Vista: "No disk"

Article ID:932998
Last Review:August 29, 2007
Revision:2.1
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SYMPTOMS

When you perform an unattended installation of Windows Vista, you may receive the following error message during the generalization phase of the installation process:
No disk
There is no disk. Please insert the disk into drive.
This problem occurs when the Setup program searches for the answer file (Unattend.xml) on an empty floppy disk drive.

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CAUSE

This problem occurs because a race condition occurs when the SetErrorMode function is called.

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RESOLUTION

How to apply this hotfix

To apply this hotfix, you must use the files that are included in this update to update the Windows installation source files. For information about how to do this, see the OEM preinstall kit (OPK) documentation.

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Hotfix information

A supported hotfix is now available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem, submit a request to Microsoft Online Customer Services to obtain the hotfix. To submit an online request to obtain the hotfix, visit the following Microsoft Web site:
http://go.microsoft.com/?linkid=6294451 (http://go.microsoft.com/?linkid=6294451)
Note If additional issues occur or any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. To create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Actionqueue.dll6.0.6000.20555167,42413-Mar-200702:11x86
Audit.exe6.0.6000.2055551,71213-Mar-200700:41x86
Diager.dll6.0.6000.2055531,23213-Mar-200702:14x86
Diagnostic.dll6.0.6000.20555121,85613-Mar-200702:14x86
Oobeldr.exe6.0.6000.2055542,49613-Mar-200700:41x86
Setup.cfgNot Applicable1,57212-Mar-200721:47Not Applicable
Setup.exe6.0.6000.20555194,23213-Mar-200702:19x86
Spprgrss.dll6.0.6000.2055552,73613-Mar-200702:14x86
Sysprep.exe6.0.6000.2055594,20813-Mar-200700:41x86
Update.mumNot Applicable1,78713-Mar-200716:17Not Applicable
W32uiimg.dll6.0.6000.205552,928,64013-Mar-200702:14x86
W32uires.dll6.0.6000.20555260,09613-Mar-200702:14x86
Wdsutil.dll6.0.6000.2055547,10413-Mar-200702:14x86
Win32ui.dll6.0.6000.20555394,24013-Mar-200702:14x86
Windeploy.exe6.0.6000.2055541,47213-Mar-200700:41x86
Winsetup.dll6.0.6000.205551,376,25613-Mar-200702:14x86
X86_3051adca2bdc8e23e03f42d5de425c89_31bf3856ad364e35_6.0.6000.20555_none_ff2e6da102d9a5be.manifestNot Applicable70313-Mar-200716:17Not Applicable
X86_microsoft-windows-setup-component_31bf3856ad364e35_6.0.6000.20555_none_309eca7dc95d678a.manifestNot Applicable29,53613-Mar-200716:21Not Applicable
Windows Vista, 64-bit versions
File nameFile versionFile sizeDateTimePlatform
Actionqueue.dll6.0.6000.20555200,70413-Mar-200703:10x64
Amd64_f3bb55675041cf605042857841aa7b54_31bf3856ad364e35_6.0.6000.20555_none_8c1972ea6111ca5f.manifestNot Applicable1,05413-Mar-200716:17Not Applicable
Amd64_microsoft-windows-setup-component_31bf3856ad364e35_6.0.6000.20555_none_8cbd660181bad8c0.manifestNot Applicable29,60213-Mar-200716:25Not Applicable
Audit.exe6.0.6000.2055562,46413-Mar-200701:01x64
Diager.dll6.0.6000.2055538,40013-Mar-200703:12x64
Diagnostic.dll6.0.6000.20555146,43213-Mar-200703:12x64
Oobeldr.exe6.0.6000.2055548,12813-Mar-200701:01x64
Setup.cfgNot Applicable1,57212-Mar-200722:11Not Applicable
Setup.exe6.0.6000.20555211,64013-Mar-200703:16x64
Spprgrss.dll6.0.6000.2055553,24813-Mar-200703:12x64
Sysprep.exe6.0.6000.20555107,52013-Mar-200701:01x64
Update.mumNot Applicable1,78713-Mar-200716:17Not Applicable
W32uiimg.dll6.0.6000.205552,928,12812-Mar-200723:03x64
W32uires.dll6.0.6000.20555259,58412-Mar-200723:03x64
Wdsutil.dll6.0.6000.2055556,32013-Mar-200703:12x64
Win32ui.dll6.0.6000.20555543,23213-Mar-200703:12x64
Windeploy.exe6.0.6000.2055546,08013-Mar-200701:01x64
Winsetup.dll6.0.6000.205551,746,94413-Mar-200703:12x64

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WORKAROUND

To work around this problem, click Retry.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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MORE INFORMATION

For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

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APPLIES TO
Windows Vista Home Basic
Windows Vista Home Premium
Windows Vista Ultimate
Windows Vista Business
Windows Vista Enterprise
Windows Vista Starter
Windows Vista Home Basic 64-bit Edition
Windows Vista Home Premium 64-bit Edition
Windows Vista Ultimate 64-bit Edition
Windows Vista Business 64-bit Edition
Windows Vista Enterprise 64-bit Edition

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Keywords: 
kbvistasp1fix kbfix kbhotfixserver kbqfe kbexpertiseadvanced kbwinvistapostrtmfix KB932998

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