Article ID: 933030 - Last Review: March 15, 2007 - Revision: 1.1

Error message when you launch an e-mail marketing campaign in Outlook 2007 with Business Contact Manager: "Too many parameters were provided in this RPC request"

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SYMPTOMS

You launch an e-mail marketing campaign in Microsoft Office Outlook 2007 with Business Contact Manager. The campaign launches as expected. However, you receive the following error message:
The incoming tabular data Stream (TDS) remote procedure call (RPC) protocol stream is incorrect. Too many parameters were provided in this RPC request. The maximum is 2100.
Additionally, you may receive the following error message:
This action cannot be completed because Business Contact Manager cannot access the database. Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.

CAUSE

This problem occurs if the following conditions are true:
  • Outlook 2007 with Business Contact Manager tries to save the e-mail marketing campaign after the campaign has been launched.
  • The campaign contains more than 1,000 recipients.
Note E-mail marketing campaigns have the campaign type selected, and they have one of the following delivery methods selected:
  • Outlook
  • Word E-mail Merge
  • Publisher E-mail Merge
  • E-mail Marketing Service
After the campaign has been launched, Outlook 2007 with Business Contact Manager tries to save the marketing campaign. This causes the error message. The marketing campaign has been successfully launched. However, you will be unable to track responses to the campaign because you cannot save the campaign after you receive the error message. The recipients will not have the marketing campaign in their communication histories.

WORKAROUND

If you have already started the campaign, there is no workaround. You must exit the campaign without saving. To close the campaign without saving, do one of the following:
  • Click Close.
  • On the marketing campaign form, click Delete in the Actions group.
To work around this problem, create a new marketing campaign. Then, filter the recipients so that the Total in list box contains fewer than 1,000 recipients. To do this, follow these steps.

Note After you complete these steps, you will have several marketing campaigns that you can use to track responses.
  1. On the File menu, point to New, and then click Marketing Campaign.
  2. Select the recipients under Who will see it on the Campaign tab.
  3. If the total number of recipients in the Total in list box exceeds 1,000 recipients, reduce the number of recipients that will receive the e-mail marketing campaign. To do this, follow these steps:
    1. Click Review and Filter.
    2. Click the Simple Filter tab.
    3. Under Include, click to select the Leads check box, click to clear the Business contacts check box, and then click OK.
  4. If the Total in list box is still more than 1,000 recipients, you must reduce the number of recipients more. To do this, follow these steps:
    1. Click Review and Filter.
    2. Select another attribute, such as State or Active, on which to filter.

      Note You can also select the Review Results tab. On the Review Results tab, click to clear the various check boxes to bring the total number of recipients to fewer than 1,000.
  5. Launch the e-mail marketing campaign as you usually do.
  6. Repeat steps 1 to 3 to create another e-mail marketing campaign. Click to select the Business Contacts check box under Include, click to clear the Leads check box, and then click OK.
  7. If the Total in list box is more than 1,000 recipients, reduce the number of recipients. To do this, follow these steps:
    1. Click Review and Filter.
    2. Select another attribute, such as State or Active, on which to filter.

      Note You can also select the Review Results tab. On the Review Results tab, click to clear the various check boxes to bring the total number of recipients to fewer than 1,000.
  8. Launch the e-mail marketing campaign as you usually do.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Office Outlook 2007 with Business Contact Manager
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