Cuando intenta utilizar Internet Explorer 7 para descargar un archivo desde una página Web, cambia el nombre de archivo

Seleccione idioma Seleccione idioma
Id. de artículo: 933133 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Intenta utilizar Windows Internet Explorer 7 para descargar un archivo desde una página Web. Sin embargo, al hacer clic en la dirección URL del archivo, se cambia el nombre de archivo.

Causa

El problema se produce cuando se cumplen las condiciones siguientes:
  • La página Web utiliza un encabezado de disposición de contenido para forzar que Windows Internet Explorer 7 para descargar un archivo en lugar de abrir el archivo en una ventana del explorador.
  • El nombre de archivo en el encabezado de disposición de contenido utiliza caracteres de (DBCS) de caracteres de doble byte, como caracteres japoneses.
  • El segundo byte, o "trailbyte" de cualquiera de los caracteres DBCS contiene valores que representan caracteres reservados en el sistema de archivo en ASCII. Por ejemplo, "trailbyte" contiene valores que representan valores ASCII como 0x5c o 0x7c.
Cuando se produce este problema, "trailbyte" se cambia a un valor diferente. Por lo tanto, se modifica el carácter DBCS.

Nota Caracteres DBCS utilizan dos bytes de memoria para mostrar un único carácter. Este carácter consta de "leadbyte" y "trailbyte". Estos dos bytes determinan qué carácter del lenguaje de destino se muestra.

Solución

Información de la actualización de seguridad

Para resolver este problema, instale la actualización de seguridad acumulativa más reciente para Internet Explorer. Para instalar las actualizaciones más recientes, visite el siguiente sitio Web de Microsoft:
http://windowsupdate.microsoft.com
Para información más técnica acerca de la actualización de seguridad acumulativa más reciente para Internet Explorer, visite el siguiente sitio Web:
http://www.microsoft.com/technet/security/current.aspx
Nota Esta corrección se incluyó primero en la actualización de seguridad 937143 (MS07-045). Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
937143MS07-045: Actualización de seguridad acumulativa para Internet Explorer

Información de revisiones

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Internet Explorer 7 en Windows Vista
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempo
Jsproxy.dll7.0.6000.2054331.23223 De febrero de 200703: 14
Wininet.dll7.0.6000.205433,582,97623 De febrero de 200703: 17
Wininetplugin.dll1.0.0.164.51223 De febrero de 200703: 17
Internet Explorer 7 para Microsoft Windows XP con Service Pack 2
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempo
Wininet.dll7.0.6000.20544823,29606-Mar-200705: 22

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Propiedades

Id. de artículo: 933133 - Última revisión: miércoles, 29 de agosto de 2007 - Versión: 3.4
La información de este artículo se refiere a:
  • Windows Internet Explorer 7 in Windows Vista
  • Windows Internet Explorer 7 for Windows XP
  • Windows Internet Explorer 7 for Windows Server 2003
  • Windows Internet Explorer 7 for Windows Server 2003 IA64
Palabras clave: 
kbmt kbvistasp1fix atdownload kbhotfixserver kbqfe kbfix kbbug kbpubtypekc KB933133 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 933133

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com