Windows ReadyDrive does not work in Windows Vista if the first partition of a hybrid hard disk drive has less than 32 MB of free space

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Article ID: 933242 - View products that this article applies to.
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SYMPTOMS

In Windows Vista, Windows ReadyDrive does not work if the first partition of a hybrid hard disk drive has less than 32 megabytes (MB) of free space. When this problem occurs, the operating system does not recognize the hybrid hard disk drive. Instead, the operating system uses this disk drive as a traditional disk drive.

CAUSE

This issue occurs because the operating system incorrectly compares the free space with the desired space.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Sysmain.dll6.0.6000.20554540,67210-Mar-200702:50x86
Systemsf.ebdNot Applicable177,77207-Jan-200705:51Not Applicable
Windows Vista, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Sysmain.dll6.0.6000.20554842,75210-Mar-200704:01x64
Systemsf.ebdNot Applicable456,68007-Jan-200705:51Not Applicable

WORKAROUND

To work around this issue, make sure that the first partition of a hybrid hard disk drive has at least 32 MB of free space.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

A hybrid hard disk drive (H-HDD) is a new type of hard disk drive that adds flash memory to a standard mobile PC hard disk drive. By using a hybrid hard disk drive, Windows ReadyDrive provides better performance, better reliability, and longer battery life. To determine whether the operating system recognizes the hybrid hard disk drive, follow these steps:
  1. Click Start, type Device Manager in the Start Search box, and then press ENTER.
  2. Click Continue in the User Access Control dialog box.
  3. In the Device Manager window, expand the Disk drives node, right-click the node that corresponds to your hybrid hard disk drive, and then click Properties.
  4. Determine whether the NV Cache tab is present.
Note The NV Cache tab may be absent for other reasons. It does not necessarily mean you are experiencing this problem. For example, this tab is absent if the hybrid hard disk drive has not passed the performance assessment.

REFERENCES

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 933242 - Last Review: October 8, 2011 - Revision: 4.0
APPLIES TO
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
Keywords: 
kbautohotfix kbvistasp1fix kbwinvistapostrtmfix kbexpertiseinter kbexpertisebeginner kbfix kbbug kbHotfixServer kbqfe KB933242

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