You cannot access SMB shares on a corporate network through a Remote Access Service (RAS) connection from a computer that is running Windows Vista

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Article ID: 933468 - View products that this article applies to.
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SYMPTOMS

When you establish a Remote Access Service (RAS) connection to a corporate network from a computer that is running Windows Vista, you cannot access Server Message Block (SMB) shares. However, if you use the ping command to test Internet connectivity, the ping test is successful.

CAUSE

This issue occurs when either of the following conditions is true:
  • The TCP port 139 is filtered on the corporate network.
  • NetBIOS over TCP/IP (NetBT) is disabled on the remote Windows Vista client.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Rasmans.dll6.0.6000.20549237,05603-Mar-200702:51x86
Windows Vista, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Rasmans.dll6.0.6000.20549281,60003-Mar-200704:00x64

WORKAROUND

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


To work around this problem, follow these steps:
  1. Click Start
    Collapse this imageExpand this image
    Start  button
    , type regedit in the Start Search box, and then click regedit.exe in the Programs list.
    Collapse this imageExpand this image
    Security shield
    If you are prompted for the administrator password or for a confirmation, type your password, or click Continue.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\Linkage
  3. On the File menu, click Export.
  4. In the Save box, specify a location where you want to save the file.
  5. In the File name box, enter a name for the file.
  6. In the Save as type box, click Registry Files.
  7. In the Export range box, click Selected branch, and then click Save.
  8. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\Linkage
  9. In the details pane, right-click the Bind registry entry in the Name column, click Modify, and then copy the data in the Value data box to the clipboard.
  10. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\smb\Linkage
  11. In the details pane, right-click the Bind entry in the Name column, click Modify, paste the data from the clipboard to the Value data text box to override the original data, and then click OK.
  12. Exit Registry Editor, and restart the computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

This problem does not occur when you use a Microsoft Windows XP-based computer as the remote client. A Windows Vista-based computer requires NetBT to be enabled with connectivity over port 139 for SMB to bind correctly to the RAS adapter. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 933468 - Last Review: May 20, 2008 - Revision: 3.1
APPLIES TO
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Ultimate
Keywords: 
kbautohotfix kbvistasp1fix kbpubtypekc kbexpertiseinter kbhotfixserver kbqfe kbfix KB933468

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