Windows Vista を実行しているコンピュータから RAS (Remote Access Service) 接続を使用して企業ネットワーク上の SMB 共有にアクセスできない

文書翻訳 文書翻訳
文書番号: 933468 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

Windows Vista を実行しているコンピュータから企業ネットワークへの RAS (Remote Access Service) 接続が確立されているときに、サーバー メッセージ ブロック (SMB) 共有にアクセスできません。ただし、ping コマンドを使用してインターネットの接続性をテストすると、ping テストは成功します。

原因

この問題は、次の条件のいずれかに該当する場合に発生します。
  • 企業ネットワーク上で TCP ポート 139 がフィルタ処理されている。
  • リモートの Windows Vista クライアントで NetBIOS over TCP/IP (NetBT) が無効になっている。

解決方法

Service Pack の情報

この問題を解決するには、Windows Vista の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
935791 最新の Windows Vista Service Pack を入手する方法

修正プログラムの情報

マイクロソフトでは、この問題を修正する修正プログラムを提供中ですが、修正プログラムはこの資料に記載された問題のみを修正することを目的としており、障害があったコンピュータに対してのみ適用することを推奨します。この修正プログラムは、今後さらにテストを行う場合があります。この問題で深刻な影響を受けていない場合は、この修正プログラムが含まれる次のソフトウェア更新プログラムがリリースされるまで待つことを推奨します。

修正プログラムをダウンロードできる場合は、この「サポート技術情報」 (Microsoft Knowledge Base) の上部に "修正プログラムのダウンロード" セクションが表示されています。このセクションが表示されていない場合は、マイクロソフト カスタマーサービス&サポートに問い合わせて、修正プログラムを入手します。

: 別の問題が発生した場合、またはトラブルシューティングが必要な場合には、別のサービス リクエストを作成することが必要になる場合があります。特定の修正プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。マイクロソフト カスタマーサービス&サポートの電話番号一覧を参照する、または別のサービス リクエストを作成するには、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support
: "修正プログラムのダウンロード" フォームは、修正プログラムが提供されている言語で表示されます。使用している言語で表示されない場合、その言語では修正プログラムは提供されていません。

必要条件

この修正プログラムをインストールするための必要条件はありません。

再起動の必要性

この修正プログラムの適用後、コンピュータを再起動する必要があります。

修正プログラムの置き換えに関する情報

この修正プログラムを適用しても、他の修正プログラムが置き換えられることはありません。

レジストリ情報

このパッケージに含まれている修正プログラムを使用するために、レジストリを変更する必要はありません。

ファイル情報

Windows Vista (x86 ベース)
元に戻す全体を表示する
ファイル名 バージョン サイズ 日付 時刻 プラットフォーム
Rasmans.dll 6.0.6000.20549 237,056 2007/03/03 11:51 x86
Windows Vista (64 ビット版)
元に戻す全体を表示する
ファイル名 バージョン サイズ 日付 時刻 プラットフォーム
Rasmans.dll 6.0.6000.20549 281,600 2007/03/03 13:00 x64

回避策

重要 : このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。レジストリを誤って変更すると、深刻な問題が発生することがあります。レジストリを編集する際には十分に注意してください。万一に備えて、編集の前にレジストリをバックアップしておくと、問題が発生した場合にレジストリを復元することができます。バックアップおよび復元方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
322756 Windows でレジストリをバックアップおよび復元する方法


この問題を回避するには、以下の手順を実行します。
  1. [スタート] ボタン
    元に戻す画像を拡大する
    [スタート] ボタン
    をクリックし、[検索の開始] ボックスに regedit と入力します。次に、[プログラム] の一覧の [regedit.exe] をクリックします。
    元に戻す画像を拡大する
    ユーザー アカウント制御の許可
    管理者のパスワードを要求するダイアログ ボックスが表示された場合はパスワードを入力して [OK] をクリックし、確認を要求するダイアログ ボックスが表示された場合は [続行] をクリックします。
  2. 次のレジストリ サブキーを見つけてクリックします。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\Linkage
  3. [ファイル] メニューの [エクスポート] をクリックします。
  4. [保存する場所] ボックスで、ファイルの保存先の場所を指定します。
  5. [ファイル名] ボックスにファイル名を入力します。
  6. [ファイルの種類] ボックスの一覧の [登録ファイル] をクリックします。
  7. [エクスポート範囲] で、[選択された部分] をクリックし、[保存] をクリックします。
  8. 次のレジストリ サブキーを見つけてクリックします。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\Linkage
  9. 詳細ウィンドウで、[名前] 列の [Bind] レジストリ エントリを右クリックし、[修正] をクリックします。[値のデータ] ボックスのデータをクリップボードにコピーします。
  10. 次のレジストリ サブキーを見つけてクリックします。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\smb\Linkage
  11. 詳細ウィンドウで、[名前] 列の [Bind] エントリを右クリックし、[修正] をクリックします。クリップボードから [値のデータ] ボックスにデータを貼り付けて元のデータを上書きし、[OK] をクリックします。
  12. レジストリ エディタを終了し、コンピュータを再起動します。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。 この問題は、Windows Vista Service Pack 1 で最初に修正されました。

詳細

この問題は、Microsoft Windows XP ベースのコンピュータをリモート クライアントとして使用する場合には発生しません。Windows Vista ベースのコンピュータで SMB を正しく RAS アダプタにバインドするには、ポート 139 経由の接続で NetBT が有効になっている必要があります。 関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
824684 マイクロソフトのソフトウェアの更新で使用される一般的な用語の説明

プロパティ

文書番号: 933468 - 最終更新日: 2008年6月13日 - リビジョン: 3.2
この資料は以下の製品について記述したものです。
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Ultimate
キーワード:?
kbautohotfix kbvistasp1fix kbpubtypekc kbexpertiseinter kbhotfixserver kbqfe kbfix KB933468
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com