Windows Vista를 실행하는 컴퓨터에서 RAS(원격 액세스 서비스) 연결을 통해 회사 네트워크의 SMB 공유에 액세스할 수 없음

기술 자료 번역 기술 자료 번역
기술 자료: 933468 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

이 페이지에서

현상

Windows Vista를 실행하는 컴퓨터에서 회사 네트워크에 RAS(원격 액세스 서비스) 연결을 설정하면 SMB(서버 메시지 블록) 공유에 액세스할 수 없습니다. 그러나 ping 명령을 사용하여 인터넷 연결을 테스트하면 ping 테스트에 성공합니다.

원인

다음 조건 중 하나에 해당하면 이 문제가 발생합니다.
  • TCP 포트 139가 회사 네트워크에서 필터링됩니다.
  • 원격 Windows Vista 클라이언트에서 NetBT(NetBIOS over TCP/IP)가 사용할 수 없도록 설정되어 있습니다.

해결 방법

Service Pack 정보

이 문제를 해결하려면 Windows Vista용 최신 서비스 팩이 필요합니다. 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하십시오.
935791 최신 Windows Vista 서비스 팩을 구하는 방법

핫픽스 정보

지원되는 핫픽스를 Microsoft에서 구할 수 있지만 이 문서에서 설명하는 문제를 해결하기 위한 것일 뿐이므로 이러한 특정 문제가 발생하는 시스템에만 이 핫픽스를 적용하십시오. 이 핫픽스는 나중에 추가 테스트를 받아야 할 수도 있습니다. 따라서 이 문제의 영향이 심각한 경우가 아니면 이 핫픽스가 포함된 다음 소프트웨어 업데이트가 나올 때까지 기다리는 것이 좋습니다.

핫픽스를 다운로드할 수 있는 경우 기술 자료 문서의 맨 위에서 "핫픽스 다운로드 가능"이 표시됩니다. 이 섹션이 표시되지 않으면 Microsoft 기술 지원 서비스에 문의하여 핫픽스를 구합니다.

참고 문제가 추가로 발생하거나 문제 해결이 필요한 경우 별도의 서비스 요청을 해야 할 수도 있습니다. 이 특정 핫픽스로 해결할 수 없는 추가 질문과 문제에 대해서는 지원 비용이 청구됩니다. Microsoft 온라인 기술 지원 전화 번호의 전체 목록을 얻거나 별도의 서비스 요청을 하려면 다음 Microsoft 웹 사이트를 방문하십시오.
http://support.microsoft.com/contactus/?ws=support
참고 "핫픽스 다운로드 사용 가능" 형식에서는 핫픽스에 사용할 수 있는 언어가 표시됩니다. 사용자 언어가 표시되지 않으면 해당 언어의 핫픽스를 사용할 수 없기 때문입니다.

전제 조건

이 핫픽스 설치에 필요한 전제 조건이 없습니다.

다시 시작 요구 사항

이 핫픽스를 적용한 후에는 컴퓨터를 다시 시작해야 합니다.

핫픽스 대체 정보

이 핫픽스는 다른 핫픽스를 대체하지 않습니다.

레지스트리 정보

이 패키지에 들어 있는 핫픽스를 사용하기 위해 레지스트리를 변경할 필요가 없습니다.

파일 정보

이 핫픽스의 영어 버전은 다음 표에 나열된 파일 특성(또는 그 이후의 파일 특성)을 갖습니다. 이 파일의 날짜와 시간은 UTC(협정 세계시)로 나열되며 파일 정보를 볼 때 현지 시간으로 변환됩니다. UTC와 현지 시간의 차이를 보려면 제어판날짜 및 시간 항목에서 표준 시간대 탭을 사용하십시오.
Windows Vista x86 기반 버전
표 축소표 확대
File nameFile versionFile sizeDateTimePlatform
Rasmans.dll6.0.6000.20549237,05603-Mar-200702:51x86
Windows Vista 64비트 버전
표 축소표 확대
File nameFile versionFile sizeDateTimePlatform
Rasmans.dll6.0.6000.20549281,60003-Mar-200704:00x64

해결 과정

중요 이 절, 방법 또는 작업에는 레지스트리를 수정하는 방법에 대한 단계가 포함되어 있습니다. 그러나 레지스트리를 잘못 수정하면 심각한 문제가 발생할 수도 있으므로 다음 단계를 주의하여 수행해야 합니다. 추가 보호 조치로 레지스트리를 수정하기 전에 해당 레지스트리를 백업하는 것이 좋습니다. 이렇게 하면 문제가 발생하는 경우 레지스트리를 복원할 수 있습니다. 레지스트리 백업 및 복원 방법에 대한 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하십시오.
322756 Windows XP 및 Windows Server 2003에서 레지스트리를 백업, 편집 및 복원하는 방법


이 문제를 해결하려면 다음과 같이 하십시오.
  1. 시작
    그림 축소그림 확대
    시작 단추
    을 클릭하고 검색 시작 상자에 regedit를 입력한 다음 프로그램 목록에서 regedit.exe를 클릭합니다.
    그림 축소그림 확대
    보안 방패
    관리자 암호나 확인을 요청하는 메시지가 나타나면 암호를 입력하거나 계속을 클릭합니다.
  2. 다음 레지스트리 하위 키를 찾아서 클릭합니다.
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\Linkage
  3. 파일 메뉴에서 내보내기를 클릭합니다.
  4. 저장 위치 상자에서 파일을 저장할 위치를 지정합니다.
  5. 파일 이름 상자에 파일의 이름을 입력합니다.
  6. 파일 형식 상자에서 레지스트리 파일을 클릭합니다.
  7. 내보내기 범위 상자에서 선택한 분기를 클릭한 다음 저장을 클릭합니다.
  8. 다음 레지스트리 하위 키를 찾아서 클릭합니다.
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\Linkage
  9. 세부 정보 창에서 이름 열의 Bind 레지스트리 항목을 마우스 오른쪽 단추로 클릭하고 수정을 클릭한 다음 값 데이터 상자의 데이터를 클립보드에 복사합니다.
  10. 다음 레지스트리 하위 키를 찾아서 클릭합니다.
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\smb\Linkage
  11. 세부 정보 창에서 이름 열의 Bind 항목을 마우스 오른쪽 단추로 클릭하고 수정을 클릭한 다음 클립보드의 데이터를 값 데이터 텍스트 상자에 붙여 넣어 원래 데이터를 다시 정의하고 확인을 클릭합니다.
  12. 레지스트리 편집기를 종료한 다음 컴퓨터를 다시 시작합니다.

현재 상태

Microsoft는 "본 문서의 정보는 다음의 제품에 적용됩니다." 절에 나열한 제품에서 이 문제를 확인했습니다. 이 문제는 Windows Vista 서비스 팩 1에서 처음 수정되었습니다.

추가 정보

Microsoft Windows XP 기반 컴퓨터를 원격 클라이언트로 사용하는 경우에는 이 문제가 발생하지 않습니다. SMB가 RAS 어댑터에 제대로 바인딩되려면 Windows Vista 기반 컴퓨터의 포트 139를 통한 연결에서 NetBT가 사용할 수 있도록 설정되어야 합니다. 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하십시오.
824684 Microsoft 소프트웨어 업데이트를 설명하는 데 사용되는 표준 용어에 대한 설명

속성

기술 자료: 933468 - 마지막 검토: 2008년 9월 11일 목요일 - 수정: 3.1
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Ultimate
키워드:?
kbautohotfix kbvistasp1fix kbpubtypekc kbexpertiseinter kbhotfixserver kbqfe kbfix KB933468

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com