Windows Vista で Microsoft Update をインストールすると "Microsoft Update をコンピュータにインストールできませんでした" というエラーが表示される

文書翻訳 文書翻訳
文書番号: 933528 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

Microsoft Windows Vista で Microsoft Update をインストールすると、以下のエラーが表示されることがあります。
Microsoft Update をコンピュータにインストールできませんでした
[エラー番号:0x80004005]
元に戻す画像を拡大する
vista update error0x80004005

原因

この問題は、 Microsoft Update のインストールを実行したユーザーのユーザー アカウント名に全角文字 (漢字、ひらがな、カタカナ等) が使われていることが原因で発生します。

: Microsoft Update をインストールするためには、管理者権限が必要です。管理者権限を持たないユーザーがインストールを行った場合にも、同様のエラーが表示されます。

回避策

この問題を回避するには、管理者権限を持つユーザーを半角英数文字の名前で作成し、そのユーザーでログインして Microsoft Update をインストールします。

ここでは、作業手順を以下の 3 つに分けて説明します。
  • 「新規ユーザーの作成」
    作業用に "Taro" という半角文字の名前で管理者権限を持つユーザーを作成
  • 「Windows Update から Microsoft Update への切り替え」
    作業用ユーザー "Taro" でログインして Microsoft Update をインストール
  • 「作業用に作成したユーザー アカウントの削除」
    作業用に作成したユーザー アカウント "Taro" を削除
: ここに示す手順は、Windows Vista Home Premium で操作しています。他のエディションの Windows Vista では、一部手順が異なる場合があります。

新規ユーザーの作成

最初に、管理者権限を持つユーザーを半角文字のアカウント名 (ユーザー名) で新規に作成します。
  1. [スタート] ボタン
    元に戻す画像を拡大する
    [スタート]  ボタン
    をクリックし、[コントロールパネル] をクリックします。
  2. [ユーザー アカウントの追加または削除] をクリックします。

    元に戻す画像を拡大する
    [ユーザー アカウントの追加または削除]


    元に戻す画像を拡大する
    ユーザー アカウント制御
    管理者のパスワードを要求するダイアログ ボックスが表示された場合はパスワードを入力して [OK] をクリックし、確認を要求するダイアログ ボックスが表示された場合は [続行] をクリックします。
  3. [新しいアカウントの作成] をクリックします。

    元に戻す画像を拡大する
    新しいアカウントの作成
  4. アカウント名とアカウントの種類を設定します。
    アカウント名のテキスト ボックスに半角文字で名前を入力し、アカウントの種類は [管理者] を選択します。ここでは、例として "Taro" という名前を入力します。
    次に、[アカウントの作成] ボタンをクリックします。

    元に戻す画像を拡大する
    Vista UserAccount NewEdit
  5. 半角文字の名前 "Taro" で管理者権限を持つユーザー (Administrator ユーザー) が作成されました。

    元に戻す画像を拡大する
    Vista UserAccount NewAccount
  6. 作成されたアカウントに、パスワードを設定します。
    新しく作成したユーザー アカウント (ここでは ”Taro”) をクリックして、[パスワードの作成] をクリックします。

    元に戻す画像を拡大する
    Account password01
  7. [新しいパスワード] と [パスワードの確認] ボックスにそれぞれ同じパスワードを入力して、[パスワードの作成] ボタンをクリックします。

    元に戻す画像を拡大する
    Account password02

Windows Update から Microsoft Update への切り替え

次に、Windows Update から Microsoft Update への切り替えを行います。
  1. 現在のユーザー (この例では "太郎") からログオフします。

    元に戻す画像を拡大する
    vista startmenu logoff
  2. 管理者権限を持ち、アカウント名が半角文字であるユーザーでログインします。
    この例では、"Taro" でログインします。
  3. [スタート]
    元に戻す画像を拡大する
    vistastartbutton
    ボタンをクリックし、[すべてのプログラム] をクリックします。

    元に戻す画像を拡大する
    vista startmenu allprograms
  4. [Windows Update] をクリックします。

    元に戻す画像を拡大する
    vista startmenu windowsupdate
  5. [他の製品の更新プログラムを取得します] をクリックします (インターネットへの接続が行われます)。

    元に戻す画像を拡大する
    vista windowsupdate other
  6. [使用条件に同意します。] チェック ボックスをオンにして、[インストール] ボタンをクリックします。
    元に戻す画像を拡大する
    securityshield
    ユーザー アカウント制御のダイアログが表示されるので、[続行] をクリックします。

    元に戻す画像を拡大する
    vista msupdate eula
  7. 以下の画面が表示されれば、Microsoft Update のインストールは完了です。
    インストールが完了したら、これまでの全角文字のユーザでログインして Microsoft Update を実行することが可能です。

    元に戻す画像を拡大する
    Vista MSUpdate Installed


    元に戻す画像を拡大する
    Vista WindowsUpdate wMSU

作業用に作成したユーザー アカウントの削除

Microsoft Update のインストールが完了したら、最後に作業用に作成したユーザー アカウントを削除します。
  1. Microsoft Update のインストールが完了したら、ログオフします。
    この例では、"Taro" からログオフします。
  2. もとの全角文字ユーザー ("太郎") でログインします。
  3. [スタート]
    元に戻す画像を拡大する
    vistastartbutton
    ボタンをクリックし、[コントロールパネル] をクリックして、[ユーザーアカウントの追加または削除]をクリックします。
  4. 削除するユーザーをクリックして選択します。
    この例では、"Taro" を選択します。

    元に戻す画像を拡大する
    vista selecttaro
  5. [アカウントの削除] をクリックします。

    元に戻す画像を拡大する
    vista deleteaccount01
  6. [ファイルの削除] をクリックします。

    元に戻す画像を拡大する
    vista deletefiles
  7. [アカウントの削除] をクリックします。

    元に戻す画像を拡大する
    Vista DeleteAccount

状況

マイクロソフトでは、この問題について現在調査中です。詳細については、わかりしだいこの資料に掲載する予定です。

関連情報

関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
922708 Windows Vista でのユーザー アカウント制御 (UAC) の使用方法
930229 "続行するにはあなたの許可が必要です" などのユーザー アカウント制御のメッセージが表示される

プロパティ

文書番号: 933528 - 最終更新日: 2010年9月14日 - リビジョン: 2.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows Update
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Microsoft Update
キーワード: 
kbharmony kbexpertiseinter kbexpertisebeginner kbtshoot kbprb KB933528
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック