Article ID: 933565 - Last Review: August 30, 2007 - Revision: 2.5

When you try to use Windows Photo Gallery or Windows Explorer to add metadata to a Canon RAW file on a Windows Vista-based computer, the file is corrupted

Expand all | Collapse all

SYMPTOMS

When you try to use Windows Photo Gallery or Windows Explorer to add metadata to a Canon RAW file on a Windows Vista-based computer, the file is corrupted. In this case, the Canon RAW file has a .tif file name extension.

CAUSE

This problem occurs if the following conditions are true:
  • The Canon RAW file was created by using a 1D camera model or a 1Ds camera model from Canon, Inc.
  • The Canon RAW codec is not installed in Windows Vista.
Files that are created by the 1D camera model or by the 1Ds camera model appear to be standard TIFF files. The Windows Imaging Component invokes the standard TIFF codec to handle the files. However, the RAW files are interpreted differently by the Canon RAW codec. Therefore, the TIFF codec cannot handle the RAW files correctly.

WORKAROUND

To work around this problem, do not use Windows Photo Gallery or Windows Explorer to do the following:
  • Import Canon RAW files.
  • Add metadata to Canon RAW files that have a .tif file name extension and that were created by a 1D camera model or by a 1Ds camera model.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Microsoft is currently developing a hotfix for this problem. The hotfix will prevent Canon RAW files from being opened by the standard TIFF codec and will prevent any chance of data loss. The hotfix will be available from Windows Update.

Canon is currently developing the Canon RAW codec for Windows Vista. When the Canon RAW codec for Windows Vista becomes available, you can use Windows Photo Gallery to add metadata to RAW files that are created by a 1D model camera or by a 1Ds model camera.

For information about your hardware manufacturer, visit the following Web site:
http://support.microsoft.com/gp/vendors/en-us (http://support.microsoft.com/gp/vendors/en-us)
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

APPLIES TO
  • Windows Live Photo Gallery
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Microsoft Windows XP Home Edition SP2
Keywords: 
kbwinliveportal kbexpertisebeginner kbnofix kbtshoot kbprb KB933565
 

Article Translations

 

Related Support Centers