Help and Support

UMDF User-mode drivers that use the Windows SideShow class extension return errors when you process commands asynchronously

Article ID:933607
Last Review:August 29, 2007
Revision:2.1
On This Page

SYMPTOMS

When a User-Mode Driver Framework (UMDF) driver that uses the Windows SideShow class extension processes a command asynchronously, the class extension may return a false error without fully processing the command. This problem may occur when the incoming input/output control (IOCTL) is not passed to the class extension component immediately. This problem may also occur when the IOCTL is from a sequential queue.

Back to the top

CAUSE

This problem occurs if the developer’s driver impersonates outside the scope of the original OnXxx callback. When this happens, the impersonation fails. This failure can cause the driver to return an incorrect error. To correctly handle incoming IOCTLs, the SideShow class extension component requires successful use of impersonation.

Back to the top

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem, submit a request to Microsoft Online Customer Services to obtain the hotfix. To submit an online request to obtain the hotfix, visit the following Microsoft Web site:
http://go.microsoft.com/?linkid=6294451 (http://go.microsoft.com/?linkid=6294451)
Note If additional issues occur or any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. To create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement Information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Vista, 32-bit versions

File nameFile versionFile sizeDateTimePlatform
Wudfcoinstaller.dll6.0.6000.2054687,55228-Feb-200703:08x86
Wudfhost.exe6.0.6000.20546144,38428-Feb-200702:14x86
Wudfpf.sys6.0.6000.2054652,22428-Feb-200702:14x86
Wudfplatform.dll6.0.6000.20546181,76028-Feb-200703:08x86
Wudfrd.sys6.0.6000.2054682,68828-Feb-200702:14Not Applicable
Wudfsvc.dll6.0.6000.2054655,29628-Feb-200703:08x86
Wudfx.dll6.0.6000.20546310,78428-Feb-200703:08x86
Wudfx.mofNot Applicable48,26207-Jan-200705:46Not Applicable
Wudfxuninstall.mofNot Applicable47507-Jan-200705:46Not Applicable

Windows Vista, 64-bit versions

File nameFile versionFile sizeDateTimePlatform
Wudfcoinstaller.dll6.0.6000.2054689,60028-Feb-200704:20x64
Wudfhost.exe6.0.6000.20546168,44828-Feb-200702:34x64
Wudfpf.sys6.0.6000.2054665,02428-Feb-200702:34x64
Wudfplatform.dll6.0.6000.20546202,75228-Feb-200704:20x64
Wudfrd.sys6.0.6000.20546108,03228-Feb-200702:34x64
Wudfsvc.dll6.0.6000.2054666,56028-Feb-200704:20x64
Wudfx.dll6.0.6000.20546382,97628-Feb-200704:20x64
Wudfx.mofNot Applicable48,26207-Jan-200705:46Not Applicable
Wudfxuninstall.mofNot Applicable47507-Jan-200705:46Not Applicable

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Back to the top

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

Back to the top


APPLIES TO
Windows Vista Ultimate
Windows Vista Ultimate 64-bit Edition
Windows Vista Business
Windows Vista Business 64-bit Edition
Windows Vista Home Premium
Windows Vista Home Premium 64-bit Edition
Windows Vista Enterprise
Windows Vista Enterprise 64-bit Edition

Back to the top

Keywords: 
kbvistasp1fix kbwinvistapostrtmfix kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB933607

Back to the top

Article Translations

 

Other Support Options

  • Contact Microsoft
    Phone Numbers, Support Options and Pricing, Online Help, and more.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.