Todos los archivos inesperadamente se quitan de la carpeta Mis documentos local cuando inicia sesión en un equipo basado en Windows XP

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Síntomas

Cuando el equipo se conecta a una red y iniciar sesión en un equipo basado en Windows XP, todos los archivos se quitan inesperadamente de la carpeta Mis documentos local. Estos archivos no se restaurarán hasta que se sincronice el documentos local carpeta.

Observe este problema si se cumplen las condiciones siguientes:
  • El complemento Directiva Maker está instalado en el equipo.
  • La carpeta Mis documentos se redirige a una carpeta compartida mediante la característica de redirección de carpeta.
  • La opción archivos sin conexión está habilitada para la carpeta Mis documentos.
  • El equipo está trabajando en modo sin conexión.

Causa

Este problema se produce cuando la ubicación de carpeta de documentos desde la siguiente subclave del registro de consultas de caché de cliente (CSC):
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
Cuando CSC consulta la subclave del registro para extraer la ruta de acceso de la carpeta local Mis documentos, CSC encuentra que el valor personal del usuario está establecido en null mediante el complemento de directiva Maker - en. Cuando el valor personal del usuario se establece en null, CSC cree que el equipo local carpeta Mis documentos no está disponible. Por lo tanto, CSC borra la memoria de caché sin conexión local de la carpeta Mis documentos local.

Solución

Después de instalar este hotfix, la ruta de acceso de la carpeta Mis documentos se almacena en el registro siguiente:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener instalado Microsoft Windows XP Service Pack 2 (SP2).

Requisito de reinicio

Tendrá que reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows XP con Service Pack 2

Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Cscui.dll5.1.2600.3103326,65619-Mar-200708: 06x 86

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Cuando se produce este problema, se genera la siguiente pila de llamadas.

Salida de la pila

0:036> kb
ChildEBP RetAddr Args to Child 
0693dfdc 7c9eeee8 00000000 7c9c7a04 00000000 shell32!_GetFolderPath+0x6d
0693e008 7c9f1c17 00000000 7c9c7a04 00000000 shell32!_GetFolderPathCached+0x93
0693e24c 7c9f1b7e 00000000 7c9c7a04 00000000 shell32!_CreateFolderIDList+0xe0
0693e274 7c9ef455 00000000 ffffffff 00001000 shell32!_GetFolderIDListCached+0x84
0693e298 7ca26638 00000000 00001005 00000000 shell32!SHGetFolderLocation+0x9e
0693e2cc 7ca2668c 00000000 00000000 01ef1318 shell32!_ReparentAliases+0x49
0693e2e8 7ca266d7 01ef1318 0693e340 0000ffff shell32!SHILAliasTranslate+0x17
0693e324 7c9ede50 00e1ec00 00000000 05564f68 shell32!CDesktopFolder::ParseDisplayName+0xbe
0693e38c 7c9edd9d 00e252e8 00000000 05564f68 shell32!CRegFolder::ParseDisplayName+0x93
0693e3c4 7c9ee336 05564f68 00000000 00000000 shell32!SHParseDisplayName+0xa3
0693e3e8 7ca23b6d 0693ebb0 00000000 00000000 shell32!ILCreateFromPathEx+0x3d
0693e874 7ca41047 00000000 0693ebb0 00000001 shell32!CShellLink::_SetPIDLPath+0x44
0693efc4 064f1cc5 01dc7984 066124b0 0693f718 shell32!CShellLink::SetPath+0x164
0693f174 06523313 0665d598 00000000 00000000 polprocl!apmConfigShortcut::Expand+0x725
0693f254 00000000 00000000 00000000 00000000 polprocl!apmClientConfigs::handleProps+0x283

0:036> r
eax=80070005 ebx=00000000 ecx=0000347b edx=00000015 esi=0693e040 edi=7c9c7a04
eip=7ca23f0e esp=0693dfd0 ebp=0693dfdc iopl=0 nv up ei pl zr na pe nc
cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00000246
shell32!_GetFolderPath+0x6d:
7ca23f0e 8bd8 mov ebx,eax
0:036> !gle
LastErrorValue: (Win32) 0x5 (5) - Access is denied.
LastStatusValue: (NTSTATUS) 0xc0000022 - {Access Denied} A process has requested access to an object, but has not been granted those access rights.

Propiedades

Id. de artículo: 933684 - Última revisión: miércoles, 29 de agosto de 2007 - Versión: 2.1
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Palabras clave: 
kbmt kbautohotfix kbexpertisebeginner kbhotfixserver kbqfe KB933684 KbMtes
Traducción automática
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Haga clic aquí para ver el artículo original (en inglés): 933684

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