Tous les fichiers sont supprimés inattendue du dossier Mes documents local lorsque vous ouvrez une session sur un ordinateur Windows XP

Traductions disponibles Traductions disponibles
Numéro d'article: 933684 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous vous connectez l'ordinateur Windows XP à un réseau et ouvrez une session sur un ordinateur Windows XP, tous les fichiers sont inattendue supprimés du dossier Mes documents local. Ces fichiers ne sont pas restaurées jusqu'à ce que vous synchronisez les Mes documents local dossier.

Vous rencontrer ce problème si les conditions suivantes sont remplies :
  • Le composant logiciel enfichable Stratégie de création est installé sur l'ordinateur.
  • Le dossier Mes documents est redirigé vers un dossier partagé à l'aide de la fonctionnalité redirection dossier.
  • L'option fichiers hors connexion est activée pour le dossier Mes documents.
  • L'ordinateur fonctionne en mode hors connexion.

Cause

Ce problème se produit lorsque la mise en cache côté client (CSC) interroge l'emplacement du dossier Mes documents de la sous-clé de Registre suivante :
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
Lorsque CSC interroge la sous-clé de Registre pour extraire le chemin du dossier Mes documents local, CSC trouve que la valeur personnel de l'utilisateur est définie à null par le composant Création de stratégie - in. Lorsque la valeur personnel de l'utilisateur est définie à null, CSC pense que locale mon dossier de documents n'est pas disponible. Par conséquent, CSC efface le cache local en mode hors connexion pour le dossier Mes documents local.

Résolution

Après avoir installé ce correctif, le chemin d'accès du dossier Mes documents est stocké dans le Registre suivant :
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Informations sur le correctif

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.

Conditions préalables

Pour appliquer ce correctif, vous devez être Microsoft Windows XP Service Pack 2 (SP2) installé.

Demande de redémarrage

Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations sur le remplacement de correctif

Ce correctif ne remplace aucun autre correctif.

Informations de fichier

La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'élément Date et heure du Panneau de configuration.
Windows XP avec Service Pack 2

Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille de fichierDateHeurePlate-forme
Cscui.dll5.1.2600.3103326,65619-Mar-200706:08x 86

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Lorsque ce problème se produit, la pile d'appel suivante est générée.

Sortie de pile

0:036> kb
ChildEBP RetAddr Args to Child 
0693dfdc 7c9eeee8 00000000 7c9c7a04 00000000 shell32!_GetFolderPath+0x6d
0693e008 7c9f1c17 00000000 7c9c7a04 00000000 shell32!_GetFolderPathCached+0x93
0693e24c 7c9f1b7e 00000000 7c9c7a04 00000000 shell32!_CreateFolderIDList+0xe0
0693e274 7c9ef455 00000000 ffffffff 00001000 shell32!_GetFolderIDListCached+0x84
0693e298 7ca26638 00000000 00001005 00000000 shell32!SHGetFolderLocation+0x9e
0693e2cc 7ca2668c 00000000 00000000 01ef1318 shell32!_ReparentAliases+0x49
0693e2e8 7ca266d7 01ef1318 0693e340 0000ffff shell32!SHILAliasTranslate+0x17
0693e324 7c9ede50 00e1ec00 00000000 05564f68 shell32!CDesktopFolder::ParseDisplayName+0xbe
0693e38c 7c9edd9d 00e252e8 00000000 05564f68 shell32!CRegFolder::ParseDisplayName+0x93
0693e3c4 7c9ee336 05564f68 00000000 00000000 shell32!SHParseDisplayName+0xa3
0693e3e8 7ca23b6d 0693ebb0 00000000 00000000 shell32!ILCreateFromPathEx+0x3d
0693e874 7ca41047 00000000 0693ebb0 00000001 shell32!CShellLink::_SetPIDLPath+0x44
0693efc4 064f1cc5 01dc7984 066124b0 0693f718 shell32!CShellLink::SetPath+0x164
0693f174 06523313 0665d598 00000000 00000000 polprocl!apmConfigShortcut::Expand+0x725
0693f254 00000000 00000000 00000000 00000000 polprocl!apmClientConfigs::handleProps+0x283

0:036> r
eax=80070005 ebx=00000000 ecx=0000347b edx=00000015 esi=0693e040 edi=7c9c7a04
eip=7ca23f0e esp=0693dfd0 ebp=0693dfdc iopl=0 nv up ei pl zr na pe nc
cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00000246
shell32!_GetFolderPath+0x6d:
7ca23f0e 8bd8 mov ebx,eax
0:036> !gle
LastErrorValue: (Win32) 0x5 (5) - Access is denied.
LastStatusValue: (NTSTATUS) 0xc0000022 - {Access Denied} A process has requested access to an object, but has not been granted those access rights.

Propriétés

Numéro d'article: 933684 - Dernière mise à jour: mercredi 29 août 2007 - Version: 2.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Édition familiale
Mots-clés : 
kbmt kbautohotfix kbexpertisebeginner kbhotfixserver kbqfe KB933684 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 933684
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com