Informazioni su Network Monitor 3

Traduzione articoli Traduzione articoli
Identificativo articolo: 933741 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

INTRODUZIONE

In questo articolo contiene informazioni su Microsoft Network Monitor 3. Network Monitor 3 Ŕ un analizzatore di protocollo. Consente di acquisire, visualizzare e analizzare i dati di rete. Consente di risolvere i problemi con le applicazioni in rete.

In questo articolo contiene download e informazioni di supporto, note di installazione e informazioni generiche sull'utilizzo sul Monitor di rete 3. Network Monitor 3.4 Ŕ la versione pi¨ recente.

Informazioni

Network Monitor 3 Ŕ una revisione completa di Network Monitor 2 precedenti.x versione. Alcune delle funzionalitÓ principali di Monitor di rete 3 comprendono:
  • Modello parser basato su script con aggiornamenti frequenti
  • Sessioni simultanee acquisizione live
  • Supporto per Windows 7
  • Supporto per piattaforme a 32 bit e piattaforme a 64 bit
  • Supporto per le conversazioni di rete e il processo di rilevamento
  • API per accedere a acquisizione e il motore di analisi
  • Wireless Monitor modalitÓ acquisizione

Download e informazioni di supporto

Per scaricare l'ultima versione di Network Monitor, Network Monitor 3.4, visitare il seguente sito Web Microsoft:
http://go.microsoft.com/fwlink/?LinkId=103158&clcid=0x409
Informazioni di supporto per 3.4 del Monitor di rete si trova nel forum Microsoft TechNet seguente:

http://go.microsoft.com/fwlink/?LinkId=151800

Note sull'installazione

Network Monitor 3.4 pu˛ coesistere con Network Monitor 2. x. Per impostazione predefinita, viene installato Network Monitor 3.4 nel "3" cartella di programma Files%\Microsoft Network Monitor %. Pertanto, non si verifichino conflitti se Ŕ installata una versione precedente in una cartella diversa sul computer. Durante l'installazione di Network Monitor 3.4, qualsiasi versione precedente di Monitor di rete 3 viene disinstallato.

Network Monitor 3.4 include un nuovo driver per Windows Vista, Windows Server 2008 e Windows 7. Questo nuovo driver supporta le nuove funzionalitÓ del driver NDIS Network Driver Interface Specification () 6.0. Se si utilizzano strumenti che si basano su Network Monitor 2.x NPPTools, gli strumenti non funzioneranno pi¨. Per acquisire i dati di rete in Windows Vista, Ŕ necessario utilizzare Network Monitor 3.4. Network Monitor 2.x non acquisire i dati di rete correttamente in Windows Vista.

Hardware consigliati per eseguire Network Monitor 3.4 Ŕ elencato come segue:
  • Processore 1 GHz o superiore
  • 1 GB di memoria
  • 60 MB di spazio disponibile sul disco rigido e lo spazio su disco per memorizzare i file di acquisizione
3.4 di Network Monitor Ŕ supportato nei sistemi operativi seguenti:
  • Windows 7
  • Windows Server 2008
  • Windows Vista
  • Windows XP
  • Windows Server 2003
Avvisi e avvertenze

Attualmente, si sconsiglia di eseguire Network Monitor 3 sui sistemi di produzione in cui il carico aggiuntivo potrebbe influire sull'esecuzione. In scenari in cui il carico Ŕ un elemento da prendere in considerazione, Ŕ possibile utilizzare la versione della riga di comando di Monitor di rete 3 per acquisire i dati di rete. La versione della riga di comando Ŕ Nmcap.exe. Per ulteriori informazioni su Nmcap.exe, vedere la sezione "Strumento della riga di comando Nmcap.exe".

Network Monitor 3 potrebbe consumare grandi quantitÓ di risorse di sistema. Di seguito sono riportati alcuni aspetti da considerare.
  • Spazio su disco

    Quando si avvia una sessione di acquisizione, Network Monitor 3 memorizza fotogrammi in una sequenza di file di acquisizione che si trovano nella cartella \Temp. Per impostazione predefinita, la dimensione di ogni file Ŕ di 20 MB. Per impostazione predefinita, se non si interrompe la sessione di acquisizione, Network Monitor 3 continua a memorizzare i file di acquisizione nella cartella \Temp fino a quando lo spazio disponibile sul disco rigido del computer Ŕ inferiore al 2%. Quindi, Monitor di rete 3 interrompe la sessione di acquisizione.

    ╚ possibile configurare la dimensione del file di acquisizione, la posizione in cui sono archiviati i file di acquisizione, il limite di spazio disponibile su disco rigido e altre opzioni di acquisizione. A tale scopo, dal menu Strumenti , scegliere Opzionie quindi fare clic sulla scheda di acquisizione .
  • Utilizzo della memoria

    Oltre a acquisizione dei dati, Monitor di rete 3 assegna le proprietÓ di frame e quindi vengono utilizzate le proprietÓ per raggruppare i fotogrammi in conversazioni. Network Monitor 3 consente di visualizzare le conversazioni e le cornici associate in una struttura ad albero nel riquadro delle Conversazioni di rete .

    La funzionalitÓ di conversazioni di Monitor di rete 3 aumenta notevolmente l'utilizzo della memoria. Ci˛ pu˛ causare il blocco del computer. Per impostazione predefinita, la funzionalitÓ di conversazioni Ŕ attivata. Alcuni filtri protocollo di livello superiore richiedono proprietÓ di conversazione. Per disattivare la funzionalitÓ di conversazioni, scegliere Opzioni dal menu Strumenti , fare clic sulla scheda di acquisizione e quindi fare clic per deselezionare la casella di controllo Abilita le conversazioni .
  • Utilizzo del processore

    La funzionalitÓ di conversazioni di Monitor di rete 3 pu˛ aumentare notevolmente l'utilizzo del processore durante l'elaborazione di grandi quantitÓ di frame. Per impostazione predefinita, la funzionalitÓ di conversazioni Ŕ disattivata, come indicato nella sezione "Utilizzo della memoria".

Utilizzo generale

Informazioni generali sull'utilizzo di Monitor di rete 3 sono elencati come indicato di seguito.
  • Acquisire i dati di rete

    Come accennato in precedenza, Monitor di rete 3 potrebbe utilizzare grandi quantitÓ di risorse di sistema. Pertanto, se si desidera ridurre al minimo l'effetto sulle risorse di sistema che possono verificarsi quando si utilizza Monitor di rete 3 per acquisire i dati, utilizzare lo strumento della riga di comando Nmcap.exe per acquisire i dati.

    Network Monitor 3 consente di raccogliere dati di rete e visualizzare i dati di rete in tempo reale, come i dati vengono acquisiti. Per avviare una sessione di acquisizione in Monitor di rete 3, fare clic sulla scheda Pagina iniziale , fare clic su Crea una nuova scheda di acquisizionee quindi fare clic sul pulsante Avvia acquisizione oppure premere F10.
  • Filtri

    Network Monitor 3 utilizza una sintassi semplice che Ŕ basato sull'espressione di filtro frame. All'utente vengono visualizzati tutti i frame che corrispondono all'espressione. Per ulteriori informazioni sui filtri, effettuare una delle seguenti operazioni:
    • Visualizzare gli argomenti disponibili nella sezione "Utilizzo di filtri" del manuale dell'utente di Network Monitor 3. A tale scopo, dal menu ? , scegliere Sommario e SDKe quindi fare doppio clic sull'Utilizzo di filtri.
    • Dal menu ? , scegliere ricerca per categoriee quindi fare clic su Usa filtri.
    • Utilizzare la scheda di Filtro di acquisizione o il Filtro di visualizzazione per visualizzare i filtri standard.
  • Conversazioni

    Per impostazione predefinita, la funzionalitÓ di conversazioni Ŕ ora attivata. La funzionalitÓ di conversazioni pu˛ occupare molta memoria, soprattutto in scenari di acquisire i dati per lunghi periodi di tempo. Per disattivare la funzionalitÓ di conversazioni, scegliere Opzioni dal menu Strumenti , fare clic per deselezionare la casella di controllo Abilita le conversazioni nella scheda di acquisizione .

    Quando Ŕ attivata la funzionalitÓ di conversazioni, cornici vengono raggruppati e visualizzati nel riquadro di Conversazioni di rete in una struttura ad albero secondo le conversazioni a cui appartengono, con le informazioni sul processo. Ad esempio, i dati TCP che utilizza la stessa porta di origine e la stessa porta di destinazione sono organizzati in un gruppo. Quando si fa clic su un nodo nel riquadro delle Conversazioni di rete , ai fotogrammi nel riquadro Riepilogo della cornice viene applicato automaticamente il filtro corrispondente di conversazione. Vengono visualizzati solo i fotogrammi che appartengono a quel particolare conversazione.
  • Strumento della riga di comando Nmcap.exe

    Lo strumento della riga di comando Nmcap.exe consente di configurare quando si desidera avviare una sessione di acquisizione o di interrompere una sessione di acquisizione. Inoltre, Ŕ possibile utilizzare lo strumento della riga di comando Nmcap.exe per creare le acquisizioni concatenate. Acquisizioni concatenate consentono di creare pi¨ file di acquisizione. Tuttavia, la dimensione dei file di acquisizione rimane piccola. Attualmente, NMCap Impossibile salvare le informazioni di processo.
  • Rete durante l'analisi del linguaggio (NPL)

    Network Monitor 3 parser sono scritti in un linguaggio in modo specifico per rendere pi¨ semplice lo sviluppo di parser. Fornisce inoltre un livello di protezione contro lo sfruttamento di potenziale da codice dannoso che potrebbe verificarsi se il parser sono stati creati come file DLL. NPL fornisce l'accesso al parser. ╚ possibile visualizzare o modificare i parser inclusi in Monitor di rete 3.

Problemi comuni

I problemi comuni includono:
  • Protocolli non possono essere analizzate correttamente. Questo problema pu˛ verificarsi se si verifica una delle seguenti condizioni:
    • La funzionalitÓ di conversazioni Ŕ disattivata.

      Alcuni protocolli dipendono dalle proprietÓ di conversazione per memorizzare i valori di stato che possono rivelarsi necessarie in fotogrammi successivi. Ad esempio, TCP deve conversazioni per memorizzare informazioni sui frame ritrasmessi. Il filtro per TCP ritrasmetterÓ non funzionerÓ a meno che non Ŕ abilitata la funzionalitÓ di conversazioni.

      Allo stesso modo, il protocollo Server Message Block (SMB) Ŕ possibile convertire la risposta a un comando di Transact, poichÚ la risposta non contiene il comando originale. Le informazioni vengono salvate nelle proprietÓ di conversazione.
    • Parser completo pu˛ non essere abilitato. Per impostazione predefinita, Ŕ possibile attivare un sottoinsieme di parser di completo per motivi di prestazioni. Per attivare l'insieme completo, attenersi alla seguente procedura:
      1. Scegliere Opzionidal menu Strumenti .
      2. Fare clic sulla scheda Parser .
      3. Selezionare la riga di Windows e quindi fare clic sul pulsante di stub fino a quando la colonna impostare Visualizza completo.
  • Viene visualizzato uno dei seguenti messaggi di errore quando si esegue Monitor di rete 3 su un computer basato su Windows Vista:
    Nessuna delle schede di rete sono associata al driver Netmon
    Questa scheda di rete non Ŕ configurata per l'acquisizione di Network Monitor
    Questo problema si verifica se si verifica una delle seguenti condizioni:
    • Monitor di rete 3 non si esegue come amministratore.
    • Non Ŕ un membro del gruppo Users Netmon.
    Durante l'installazione di Monitor di rete 3 in Windows Vista o versioni successive, Ŕ necessario aggiungere l'account di programmi di installazione al gruppo utenti Netmon. Ma questo non ha effetto fino a quando non si disconnette e quindi nuovamente. Se Ŕ necessario acquisire un'immediatamente, Ŕ possibile eseguire Monitor di rete 3 come amministratore.

    Per ulteriori informazioni, vedere che il Monitor di rete 3 rilascia note o l'argomento "Funziona su Windows Vista" nella Guida di Network Monitor 3.

Riferimenti

Per informazioni di supporto su Monitor di rete 3, visitare i seguenti siti Web Microsoft:
Forum TechNet su Monitor di rete
Blog di Monitor di rete e la pagina di destinazione
Parser Open Source di Network Monitor
Strumenti di analisi degli esperti di Network Monitor

ProprietÓ

Identificativo articolo: 933741 - Ultima modifica: mercoledý 20 agosto 2014 - Revisione: 12.0
Le informazioni in questo articolo si applicano a:
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Web Server 2008
  • Windows 7 Beta
Chiavi:á
kbhowto kbinfo kbexpertiseinter kbmt KB933741 KbMtit
Traduzione automatica articoli
IMPORTANTE: il presente articolo Ŕ stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l?obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre Ŕ perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilitÓ per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualitÓ della traduzione.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 933741
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com