On a computer that is running Windows Vista, all the check boxes on the Supported Formats tab of an installed device are unexpectedly selected

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Article ID: 933750 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario. On a computer that is running Windows Vista, you open the Sound item in Control Panel. Then, you open the Properties dialog box for an installed device that uses one of the following interface formats:
  • High-Definition Multimedia Interface (HDMI)
  • Sony/Philips Digital Interface (S/PDIF)
However, when you click the Supported Formats tab in the Properties dialog box for the device, you notice that all the check boxes are unexpectedly selected. For example, the following check boxes are selected:
  • DTS Audio
  • Dolby Digital
  • Microsoft WMA Audio
  • 44.1 KHz
  • 48.0 KHz
  • 88.2 KHz
  • 96.0 KHz
  • 176.4 KHz
  • 192.0 KHz
You experience this problem even though the following conditions are true:
  • You did not select all the check boxes.
  • The device does not support all these selected formats.
When this problem occurs, you may not receive sound from the device.

CAUSE

This problem occurs in the following scenario:
  1. After you click the Supported Formats tab for the device, you click another tab in the Properties dialog box. Then, you click Cancel.
  2. You reopen the Properties dialog box for the device, and then you click the Supported Formats tab again.
In this scenario, the settings that were previously configured on the Supported Formats tab are not maintained. Windows Vista incorrectly selects all the check boxes.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Update.mumNot Applicable1,77727-Mar-200710:48Not Applicable
X86_ef0de3014ce6ec19287cab7af50b5e0c_31bf3856ad364e35_6.0.6000.20566_none_6e0ed9aa5ea8b5f9.manifestNot Applicable69327-Mar-200710:48Not Applicable
X86_microsoft-windows-mmsys_31bf3856ad364e35_6.0.6000.20566_none_5cd846cdfb4d7108.manifestNot Applicable14,69827-Mar-200710:50Not Applicable
8point1.wavNot Applicable1,228,10007-Jan-200705:29Not Applicable
Ac3.wavNot Applicable1,843,24407-Jan-200705:29Not Applicable
Dts.wavNot Applicable1,851,43607-Jan-200705:29Not Applicable
Mmsys.cpl6.0.6000.205661,085,95227-Mar-200701:45Not Applicable
Wmapro.wavNot Applicable1,777,73207-Jan-200705:29Not Applicable
Windows Vista, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_852dee7dffae810d81f78ee6b19af29b_31bf3856ad364e35_6.0.6000.20566_none_0f44bb94e57ecd85.manifestNot Applicable1,03627-Mar-200710:48Not Applicable
Amd64_microsoft-windows-mmsys_31bf3856ad364e35_6.0.6000.20566_none_b8f6e251b3aae23e.manifestNot Applicable14,72827-Mar-200710:55Not Applicable
Update.mumNot Applicable2,00027-Mar-200710:48Not Applicable
Wow64_microsoft-windows-mmsys_31bf3856ad364e35_6.0.6000.20566_none_c34b8ca3e80ba439.manifestNot Applicable11,59627-Mar-200710:55Not Applicable
8point1.wavNot Applicable1,228,10007-Jan-200705:29Not Applicable
Ac3.wavNot Applicable1,843,24407-Jan-200705:29Not Applicable
Dts.wavNot Applicable1,851,43607-Jan-200705:29Not Applicable
Mmsys.cpl6.0.6000.205661,045,50427-Mar-200702:59Not Applicable
Wmapro.wavNot Applicable1,777,73207-Jan-200705:29Not Applicable
8point1.wavNot Applicable1,228,10007-Jan-200705:29Not Applicable
Mmsys.cpl6.0.6000.205661,085,95227-Mar-200701:45Not Applicable

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Properties

Article ID: 933750 - Last Review: October 8, 2011 - Revision: 4.0
APPLIES TO
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Business 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Starter
Keywords: 
kbautohotfix kbvistasp1fix kbwinvistapostrtmfix kbfix kbbug kbhotfixserver kbqfe kbexpertisebeginner KB933750

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