Podczas wznawiania pracy komputera z systemem Windows Vista z trybu uśpienia ustawienie bramy domyślnej jest tracone

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 933872 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Symptomy

Podczas wznawiania pracy komputera z systemem Windows Vista ze stanu uśpienia ustawienie bramy domyślnej jest tracone. Podczas uruchamiania polecenia ipconfig /all w celu wyświetlania konfiguracji IP ustawienie bramy domyślnej nie jest widoczne.

Ten problem występuje, jeżeli są spełnione następujące warunki:
  • Komputer jest skonfigurowany jako klient DHCP (Dynamic Host Configuration Protocol) i połączony z serwerem DHCP.
  • Serwer DHCP konfiguruje zakres razem z opcjami 3 i 249.
  • Komputer jest uwzględniony w tym zakresie.

Przyczyna

Po wznowieniu pracy komputera ze stanu uśpienia usługa klienta DHCP (Dhcpcsvc.dll) jest zobowiązana do przekazywania do stosu protokołu IP informacji związanych z routingiem. Informacje związane z routingiem są przechowywane w interfejsie magazynu sieciowego. Ten problem występuje wówczas, gdy interfejs magazynu sieciowego ma już informacje związane z routingiem, które usługa klienta DHCP chce zapisać. W przypadku niepowodzenia operacji zapisywania wszystkie związane z routingiem informacje przechowywane w interfejsie magazynu sieciowego (NSI) są tracone. Komputer traci więc wszystkie informacje związane z routingiem. Dotyczy to również bramy domyślnej.

Rozwiązanie

Informacje dotyczące aktualizacji

Poniższe pliki są udostępnione do pobrania w Centrum pobierania Microsoft:

Windows Vista, wersje z procesorem x86
Zwiń ten obrazekRozwiń ten obrazek
Pobierz
Pobierz pakiet aktualizacji dla wersji systemu Windows Vista przeznaczonych dla komputerów z procesorami x86 (KB933872) teraz.
Windows Vista, wersje 64-bitowe
Zwiń ten obrazekRozwiń ten obrazek
Pobierz
Pobierz pakiet aktualizacji dla 64-bitowych wersji systemu Windows Vista (KB933872) teraz.


Data wydania: 24 kwietnia 2007

Aby uzyskać więcej informacji dotyczących sposobu pobierania plików pomocy technicznej firmy Microsoft, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
119591 Jak uzyskać pliki Pomocy technicznej Microsoft w usługach online
Firma Microsoft przeskanowała ten plik w poszukiwaniu wirusów. Firma Microsoft użyła najnowszego oprogramowania do wykrywania wirusów dostępnego w dniu opublikowania pliku. Plik jest przechowywany na serwerach o podwyższonym poziomie zabezpieczeń, które utrudniają wprowadzanie nieautoryzowanych zmian w pliku.

Informacje dotyczące poprawki

Wymagania wstępne

Nie określono wymagań wstępnych.

Wymagania dotyczące ponownego uruchamiania

Po zastosowaniu tej poprawki należy ponownie uruchomić komputer.

Informacje dotyczące zastępowania poprawek

Ta poprawka nie zastępuje żadnych innych poprawek.

Informacje dotyczące rejestru

Aby skorzystać z tej poprawki, nie trzeba wprowadzać żadnych zmian w rejestrze.

Informacje dotyczące plików

Wersja anglojęzyczna tej poprawki ma atrybuty pliku pokazane w poniższej tabeli (lub nowsze). Daty i godziny odpowiadające tym plikom zostały podane w formacie skoordynowanego czasu uniwersalnego (UTC). Są one zamieniane na czas lokalny po wyświetleniu informacji o pliku. Aby sprawdzić różnicę między czasem UTC i czasem lokalnym, należy skorzystać z karty Strefa czasowa narzędzia Data i godzina w Panelu sterowania.
Windows Vista, wersje 32-bitowe
Zwiń tę tabelęRozwiń tę tabelę
Nazwa plikuWersja plikuRozmiar plikuDataGodzinaPlatforma
Dhcpcmonitor.dll6.0.6000.2055410 24010-mar-200702:47x86
Dhcpcsvc.dll6.0.6000.20554204 80010-mar-200702:47x86
Dhcpcsvc6.dll6.0.6000.20554120 32010-mar-200702:47x86
Windows Vista, wersje 64-bitowe
Zwiń tę tabelęRozwiń tę tabelę
Nazwa plikuWersja plikuRozmiar plikuDataGodzinaPlatforma
Dhcpcmonitor.dll6.0.6000.2055412 28810-mar-200703:58x64
Dhcpcsvc.dll6.0.6000.20554271 36010-mar-200703:58x64
Dhcpcsvc6.dll6.0.6000.20554150 52810-mar-200703:58x64

Obejście problemu

W celu obejścia tego problemu należy uruchamiać polecenie ipconfig /renew za każdym razem, gdy praca komputera jest wznawiana ze stanu uśpienia.

Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych w sekcji „Informacje zawarte w tym artykule dotyczą” .

Więcej informacji

Aby uzyskać więcej informacji dotyczących terminologii używanej do opisywania aktualizacji oprogramowania, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
824684 Opis standardowej terminologii używanej do opisywania aktualizacji oprogramowania firmy Microsoft

Właściwości

Numer ID artykułu: 933872 - Ostatnia weryfikacja: 13 grudnia 2007 - Weryfikacja: 3.2
Informacje zawarte w tym artykule dotyczą:
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Starter
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise 64-bit edition
Słowa kluczowe: 
kbvistasp1fix atdownload kbhotfixserver kbpubtypekc kbfix kbexpertiseinter kbqfe KB933872

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com