Les champs que l'événement OnChange activé sont indisponibles dans la fenêtre modifier plusieurs enregistrements dans Microsoft Dynamics CRM 3.0

Traductions disponibles Traductions disponibles
Numéro d'article: 933898 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Symptômes

Lorsque vous modifiez plusieurs enregistrements dans la fenêtre modifier plusieurs enregistrements dans Microsoft Dynamics CRM 3.0, les champs qui ont l'événement OnChange activé sont indisponibles. Ce problème se produit si vous avez installé le correctif cumulatif 1 pour Microsoft Dynamics CRM 3.0.

Cause

Ce problème se produit car Microsoft Dynamics CRM 3.0 désactive les champs qui ont l'événement OnChange activé dans la fenêtre modifier plusieurs enregistrements. Le programme désactive ces champs pour empêcher l'événement OnChange de provoquer des erreurs.

Résolution

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.

Contournement

Pour résoudre ce problème, activez manuellement les champs que l'événement OnChange activé. L'exemple suivant indique comment activer le champ parentaccountid .

Pour activer le champ parentaccountid , procédez comme suit :
  1. Exporter la personnalisation de du compte. Pour ce faire, procédez comme suit :
    1. Dans le client Web Microsoft Dynamics CRM 3.0, cliquez sur Paramètres , cliquez sur Personnalisation et puis cliquez sur Exporter les personnalisations .
    2. Cliquez sur le compte , cliquez sur Exporter les personnalisations sélectionnée dans le menu Actions supplémentaires , cliquez sur OK et puis enregistrez le fichier exporté en tant que fichier AccountCustom.xml.
  2. Ouvrez le fichier AccountCustom.xml en utilisant le bloc-notes.
  3. Dans le fichier AccountCustom.xml, modifier une ligne dans la étiquette description = « compte parent » section comme suit :
    ligne existante
    <event name="onclick" application="true" active="true"> <event name="onchange" application="true" active="true">
    
    remplacez ligne
    <event name="onclick" application="true" active="true" BehaviorInBulkEditForm="Enabled">
    <event name="onchange" application="true" active="true" BehaviorInBulkEditForm="Enabled">
    
  4. Enregistrez le fichier modifié.
  5. Importer le fichier AccountCustom.xml modifié. Pour ce faire, procédez comme suit :
    1. Cliquez sur Paramètres , cliquez sur Personnalisation , puis cliquez sur Importer des personnalisations .
    2. Dans la zone Importer un fichier , entrez le chemin d'accès du fichier AccountCustom.xml modifié et puis cliquez sur Télécharger .
    3. Cliquez sur le compte , puis cliquez sur Importer des personnalisations sélectionnée dans le menu Actions supplémentaires .
  6. Publier les personnalisations. Pour ce faire, procédez comme suit :
    1. Cliquez sur Paramètres , cliquez sur Personnalisation , puis cliquez sur Personnaliser les entités .
    2. Cliquez sur compte , puis cliquez sur Publier .
note Vous pouvez utiliser une procédure similaire pour activer d'autres champs.

Plus d'informations

Pour plus informationUpdate le correctif cumulatif 1 pour Microsoft Dynamics CRM 3.0, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft. :
922815 Update Rollup 1 pour Microsoft Dynamics CRM 3.0 est disponible
Pour plus d'informations sur un problème qui se produit lorsque vous essayez d'en masse modifier dans Microsoft Dynamics CRM 3.0, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
913645 Les champs « compte parent » et « client parent » sont indisponibles lorsque vous essayez d'en masse modifier plusieurs enregistrements de contact ou de plusieurs enregistrements compte dans Microsoft Dynamics CRM 3.0
Pour plus d'informations sur la terminologie utilisée pour décrire les mises à jour logicielles Microsoft, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :
824684 Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft
887283 Package correctif de logiciel Microsoft Business Solutions CRM et mise à jour de normes d'affectation de noms

Propriétés

Numéro d'article: 933898 - Dernière mise à jour: vendredi 13 juillet 2007 - Version: 1.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft CRM 3.0
Mots-clés : 
kbmt kbautohotfix kbhotfixserver kbmbscustomization kbqfe kbmbsmigrate KB933898 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 933898
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com